summaryrefslogtreecommitdiff
path: root/kde-base/kdepim-meta
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-base/kdepim-meta
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-base/kdepim-meta')
-rw-r--r--kde-base/kdepim-meta/kdepim-meta-4.14.10.ebuild43
-rw-r--r--kde-base/kdepim-meta/kdepim-meta-4.14.3.ebuild43
-rw-r--r--kde-base/kdepim-meta/kdepim-meta-4.14.8.ebuild43
-rw-r--r--kde-base/kdepim-meta/kdepim-meta-4.4.11.1-r1.ebuild45
-rw-r--r--kde-base/kdepim-meta/kdepim-meta-4.4.2015.06.ebuild43
-rw-r--r--kde-base/kdepim-meta/metadata.xml8
6 files changed, 225 insertions, 0 deletions
diff --git a/kde-base/kdepim-meta/kdepim-meta-4.14.10.ebuild b/kde-base/kdepim-meta/kdepim-meta-4.14.10.ebuild
new file mode 100644
index 00000000000..f105d1399bc
--- /dev/null
+++ b/kde-base/kdepim-meta/kdepim-meta-4.14.10.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit kde4-meta-pkg
+
+DESCRIPTION="kdepim - merge this to pull in all kdepim-derived packages"
+HOMEPAGE+=" http://community.kde.org/KDE_PIM"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="nls"
+
+RDEPEND="
+ $(add_kdebase_dep akonadiconsole)
+ $(add_kdebase_dep akregator)
+ $(add_kdebase_dep blogilo)
+ $(add_kdebase_dep calendarjanitor)
+ $(add_kdebase_dep kabcclient)
+ $(add_kdebase_dep kaddressbook)
+ $(add_kdebase_dep kalarm)
+ $(add_kdebase_dep kdepim-icons)
+ $(add_kdebase_dep kdepim-kresources)
+ $(add_kdebase_dep kdepim-runtime)
+ $(add_kdebase_dep kjots)
+ $(add_kdebase_dep kleopatra)
+ $(add_kdebase_dep kmail)
+ $(add_kdebase_dep knode)
+ $(add_kdebase_dep knotes)
+ $(add_kdebase_dep konsolekalendar)
+ $(add_kdebase_dep kontact)
+ $(add_kdebase_dep korganizer)
+ $(add_kdebase_dep ktimetracker)
+ $(add_kdebase_dep ktnef)
+ nls? ( || (
+ (
+ $(add_kdeapps_dep kde4-l10n '' 15.04.0)
+ )
+ (
+ $(add_kdeapps_dep kde4-l10n '' 4.14.3)
+ $(add_kdebase_dep kdepim-l10n '' 4.14.3)
+ )
+ ) )
+"
diff --git a/kde-base/kdepim-meta/kdepim-meta-4.14.3.ebuild b/kde-base/kdepim-meta/kdepim-meta-4.14.3.ebuild
new file mode 100644
index 00000000000..49f869cb7b1
--- /dev/null
+++ b/kde-base/kdepim-meta/kdepim-meta-4.14.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit kde4-meta-pkg
+
+DESCRIPTION="kdepim - merge this to pull in all kdepim-derived packages"
+HOMEPAGE+=" http://community.kde.org/KDE_PIM"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="nls"
+
+RDEPEND="
+ $(add_kdebase_dep akonadiconsole)
+ $(add_kdebase_dep akregator)
+ $(add_kdebase_dep blogilo)
+ $(add_kdebase_dep calendarjanitor)
+ $(add_kdebase_dep kabcclient)
+ $(add_kdebase_dep kaddressbook)
+ $(add_kdebase_dep kalarm)
+ $(add_kdebase_dep kdepim-icons)
+ $(add_kdebase_dep kdepim-kresources)
+ $(add_kdebase_dep kdepim-runtime)
+ $(add_kdebase_dep kjots)
+ $(add_kdebase_dep kleopatra)
+ $(add_kdebase_dep kmail)
+ $(add_kdebase_dep knode)
+ $(add_kdebase_dep knotes)
+ $(add_kdebase_dep konsolekalendar)
+ $(add_kdebase_dep kontact)
+ $(add_kdebase_dep korganizer)
+ $(add_kdebase_dep ktimetracker)
+ $(add_kdebase_dep ktnef)
+ nls? ( || (
+ (
+ $(add_kdeapps_dep kde4-l10n '' 15.04.0)
+ )
+ (
+ $(add_kdeapps_dep kde4-l10n '' 4.14.3)
+ $(add_kdebase_dep kdepim-l10n '' 4.14.3)
+ )
+ ) )
+"
diff --git a/kde-base/kdepim-meta/kdepim-meta-4.14.8.ebuild b/kde-base/kdepim-meta/kdepim-meta-4.14.8.ebuild
new file mode 100644
index 00000000000..df565924744
--- /dev/null
+++ b/kde-base/kdepim-meta/kdepim-meta-4.14.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit kde4-meta-pkg
+
+DESCRIPTION="kdepim - merge this to pull in all kdepim-derived packages"
+HOMEPAGE+=" http://community.kde.org/KDE_PIM"
+KEYWORDS="amd64 ~arm ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="nls"
+
+RDEPEND="
+ $(add_kdebase_dep akonadiconsole)
+ $(add_kdebase_dep akregator)
+ $(add_kdebase_dep blogilo)
+ $(add_kdebase_dep calendarjanitor)
+ $(add_kdebase_dep kabcclient)
+ $(add_kdebase_dep kaddressbook)
+ $(add_kdebase_dep kalarm)
+ $(add_kdebase_dep kdepim-icons)
+ $(add_kdebase_dep kdepim-kresources)
+ $(add_kdebase_dep kdepim-runtime)
+ $(add_kdebase_dep kjots)
+ $(add_kdebase_dep kleopatra)
+ $(add_kdebase_dep kmail)
+ $(add_kdebase_dep knode)
+ $(add_kdebase_dep knotes)
+ $(add_kdebase_dep konsolekalendar)
+ $(add_kdebase_dep kontact)
+ $(add_kdebase_dep korganizer)
+ $(add_kdebase_dep ktimetracker)
+ $(add_kdebase_dep ktnef)
+ nls? ( || (
+ (
+ $(add_kdeapps_dep kde4-l10n '' 15.04.0)
+ )
+ (
+ $(add_kdeapps_dep kde4-l10n '' 4.14.3)
+ $(add_kdebase_dep kdepim-l10n '' 4.14.3)
+ )
+ ) )
+"
diff --git a/kde-base/kdepim-meta/kdepim-meta-4.4.11.1-r1.ebuild b/kde-base/kdepim-meta/kdepim-meta-4.4.11.1-r1.ebuild
new file mode 100644
index 00000000000..3a840f3ff03
--- /dev/null
+++ b/kde-base/kdepim-meta/kdepim-meta-4.4.11.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit kde4-meta-pkg
+
+DESCRIPTION="kdepim - merge this to pull in all kdepim-derived packages"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+IUSE="+akonadi nls"
+
+RDEPEND="
+ $(add_kdebase_dep akregator)
+ $(add_kdebase_dep blogilo)
+ $(add_kdebase_dep kabcclient)
+ $(add_kdebase_dep kaddressbook)
+ $(add_kdebase_dep kalarm)
+ $(add_kdebase_dep kdepim-icons)
+ $(add_kdebase_dep kdepim-kresources)
+ $(add_kdebase_dep kdepim-runtime)
+ $(add_kdebase_dep kdepim-strigi-analyzer)
+ $(add_kdebase_dep kdepim-wizards)
+ $(add_kdebase_dep kjots)
+ $(add_kdebase_dep kleopatra)
+ $(add_kdebase_dep kmail)
+ $(add_kdebase_dep knode)
+ $(add_kdebase_dep knotes)
+ $(add_kdebase_dep konsolekalendar)
+ $(add_kdebase_dep kontact)
+ $(add_kdebase_dep korganizer)
+ $(add_kdebase_dep ktimetracker)
+ $(add_kdebase_dep libkdepim)
+ $(add_kdebase_dep libkleo)
+ $(add_kdebase_dep libkpgp)
+ akonadi? ( $(add_kdebase_dep akonadi) )
+ nls? ( || (
+ (
+ $(add_kdeapps_dep kde4-l10n '' 15.04.0)
+ )
+ (
+ $(add_kdeapps_dep kde4-l10n '' 4.14.3)
+ $(add_kdebase_dep kdepim-l10n '' 4.4.11.1-r1)
+ )
+ ) )
+"
diff --git a/kde-base/kdepim-meta/kdepim-meta-4.4.2015.06.ebuild b/kde-base/kdepim-meta/kdepim-meta-4.4.2015.06.ebuild
new file mode 100644
index 00000000000..c1ebc7796d0
--- /dev/null
+++ b/kde-base/kdepim-meta/kdepim-meta-4.4.2015.06.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit kde4-meta-pkg
+
+DESCRIPTION="kdepim - merge this to pull in all kdepim-derived packages"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="nls"
+
+RDEPEND="
+ $(add_kdebase_dep akregator)
+ $(add_kdebase_dep blogilo)
+ $(add_kdebase_dep kabcclient)
+ $(add_kdebase_dep kaddressbook)
+ $(add_kdebase_dep kalarm)
+ $(add_kdebase_dep kdepim-icons)
+ $(add_kdebase_dep kdepim-kresources)
+ $(add_kdebase_dep kdepim-wizards)
+ $(add_kdebase_dep kjots)
+ $(add_kdebase_dep kleopatra)
+ $(add_kdebase_dep kmail)
+ $(add_kdebase_dep knode)
+ $(add_kdebase_dep knotes)
+ $(add_kdebase_dep konsolekalendar)
+ $(add_kdebase_dep kontact)
+ $(add_kdebase_dep korganizer)
+ $(add_kdebase_dep ktimetracker)
+ $(add_kdebase_dep libkdepim)
+ $(add_kdebase_dep libkleo)
+ $(add_kdebase_dep libkpgp)
+ nls? ( || (
+ (
+ $(add_kdeapps_dep kde4-l10n '' 15.04.0)
+ )
+ (
+ $(add_kdeapps_dep kde4-l10n '' 4.14.3)
+ $(add_kdebase_dep kdepim-l10n '' 4.4.11.1-r1)
+ )
+ ) )
+ !kde-base/kdepim-runtime
+"
diff --git a/kde-base/kdepim-meta/metadata.xml b/kde-base/kdepim-meta/metadata.xml
new file mode 100644
index 00000000000..bf6e23b695a
--- /dev/null
+++ b/kde-base/kdepim-meta/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <use>
+ <flag name="akonadi">Enables support for <pkg>kde-base/akonadi</pkg></flag>
+ </use>
+</pkgmetadata>