summaryrefslogtreecommitdiff
path: root/kde-base/libkdepim
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-base/libkdepim
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-base/libkdepim')
-rw-r--r--kde-base/libkdepim/Manifest2
-rw-r--r--kde-base/libkdepim/files/4.4/0004-libkdepim-Make-spell-checking-work-again.patch69
-rw-r--r--kde-base/libkdepim/libkdepim-4.4.11.1-r1.ebuild39
-rw-r--r--kde-base/libkdepim/libkdepim-4.4.2015.06.ebuild38
-rw-r--r--kde-base/libkdepim/metadata.xml5
5 files changed, 153 insertions, 0 deletions
diff --git a/kde-base/libkdepim/Manifest b/kde-base/libkdepim/Manifest
new file mode 100644
index 00000000000..16396e32452
--- /dev/null
+++ b/kde-base/libkdepim/Manifest
@@ -0,0 +1,2 @@
+DIST kdepim-4.4.11.1.tar.bz2 8964708 SHA256 a2fa237a3d880cc55a6c94450b93a7918bb0d5e3943eb7a759c8789de1ed41bf SHA512 7450ba9985c5583847d1fc3d214940cef130150a3591c3cbb73bc15624ee0298805d5dc25f3cd3a135091c1d0491b865961d52aa8feef623219eed9364dd86bf WHIRLPOOL 349a72c5c6859c7cafb1aefdf80b80482102c8b1d6e0123c6c410d262c3908b9572daa1950e2fb41e6bc727430fc91bb57b7276e345553ed15d792fa63aba5ec
+DIST kdepim-4.4.2015.06.tar.xz 8901968 SHA256 d9153c57e697ca33d0bd82f1f93ed2befdabbe3822189c1c8acbdf7bf9bbaec6 SHA512 10e89ff1bb22ef03ae2128b800f87c76da945703fa98c07fa0ac29deb17c724beeca84995c50b067138ab7cf0543112173eb850d897b38c512a25974bfc15e1e WHIRLPOOL 543b9d629380e9923b38c414cf6e7390437a48acfb31b9ed934e9655bb1efb1f480065942775dc68d8382e639e4df122f953388dad90a9fadb3734d2f2fe72f0
diff --git a/kde-base/libkdepim/files/4.4/0004-libkdepim-Make-spell-checking-work-again.patch b/kde-base/libkdepim/files/4.4/0004-libkdepim-Make-spell-checking-work-again.patch
new file mode 100644
index 00000000000..19d8c01666f
--- /dev/null
+++ b/kde-base/libkdepim/files/4.4/0004-libkdepim-Make-spell-checking-work-again.patch
@@ -0,0 +1,69 @@
+From 6f62ea1bff318d8efea42f59bdc965ee2ab187a0 Mon Sep 17 00:00:00 2001
+From: Thomas McGuire <mcguire@kde.org>
+Date: Wed, 11 May 2011 18:21:32 +0100
+Subject: [PATCH 4/6] Make spell checking work again. The text edit used the
+ wrong config file for loading spell settings. After
+ using the config file, the correct settigns get loaded
+ again, since the Loader from Sonnet is a singleton and
+ therefore shares the settings, so even the textedit
+ with the wrong settings file name gets updated.
+
+cherry-picked from d1708effbb68d6eae36ee5177a599c965973725f.
+
+BUG: 247486
+---
+ kmail/kmcomposereditor.cpp | 2 +-
+ libkdepim/kmeditor.cpp | 12 ++++++++++++
+ libkdepim/kmeditor.h | 6 ++++++
+ 3 files changed, 19 insertions(+), 1 deletion(-)
+
+diff --git a/libkdepim/kmeditor.cpp b/libkdepim/kmeditor.cpp
+index e8f0d36..067c781 100644
+--- a/libkdepim/kmeditor.cpp
++++ b/libkdepim/kmeditor.cpp
+@@ -28,6 +28,7 @@
+ #include <KProcess>
+ #include <KPushButton>
+ #include <KTemporaryFile>
++#include <kdeversion.h>
+
+ #include <QApplication>
+ #include <QClipboard>
+@@ -215,6 +216,17 @@ KMeditor::KMeditor( QWidget *parent )
+ d->init();
+ }
+
++KMeditor::KMeditor( QWidget *parent, const QString & configFile )
++#if KDE_IS_VERSION(4,6,0)
++ : TextEdit( parent, configFile ), d( new KMeditorPrivate( this ) )
++#else
++ : TextEdit( parent ), d( new KMeditorPrivate( this ) )
++#endif
++{
++ Q_UNUSED( configFile )
++ d->init();
++}
++
+ KMeditor::~KMeditor()
+ {
+ delete d;
+diff --git a/libkdepim/kmeditor.h b/libkdepim/kmeditor.h
+index 4aab8aa..66ebb4a 100644
+--- a/libkdepim/kmeditor.h
++++ b/libkdepim/kmeditor.h
+@@ -61,6 +61,12 @@ class KDEPIM_EXPORT KMeditor : public KPIMTextEdit::TextEdit
+ */
+ explicit KMeditor( QWidget *parent = 0 );
+
++ /**
++ * Constructs a KMeditor object.
++ */
++ explicit KMeditor( QWidget *parent, const QString& configFile );
++
++
+ virtual ~KMeditor();
+
+ //Redefine it for each apps
+--
+1.7.9.2
+
diff --git a/kde-base/libkdepim/libkdepim-4.4.11.1-r1.ebuild b/kde-base/libkdepim/libkdepim-4.4.11.1-r1.ebuild
new file mode 100644
index 00000000000..8b13c42918d
--- /dev/null
+++ b/kde-base/libkdepim/libkdepim-4.4.11.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="Common library for KDE PIM apps"
+KEYWORDS="amd64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop(+)' 4.6)
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="
+ korganizer/korgac/org.kde.korganizer.KOrgac.xml
+"
+
+KMSAVELIBS="true"
+
+# the one test that can be run requires a dbus session bus
+RESTRICT=test
+
+PATCHES=( "${FILESDIR}/4.4/"0004-*.patch )
+
+src_install() {
+ kde4-meta_src_install
+
+ # install additional generated headers that are needed by other packages that
+ # are derived from kdepim. e.g. kmail.
+ pushd "${CMAKE_BUILD_DIR}/libkdepim/" 2>/dev/null || die "pushd libkdepim failed"
+ insinto "${PREFIX}/include"
+ doins ui_addresspicker.h ui_categoryselectdialog_base.h || die "Failed to install extra header files."
+ popd 2>/dev/null
+}
diff --git a/kde-base/libkdepim/libkdepim-4.4.2015.06.ebuild b/kde-base/libkdepim/libkdepim-4.4.2015.06.ebuild
new file mode 100644
index 00000000000..134cb76a4dc
--- /dev/null
+++ b/kde-base/libkdepim/libkdepim-4.4.2015.06.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="Common library for KDE PIM apps (noakonadi branch)"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs '' 4.6)
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="
+ korganizer/korgac/org.kde.korganizer.KOrgac.xml
+ kaddressbook/org.kde.KAddressbook.Core.xml
+"
+
+KMSAVELIBS="true"
+
+# the one test that can be run requires a dbus session bus
+RESTRICT=test
+
+src_install() {
+ kde4-meta_src_install
+
+ # install additional generated headers that are needed by other packages that
+ # are derived from kdepim. e.g. kmail.
+ pushd "${CMAKE_BUILD_DIR}/libkdepim/" 2>/dev/null || die "pushd libkdepim failed"
+ insinto "${PREFIX}/include"
+ doins ui_addresspicker.h ui_categoryselectdialog_base.h || die "Failed to install extra header files."
+ popd 2>/dev/null
+}
diff --git a/kde-base/libkdepim/metadata.xml b/kde-base/libkdepim/metadata.xml
new file mode 100644
index 00000000000..8d1e86a9cef
--- /dev/null
+++ b/kde-base/libkdepim/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+</pkgmetadata>