summaryrefslogtreecommitdiff
path: root/kde-base/libkleo
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-base/libkleo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-base/libkleo')
-rw-r--r--kde-base/libkleo/Manifest2
-rw-r--r--kde-base/libkleo/files/libkleo-4.4.11.1-gcc47.patch12
-rw-r--r--kde-base/libkleo/libkleo-4.4.11.1-r1.ebuild25
-rw-r--r--kde-base/libkleo/libkleo-4.4.2015.06.ebuild23
-rw-r--r--kde-base/libkleo/metadata.xml5
5 files changed, 67 insertions, 0 deletions
diff --git a/kde-base/libkleo/Manifest b/kde-base/libkleo/Manifest
new file mode 100644
index 00000000000..16396e32452
--- /dev/null
+++ b/kde-base/libkleo/Manifest
@@ -0,0 +1,2 @@
+DIST kdepim-4.4.11.1.tar.bz2 8964708 SHA256 a2fa237a3d880cc55a6c94450b93a7918bb0d5e3943eb7a759c8789de1ed41bf SHA512 7450ba9985c5583847d1fc3d214940cef130150a3591c3cbb73bc15624ee0298805d5dc25f3cd3a135091c1d0491b865961d52aa8feef623219eed9364dd86bf WHIRLPOOL 349a72c5c6859c7cafb1aefdf80b80482102c8b1d6e0123c6c410d262c3908b9572daa1950e2fb41e6bc727430fc91bb57b7276e345553ed15d792fa63aba5ec
+DIST kdepim-4.4.2015.06.tar.xz 8901968 SHA256 d9153c57e697ca33d0bd82f1f93ed2befdabbe3822189c1c8acbdf7bf9bbaec6 SHA512 10e89ff1bb22ef03ae2128b800f87c76da945703fa98c07fa0ac29deb17c724beeca84995c50b067138ab7cf0543112173eb850d897b38c512a25974bfc15e1e WHIRLPOOL 543b9d629380e9923b38c414cf6e7390437a48acfb31b9ed934e9655bb1efb1f480065942775dc68d8382e639e4df122f953388dad90a9fadb3734d2f2fe72f0
diff --git a/kde-base/libkleo/files/libkleo-4.4.11.1-gcc47.patch b/kde-base/libkleo/files/libkleo-4.4.11.1-gcc47.patch
new file mode 100644
index 00000000000..b2b64fe4d1a
--- /dev/null
+++ b/kde-base/libkleo/files/libkleo-4.4.11.1-gcc47.patch
@@ -0,0 +1,12 @@
+diff -ruN libkleo-4.4.11.1.orig/libkleo/backends/qgpgme/threadedjobmixin.h libkleo-4.4.11.1/libkleo/backends/qgpgme/threadedjobmixin.h
+--- libkleo-4.4.11.1.orig/libkleo/backends/qgpgme/threadedjobmixin.h 2011-04-20 22:03:31.000000000 +0200
++++ libkleo-4.4.11.1/libkleo/backends/qgpgme/threadedjobmixin.h 2012-07-20 23:51:45.000000000 +0200
+@@ -143,7 +143,7 @@
+
+ void lateInitialization() {
+ assert( m_ctx );
+- connect( &m_thread, SIGNAL(finished()), this, SLOT(slotFinished()) );
++ this->connect( &m_thread, SIGNAL(finished()), this, SLOT(slotFinished()) );
+ m_ctx->setProgressProvider( this );
+ }
+
diff --git a/kde-base/libkleo/libkleo-4.4.11.1-r1.ebuild b/kde-base/libkleo/libkleo-4.4.11.1-r1.ebuild
new file mode 100644
index 00000000000..2681c9ab921
--- /dev/null
+++ b/kde-base/libkleo/libkleo-4.4.11.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="KDE library for encryption handling"
+KEYWORDS="amd64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ app-crypt/gpgme
+ $(add_kdebase_dep kdepimlibs '' 4.6)
+"
+RDEPEND="${DEPEND}
+ app-crypt/gnupg
+"
+
+PATCHES=( "${FILESDIR}/${P}-gcc47.patch" )
+
+KMSAVELIBS="true"
+KMEXTRACTONLY="kleopatra/"
diff --git a/kde-base/libkleo/libkleo-4.4.2015.06.ebuild b/kde-base/libkleo/libkleo-4.4.2015.06.ebuild
new file mode 100644
index 00000000000..a4eabff5509
--- /dev/null
+++ b/kde-base/libkleo/libkleo-4.4.2015.06.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="KDE library for encryption handling"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ app-crypt/gpgme
+ $(add_kdebase_dep kdepimlibs '' 4.6)
+"
+RDEPEND="${DEPEND}
+ app-crypt/gnupg
+"
+
+KMSAVELIBS="true"
+KMEXTRACTONLY="kleopatra/"
diff --git a/kde-base/libkleo/metadata.xml b/kde-base/libkleo/metadata.xml
new file mode 100644
index 00000000000..8d1e86a9cef
--- /dev/null
+++ b/kde-base/libkleo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+</pkgmetadata>