summaryrefslogtreecommitdiff
path: root/kde-frameworks/baloo
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2015-09-22 21:37:53 +0200
committerMichael Palimaka <kensington@gentoo.org>2015-09-27 02:00:40 +1000
commit233ee641eb0819f6795c07b6a33d927dcc0c0e2e (patch)
tree9a1d802214a403e9b9016417ed3090d211f0bdf2 /kde-frameworks/baloo
parenta5fa7a7db833f23eddd20837a381147446156a50 (diff)
downloadgentoo-233ee641eb0819f6795c07b6a33d927dcc0c0e2e.tar.gz
gentoo-233ee641eb0819f6795c07b6a33d927dcc0c0e2e.tar.xz
kde-frameworks/baloo: Backport fix for baloo crash if disabled
Upstream bug: https://bugs.kde.org/show_bug.cgi?id=353049 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'kde-frameworks/baloo')
-rw-r--r--kde-frameworks/baloo/baloo-5.14.0-r1.ebuild36
-rw-r--r--kde-frameworks/baloo/files/baloo-5.14.0-check-if-db-open.patch28
2 files changed, 64 insertions, 0 deletions
diff --git a/kde-frameworks/baloo/baloo-5.14.0-r1.ebuild b/kde-frameworks/baloo/baloo-5.14.0-r1.ebuild
new file mode 100644
index 00000000000..bf7b12e5c8c
--- /dev/null
+++ b/kde-frameworks/baloo/baloo-5.14.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_PUNT_BOGUS_DEPS="true"
+inherit kde5
+
+DESCRIPTION="Framework for searching and managing metadata"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kauth)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kfilemetadata)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kidletime)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep solid)
+ dev-db/lmdb
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ sys-apps/attr
+"
+RDEPEND="${DEPEND}
+ !kde-base/baloo:4[-minimal(-)]
+"
+
+PATCHES=( "${FILESDIR}/${P}-check-if-db-open.patch" )
diff --git a/kde-frameworks/baloo/files/baloo-5.14.0-check-if-db-open.patch b/kde-frameworks/baloo/files/baloo-5.14.0-check-if-db-open.patch
new file mode 100644
index 00000000000..76c71fb7387
--- /dev/null
+++ b/kde-frameworks/baloo/files/baloo-5.14.0-check-if-db-open.patch
@@ -0,0 +1,28 @@
+From: Boudhayan Gupta <me@BaloneyGeek.com>
+Date: Tue, 22 Sep 2015 18:55:36 +0000
+Subject: Fail Baloo::File::load() if the Database is not open.
+X-Git-Url: http://quickgit.kde.org/?p=baloo.git&a=commitdiff&h=29fe68f2657df503926e629477a41f7d9435048f
+---
+Fail Baloo::File::load() if the Database is not open.
+Fixes crash if selecting multiple files in Dolphin with
+Baloo disabled.
+
+BUG: 353049
+REVIEW: 125352
+---
+
+
+--- a/src/lib/file.cpp
++++ b/src/lib/file.cpp
+@@ -98,6 +98,10 @@
+ Database *db = globalDatabaseInstance();
+ db->open(Database::OpenDatabase);
+
++ if (!db->isOpen()) {
++ return false;
++ }
++
+ quint64 id = filePathToId(QFile::encodeName(d->url));
+ if (!id) {
+ return false;
+