summaryrefslogtreecommitdiff
path: root/kde-frameworks/extra-cmake-modules
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-frameworks/extra-cmake-modules
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-frameworks/extra-cmake-modules')
-rw-r--r--kde-frameworks/extra-cmake-modules/Manifest1
-rw-r--r--kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.12.0.ebuild45
-rw-r--r--kde-frameworks/extra-cmake-modules/metadata.xml5
3 files changed, 51 insertions, 0 deletions
diff --git a/kde-frameworks/extra-cmake-modules/Manifest b/kde-frameworks/extra-cmake-modules/Manifest
new file mode 100644
index 00000000000..392d5e7ce4f
--- /dev/null
+++ b/kde-frameworks/extra-cmake-modules/Manifest
@@ -0,0 +1 @@
+DIST extra-cmake-modules-5.12.0.tar.xz 132216 SHA256 5100405ce5a86796e3197c2f62fae9cbdefe5a1d617341f29fa88e44ac3ec792 SHA512 00c1e6e47dff9e92974106d4570fb74f3edbe1718c6603047e6fdef6c3c491b1350c71eff8585702f759a56308b5cdf9d26b0af898515a90b23a89483ab4f082 WHIRLPOOL 0f1b558a89ba1ccf71d24c9147f27eefd98865f0de77846aad4d3c46c3a638fb5f63d6ae65096ca1f42b15020458fa6631f3e928bc77c8f2dc1c4b27fe5270db
diff --git a/kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.12.0.ebuild b/kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.12.0.ebuild
new file mode 100644
index 00000000000..df3da72712d
--- /dev/null
+++ b/kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.12.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+KDE_AUTODEPS="false"
+KDE_DEBUG="false"
+inherit kde5 python-any-r1
+
+DESCRIPTION="Extra modules and scripts for CMake"
+HOMEPAGE="https://projects.kde.org/projects/kdesupport/extra-cmake-modules"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ >=dev-util/cmake-2.8.12
+ doc? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')
+ )
+"
+RDEPEND="
+ dev-qt/qtcore:5
+"
+
+python_check_deps() {
+ has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build doc HTML_DOCS)
+ $(cmake-utils_use_build doc MAN_DOCS)
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/kde-frameworks/extra-cmake-modules/metadata.xml b/kde-frameworks/extra-cmake-modules/metadata.xml
new file mode 100644
index 00000000000..a23f444b67d
--- /dev/null
+++ b/kde-frameworks/extra-cmake-modules/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+</pkgmetadata>