summaryrefslogtreecommitdiff
path: root/kde-frameworks/frameworkintegration
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-10-11 19:49:41 +1100
committerMichael Palimaka <kensington@gentoo.org>2015-10-11 19:50:59 +1100
commit0308c404932dec82a6a974cbc2c83c9198d1602f (patch)
tree9b441ac896ae0a25c1796bcd03ea47d2abccfab1 /kde-frameworks/frameworkintegration
parent22b6db86586cbdb4662dbe5f61d85b6610104025 (diff)
downloadgentoo-0308c404932dec82a6a974cbc2c83c9198d1602f.tar.gz
gentoo-0308c404932dec82a6a974cbc2c83c9198d1602f.tar.xz
kde-frameworks: version bump 5.15.0
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.15.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 41b545007d0..7d7d9581c29 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1 +1,2 @@
DIST frameworkintegration-5.14.0.tar.xz 1780396 SHA256 c8f7e49d3c2100716f2b87f94c6a779d7b541946208697cc46ac5db9e4829ba4 SHA512 b5f21ee008119a7e14f8a21df5a095795498272bfbc6b2a875bbf128c9495a9a020b0fb201775f6b0c9c73358a3133f9304d20e94e4ff7b8aabcccb8973498dc WHIRLPOOL 11be017f7a760f49faa6b4e9137f4901bc50425785f27a11ee0c8a9e8ce364d0c86319a3227f476b37e3ed7804db857ec0ddcec0e3e3c8c51b91fed9526bb0b7
+DIST frameworkintegration-5.15.0.tar.xz 1781464 SHA256 2a7a3d450c28d7f1ac19ddf02cb5e2badcd6903cf3981d82ce70bcd16d644a1b SHA512 7b526f2919f3fa2682a7b45c158b933c9e46a28467ac93c9fdd2a9266b6bee05157bb9dbb5f297a61e312381b9184440e3d935acc7de71c0475efd6f74bef44e WHIRLPOOL 654b5257ec6f5e013d2e1ef593b6e861fb3f81ee6c7f598cdb1d30ef4491a95e08a1b25135631a5d47c10ea5e05ad1ed4d42ff516b25d1f08a8988da26d097ba
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.15.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.15.0.ebuild
new file mode 100644
index 00000000000..0c41d1b5cf4
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.15.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for integrating Qt applications with KDE workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+
+RDEPEND="
+ $(add_plasma_dep oxygen-fonts)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ X? (
+ dev-qt/qtx11extras:5
+ x11-libs/libxcb
+ x11-libs/libXcursor
+ )
+"
+DEPEND="${RDEPEND}"
+
+# requires running kde environment
+RESTRICT="test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package X XCB)
+ )
+
+ kde5_src_configure
+}