summaryrefslogtreecommitdiff
path: root/kde-frameworks/frameworkintegration
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-02-15 03:45:01 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-02-15 03:46:01 +1100
commit308018c879d78532b4deb50754fce3b4baa9aa25 (patch)
treec239383027c2b8c67494d1a43884bb4e979733ac /kde-frameworks/frameworkintegration
parentd57e9fbe719e9f1c5a4e7a2b3737549ddf2bd076 (diff)
downloadgentoo-308018c879d78532b4deb50754fce3b4baa9aa25.tar.gz
gentoo-308018c879d78532b4deb50754fce3b4baa9aa25.tar.xz
kde-frameworks: version bump 5.19.0
Package-Manager: portage-2.2.27
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.19.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 5d2e4cedf46..7b55bc291fa 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.17.0.tar.xz 1782980 SHA256 743f94f359984b85f608b2f4f059b2daaa1f8dc90210431526677dcd0da60cb9 SHA512 869394a4ddbc2d842d5ea724c1fcd30ad63667f9f197a5cdc7aea5ca9901b2e11ebb3942e73cab9f6a66bc45bcd0186276e36e9d0662a7b2c0866a8946593cc1 WHIRLPOOL f3f8c116538e095d6e5aa9821b3e19860613914727a9036340f7b2a36af3b0fbbe6c645d05062c9cc473876670fc0dc3c8be381b9247e26d801b63fabe46f6d7
DIST frameworkintegration-5.18.0.tar.xz 1782972 SHA256 3b072fac7d4fc4a1c5981000799b5da2bb703d1c1f3747c7092282590b421c1a SHA512 40a90aa5e779d33af35e446bbfcff6ca475b9430cd3c6146411ca542a972ba72c9a92342e6c55d5d60934df7d660a775aabf297b01e5252334e4a5f8a0bfe1e7 WHIRLPOOL 1f0861753049e15803d83227bd8110dd4f7c0541392ceb60a11cd860567d85b3cf9d5dbf63db62c0977499c6bb1da1bf4be360e750bfdc09ca4b359328a1ed98
+DIST frameworkintegration-5.19.0.tar.xz 1784504 SHA256 c3cb58b4758b28df9121c44aaadac74fb4546b968ec071a2ef177bc6cf3d8a02 SHA512 f9bdda8f819843100ca47ffb807ef1633a1ed08e894cd4df2f679f2ffda6c595eec18bd3396a01bdff74e1acb2280a8c8f616be4f32da1f01237d509f89c5e1a WHIRLPOOL e7bb00dbd70d18c35aa6fff54d36567b76190dcc1a178d13f69f394cfa3b51624af76097cc3cbe897c7a4de087c668bae34a53cafde9309ae068cc8e5b3ec239
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.19.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.19.0.ebuild
new file mode 100644
index 00000000000..9e2f36963e1
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.19.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+QT_MINIMAL="5.5.1"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for integrating Qt applications with KDE workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="X"
+
+RDEPEND="
+ $(add_plasma_dep oxygen-fonts)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui '' '' '5=')
+ $(add_qt_dep qtwidgets)
+ media-fonts/noto
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb
+ x11-libs/libXcursor
+ )
+"
+DEPEND="${RDEPEND}"
+
+# requires running kde environment
+RESTRICT="test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package X XCB)
+ )
+
+ kde5_src_configure
+}