summaryrefslogtreecommitdiff
path: root/kde-frameworks/frameworkintegration
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-10-14 17:05:21 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-10-14 17:06:15 +0200
commit66b09c22973a2fa441b3a4dc7d71874a8a40204a (patch)
tree2bf2d57a052b373529fd4653fbcbbe51c3095d80 /kde-frameworks/frameworkintegration
parentd563ca25f3e7cf37e84bee5dc79391d948374a88 (diff)
downloadgentoo-66b09c22973a2fa441b3a4dc7d71874a8a40204a.tar.gz
gentoo-66b09c22973a2fa441b3a4dc7d71874a8a40204a.tar.xz
kde-frameworks: Add KDE Frameworks 5.39.0
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.39.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 04eb9b6b186..b2b0a0060d3 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.37.0.tar.xz 1752004 SHA256 aa8ca045ba97899b739077e07a961b9e402520a0abfcee8be90baa85251c9e5d SHA512 ecff45b2d7138621b19b9b276c4a2d7940c156ee81d85789d598178179e524ed6fef014c9d6615b91d2ea9c4c9a058d5009f44899834c541c36301f9ca581dd7 WHIRLPOOL 19d6589c03fb9899b3e823304c159cd345a94735995d27e47463c12c428cfb7c75f243fb174d7f3639baef37723d7407edde3f534c361bab8314037d0698565e
DIST frameworkintegration-5.38.0.tar.xz 1752696 SHA256 08cb88ef7c7ceb7cd43cbc7f3040daf7128d22bb75f8eb3956d55afd3e1b3670 SHA512 d7a992709c15c3fe6f4fb6ff83c75574748e2b46fd5f20e13b089fb2dbdb721d83e0d62b31230b72dcdf5f747a7a94870619b5b40868fea580c43f109f56ff07 WHIRLPOOL 0b40775a6f87a4061589ea1f9ea588978f90e5d7768c1fdce160521737c3231f95548c2b1955867283f9e754436a5609f1cdb785a247cdf243233ff754c3f15f
+DIST frameworkintegration-5.39.0.tar.xz 1752696 SHA256 50b427b53dfdf667d3e6d8de2b1662a7bea508cbf361163f0383a9e82143da8c SHA512 13959a74c08f77947d7d6a810a5bb9638a3e63437b293132143ae9668d070be81e40608bfa80cecd3d5dd59ae01b746d12e4c2db76fc99ff98216fe1eea6f89d WHIRLPOOL aa334e40c90e8f4a8458d005677f94861b5fb218c73c85edd08f0ba814350a62fd66072a47623744173e492a7854796f90a04c004e4ca40a618a7178ef415c76
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.39.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.39.0.ebuild
new file mode 100644
index 00000000000..9062d6d3800
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.39.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_QTHELP="false"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="appstream X"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ appstream? (
+ app-admin/packagekit-qt
+ dev-libs/appstream[qt5]
+ )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb
+ )
+"
+DEPEND="${RDEPEND}"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+src_prepare() {
+ punt_bogus_dep Qt5 DBus
+ kde5_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package appstream AppStreamQt)
+ $(cmake-utils_use_find_package appstream packagekitqt5)
+ $(cmake-utils_use_find_package X XCB)
+ )
+
+ kde5_src_configure
+}