summaryrefslogtreecommitdiff
path: root/kde-frameworks/kauth
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-10-11 19:49:41 +1100
committerMichael Palimaka <kensington@gentoo.org>2015-10-11 19:50:59 +1100
commit0308c404932dec82a6a974cbc2c83c9198d1602f (patch)
tree9b441ac896ae0a25c1796bcd03ea47d2abccfab1 /kde-frameworks/kauth
parent22b6db86586cbdb4662dbe5f61d85b6610104025 (diff)
downloadgentoo-0308c404932dec82a6a974cbc2c83c9198d1602f.tar.gz
gentoo-0308c404932dec82a6a974cbc2c83c9198d1602f.tar.xz
kde-frameworks: version bump 5.15.0
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'kde-frameworks/kauth')
-rw-r--r--kde-frameworks/kauth/Manifest1
-rw-r--r--kde-frameworks/kauth/kauth-5.15.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/kde-frameworks/kauth/Manifest b/kde-frameworks/kauth/Manifest
index 7c314f3fa49..53c95679879 100644
--- a/kde-frameworks/kauth/Manifest
+++ b/kde-frameworks/kauth/Manifest
@@ -1 +1,2 @@
DIST kauth-5.14.0.tar.xz 82116 SHA256 1430e9f480c8fffdefe7281c4b6365472404e2d549647aeda73cf497a5b9d8cd SHA512 633722520c47184dcba726e5909b0a10224de43892cafce36f62796b6934c764da071eb6579fb51dc56eae1c0dc32431010678bb7d4c5c75b35deae607c93eef WHIRLPOOL 449c7566fd86fe9ca58ad1f3edf4be5614989df590c0121e7d56a0ccf2c069426f91d881995c7f6f0ae380bee762c3d9084f51f2d1169bc4c9aa8e74e59b6487
+DIST kauth-5.15.0.tar.xz 82088 SHA256 e2a91e1a4c40d5547c8963c74a805810b6bc192e3193245f52e855addc7219da SHA512 0be2173f33076f9ede4ae90561743686df618be255edf8eeafe934bc8f698b72771a02d019f4fd7a94f074718c25115565115271637a383b73d1705ab128479a WHIRLPOOL 84f40e08eb7581d82a46f15214572bb55fac43287e12733dddd5f661799046f69889fb52a8022bb8785253372487309edc7d66c474418f6a71d0c0456b0365ec
diff --git a/kde-frameworks/kauth/kauth-5.15.0.ebuild b/kde-frameworks/kauth/kauth-5.15.0.ebuild
new file mode 100644
index 00000000000..01504008c4a
--- /dev/null
+++ b/kde-frameworks/kauth/kauth-5.15.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework to let applications perform actions as a privileged user"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls +policykit"
+
+RDEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ policykit? ( sys-auth/polkit-qt[qt5] )
+"
+DEPEND="${RDEPEND}
+ nls? ( dev-qt/linguist-tools:5 )
+"
+PDEPEND="policykit? ( kde-plasma/polkit-kde-agent )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package policykit PolkitQt5-1)
+ )
+
+ kde5_src_configure
+}