summaryrefslogtreecommitdiff
path: root/kde-frameworks/kded/kded-5.29.0.ebuild
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-12-12 18:28:03 +0100
committerJohannes Huber <johu@gentoo.org>2016-12-12 18:28:19 +0100
commit4b160993f90db90a69e37baff8977a24177cc48c (patch)
treebb0e84333f2b17fc242263e06515cfa97425afd6 /kde-frameworks/kded/kded-5.29.0.ebuild
parent3fac5fffe2a1534a4137ba973174f09d02242a00 (diff)
downloadgentoo-4b160993f90db90a69e37baff8977a24177cc48c.tar.gz
gentoo-4b160993f90db90a69e37baff8977a24177cc48c.tar.xz
kde-frameworks: Version bump KDE Frameworks 5.29.0
Package-Manager: portage-2.3.3
Diffstat (limited to 'kde-frameworks/kded/kded-5.29.0.ebuild')
-rw-r--r--kde-frameworks/kded/kded-5.29.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-frameworks/kded/kded-5.29.0.ebuild b/kde-frameworks/kded/kded-5.29.0.ebuild
new file mode 100644
index 00000000000..4548df12de2
--- /dev/null
+++ b/kde-frameworks/kded/kded-5.29.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_TEST="false"
+inherit kde5
+
+DESCRIPTION="Central daemon of KDE workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+man"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kservice)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+"
+DEPEND="${RDEPEND}
+ man? ( $(add_frameworks_dep kdoctools) )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package man KF5DocTools)
+ )
+
+ kde5_src_configure
+}