summaryrefslogtreecommitdiff
path: root/kde-frameworks/khtml
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-frameworks/khtml
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-frameworks/khtml')
-rw-r--r--kde-frameworks/khtml/Manifest1
-rw-r--r--kde-frameworks/khtml/khtml-5.12.0.ebuild66
-rw-r--r--kde-frameworks/khtml/metadata.xml5
3 files changed, 72 insertions, 0 deletions
diff --git a/kde-frameworks/khtml/Manifest b/kde-frameworks/khtml/Manifest
new file mode 100644
index 00000000000..927634084e1
--- /dev/null
+++ b/kde-frameworks/khtml/Manifest
@@ -0,0 +1 @@
+DIST khtml-5.12.0.tar.xz 2070572 SHA256 5ca77b283a40299f50147c84bcbe274ecca1786ec74d8e813fad05e43feae638 SHA512 22442a8a5d76bc062a38345f4b000cf80b668c9b303cf8e6b4d7834caac4e412ac5197a70dc5f5777cbd7fe76d83bb71bf6f2c188989b657b14582d7a232b2eb WHIRLPOOL 2f007a3bd1aa93106592ba3eeda5fc2829647b1e29425d1d850e9d852467d83515e93bd139013ae8830147fc3a5216b3adcb50f21db01ed2fbf244e91758fd25
diff --git a/kde-frameworks/khtml/khtml-5.12.0.ebuild b/kde-frameworks/khtml/khtml-5.12.0.ebuild
new file mode 100644
index 00000000000..6ad13092286
--- /dev/null
+++ b/kde-frameworks/khtml/khtml-5.12.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KHTML web rendering engine"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kjs)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep sonnet)
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ media-libs/giflib
+ media-libs/libpng:0=
+ media-libs/phonon[qt5]
+ sys-libs/zlib
+ virtual/jpeg:0
+ X? (
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+ )
+"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-libs/openssl
+ test? ( dev-qt/qtx11extras:5 )
+ X? ( x11-proto/xproto )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package X X11)
+ )
+
+ kde5_src_configure
+}
diff --git a/kde-frameworks/khtml/metadata.xml b/kde-frameworks/khtml/metadata.xml
new file mode 100644
index 00000000000..a23f444b67d
--- /dev/null
+++ b/kde-frameworks/khtml/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+</pkgmetadata>