summaryrefslogtreecommitdiff
path: root/kde-frameworks/kio
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-09-15 04:04:32 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-09-15 04:12:16 +1000
commit1f9700ed2ec8463a6b7d80a06f83c7b50c973b54 (patch)
tree4a5042f5e2915e29ee83096ce0306f8e0e8208ee /kde-frameworks/kio
parentf9deb4d3e0a339818db1d6147e3134c832dc10f7 (diff)
downloadgentoo-1f9700ed2ec8463a6b7d80a06f83c7b50c973b54.tar.gz
gentoo-1f9700ed2ec8463a6b7d80a06f83c7b50c973b54.tar.xz
kde-frameworks: version bump 5.26.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'kde-frameworks/kio')
-rw-r--r--kde-frameworks/kio/Manifest1
-rw-r--r--kde-frameworks/kio/files/kio-5.26.0-fix-desktop-launch.patch26
-rw-r--r--kde-frameworks/kio/kio-5.26.0-r1.ebuild82
3 files changed, 109 insertions, 0 deletions
diff --git a/kde-frameworks/kio/Manifest b/kde-frameworks/kio/Manifest
index 76ad2c18b8f..32b3d9d614a 100644
--- a/kde-frameworks/kio/Manifest
+++ b/kde-frameworks/kio/Manifest
@@ -1,2 +1,3 @@
DIST kio-5.23.0.tar.xz 2895756 SHA256 3489ba9c45e587f6b8b542aea4608eeb21cdbca27ef37d9f45d4308da8fd32b5 SHA512 4df3a30a33e66c28013f8d869253c5b8d3e88891ddada16185f101753c14e56450eb1014601d0ee2406211676250bebb2645afaf75a5d75a16ab726537950065 WHIRLPOOL 7600dc8de676b3bc909f86da4350cd2f73b225066efde5424a51cdd0e92ed7bda239bac3d4549a069847cb71c2e7248e38be2a7c871d0ced135be3262a52438a
DIST kio-5.25.0.tar.xz 2951304 SHA256 d9806d74d0119ced246446fd22110ba8ae5a980e4734b165819b30bcadf90578 SHA512 21021aa702fe491b35e61b5f2f01f5eeb1ae8e03ac0fe9305fc0a251c41833b8304d313f71079cc24afb6ac809486ea7a594d343cecc51eca2519d2dd4dc3f22 WHIRLPOOL 5cbe5edc40988f4f8b1030324e8a170902b9bf11240a8b0e902b7e5235a25300c683b4cab28f19db3b45d4436c578eb01f1be4aed460994d152281492dfad8f6
+DIST kio-5.26.0.tar.xz 2953124 SHA256 40d546074af313be97f64b644daad46fc9c287dbcf4bc41ca9fb5ff6c02976cf SHA512 dd8eed496698edee0af7461aaf5e170c6b6cdaf04a03caa9f8b0a5022446bbb5fa7e0eb40a93ecd8985a4e219eb5b930c8714449fa4f6f93910cc649b4650a8b WHIRLPOOL a26d95ce1d5b6a877143337dcab88dbede21fde5916ac72e20b350eeaf9a7c6c7e75f5ad21b8cabf5c65d97195aef6d262a9f15d9ca8e9504275b46f6d7fe477
diff --git a/kde-frameworks/kio/files/kio-5.26.0-fix-desktop-launch.patch b/kde-frameworks/kio/files/kio-5.26.0-fix-desktop-launch.patch
new file mode 100644
index 00000000000..b2766a6411b
--- /dev/null
+++ b/kde-frameworks/kio/files/kio-5.26.0-fix-desktop-launch.patch
@@ -0,0 +1,26 @@
+From: Antonio Rojas <arojas@archlinux.org>
+Date: Sat, 10 Sep 2016 22:14:56 +0000
+Subject: Fix launching terminal .desktop files with konsole
+X-Git-Url: http://quickgit.kde.org/?p=kio.git&a=commitdiff&h=c784a879eaba0babc6274bc32e761772add3d4f8
+---
+Fix launching terminal .desktop files with konsole
+
+Launching .desktop files which have Terminal=true currently fails, because kio adds to the konsole command the obsolete KDE4 command line options,
+which are not recognized by the KF5 konsole.
+
+REVIEW: 128882
+---
+
+
+--- a/src/core/desktopexecparser.cpp
++++ b/src/core/desktopexecparser.cpp
+@@ -363,7 +363,7 @@
+ if (!d->service.path().isEmpty()) {
+ terminal += " --workdir " + KShell::quoteArg(d->service.path());
+ }
+- terminal += QLatin1String(" -caption=%c %i %m");
++ terminal += QLatin1String(" -qwindowtitle '%c' %i");
+ }
+ terminal += ' ';
+ terminal += d->service.terminalOptions();
+
diff --git a/kde-frameworks/kio/kio-5.26.0-r1.ebuild b/kde-frameworks/kio/kio-5.26.0-r1.ebuild
new file mode 100644
index 00000000000..19704708b35
--- /dev/null
+++ b/kde-frameworks/kio/kio-5.26.0-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework providing transparent file and data management"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="acl +handbook kerberos +kwallet X"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork 'ssl')
+ $(add_qt_dep qtscript)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ dev-libs/libxml2
+ dev-libs/libxslt
+ acl? (
+ sys-apps/attr
+ virtual/acl
+ )
+ kerberos? ( virtual/krb5 )
+ kwallet? ( $(add_frameworks_dep kwallet) )
+ X? ( $(add_qt_dep qtx11extras) )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_qt_dep qtconcurrent)
+ handbook? ( $(add_frameworks_dep kdoctools) )
+ test? ( sys-libs/zlib )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXrender
+ x11-proto/xproto
+ )
+"
+PDEPEND="
+ $(add_frameworks_dep kded)
+"
+RDEPEND="${COMMON_DEPEND}"
+
+# tests hang
+RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}/${P}-fix-desktop-launch.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package acl ACL)
+ $(cmake-utils_use_find_package handbook KF5DocTools)
+ $(cmake-utils_use_find_package kerberos GSSAPI)
+ $(cmake-utils_use_find_package kwallet KF5Wallet)
+ $(cmake-utils_use_find_package X X11)
+ )
+
+ kde5_src_configure
+}