summaryrefslogtreecommitdiff
path: root/kde-frameworks/kwallet
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-08-11 14:35:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-08-11 14:35:16 +0200
commite9e7fbc7f1c7514a10cef7a47b4a940d0676410e (patch)
tree2938f0df53e4ecfd1cfb02fe5b2f9757b497e9cd /kde-frameworks/kwallet
parentc3a50f8b45e490fa4a9277759c87b7ca96a3242d (diff)
downloadgentoo-e9e7fbc7f1c7514a10cef7a47b4a940d0676410e.tar.gz
gentoo-e9e7fbc7f1c7514a10cef7a47b4a940d0676410e.tar.xz
kde-frameworks: Add KDE Frameworks 5.49.0
Package-Manager: Portage-2.3.45, Repoman-2.3.10
Diffstat (limited to 'kde-frameworks/kwallet')
-rw-r--r--kde-frameworks/kwallet/Manifest1
-rw-r--r--kde-frameworks/kwallet/kwallet-5.49.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/kde-frameworks/kwallet/Manifest b/kde-frameworks/kwallet/Manifest
index b57b7f5054f..49dac0577db 100644
--- a/kde-frameworks/kwallet/Manifest
+++ b/kde-frameworks/kwallet/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-5.46.0.tar.xz 307032 BLAKE2B c579c28981ab90048e8ebeffce9d679914441c2bca7f4850f87f6c3fe5af218ebff5645eafb6d52497b54dadbefa5efc5e1f376d87df0775c834023ce8173614 SHA512 244c386d5739752fdc27a3ef9b5a5a90a529ab842e7337b8ef9c539781f230bfd0dac487cda370a75bd9a6c0eda52549c9dda0fd6a27b1d243b373b05cd57d46
DIST kwallet-5.48.0.tar.xz 307004 BLAKE2B 5064d1fe80d7d910baed17bce6ff2fb8f8ea922b62abe2601b5e6f2026e237deb403ed9fee636be848b989493b1acde0d72ef92abadd5e2cf80fea48b2009b46 SHA512 465c6839f5a47126f785381f0a8b01c03aa6952c606ff1beb639f48f0f57baecff89a48590cebde1b731e8a931f96ccc0ec9e4df786aa947962cc1999c188db4
+DIST kwallet-5.49.0.tar.xz 307060 BLAKE2B 0afb825880a0f5ed5b266cb14d77d8f1571fdd06878a403db97f3f371520ddce66e1889c45114b06d7a48345790479d1ecca7714954c9cb4510fb0d8f9810df4 SHA512 0ce685ebe5b9411f38cbb28cf18d44cdcfda0ae19faa6336343e0df8a824a8ee4a8932e6df92a6ab1ba024f863e81c9ea7966a1b347cf0a66787b9ccc3605136
diff --git a/kde-frameworks/kwallet/kwallet-5.49.0.ebuild b/kde-frameworks/kwallet/kwallet-5.49.0.ebuild
new file mode 100644
index 00000000000..9ebbc724def
--- /dev/null
+++ b/kde-frameworks/kwallet/kwallet-5.49.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Framework providing desktop-wide storage for passwords"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="gpg +man"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ dev-libs/libgcrypt:0=
+ gpg? ( >=app-crypt/gpgme-1.7.1[cxx,qt5] )
+"
+DEPEND="${RDEPEND}
+ man? ( $(add_frameworks_dep kdoctools) )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package gpg Gpgmepp)
+ $(cmake-utils_use_find_package man KF5DocTools)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ if ! has_version "kde-plasma/kwallet-pam" || ! has_version "kde-apps/kwalletmanager:5" ; then
+ elog
+ elog "Install kde-plasma/kwallet-pam for auto-unlocking after account login."
+ elog "Install kde-apps/kwalletmanager:5 to manage your kwallet."
+ elog
+ fi
+ if has_version "kde-apps/kwalletd"; then
+ elog "Starting with 5.34.0-r1, ${PN} is able to serve applications"
+ elog "that still require old kwalletd4. After migration has finished,"
+ elog "kde-apps/kwalletd can be removed."
+ fi
+ elog "For more information, read https://wiki.gentoo.org/wiki/KDE#KWallet"
+}