summaryrefslogtreecommitdiff
path: root/kde-frameworks/purpose
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-05-12 14:55:36 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-05-12 16:01:15 +0200
commit1e62bbc175408949f57833235bf3bcfecf99638c (patch)
tree0acd97bd97458eb52c5d438429d281b927e77f79 /kde-frameworks/purpose
parent764f495d5fd70325f9e907b04f84af29151cbcc1 (diff)
downloadgentoo-1e62bbc175408949f57833235bf3bcfecf99638c.tar.gz
gentoo-1e62bbc175408949f57833235bf3bcfecf99638c.tar.xz
kde-frameworks: Add KDE Frameworks 5.46.0
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'kde-frameworks/purpose')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-5.46.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
index ababe4c7e18..1c2117c717c 100644
--- a/kde-frameworks/purpose/Manifest
+++ b/kde-frameworks/purpose/Manifest
@@ -1,2 +1,3 @@
DIST purpose-5.43.0.tar.xz 117084 BLAKE2B d68e6153524cac9ab6e221433d5781e0d4060b734cef27786cdafa9dd96a0eda410b1bc7371dc49db7846be48474cedd1dbc2b224811514913d0adf0eec8c79c SHA512 5cd1b90b120111d1d8ba4d3103143679026bedc4de29acfe5d25a39464a1277450030d7ac505cc322385cf9d300c7009c99ce57a21acafb6ac07ab6186ec25a5
DIST purpose-5.45.0.tar.xz 118628 BLAKE2B 51320ce7481c55298f78eadd6908914f846f7f832a8b76950e583472cfc8b4132a0723e0fe45d180d16835093e26056bf6b5b9d033f8c2241f0a30aeca5f4322 SHA512 964b5c858d799cf828e806c61415135aab7b0d18be8a3e177455b7d01f249a5e2981bd41202b1567251ab0037b0ed51357eeb6aa8ba44b0d12b5f773c5454fa8
+DIST purpose-5.46.0.tar.xz 119424 BLAKE2B d786255ff0032e5c06414e5f42a06299d604bc76425832646b20f37887e80ed8a75eca0ff551993cb70c761241c317f14336c4e38d9bd9c4c0c971d4e461d044 SHA512 682dff7d8b160203b81bada628637c82822bf020acdd838cfc298b978b2b695ad413a40d955fd76c2bbed3c0debee4ebf17f31e34951ef50a1a75c912725c207
diff --git a/kde-frameworks/purpose/purpose-5.46.0.ebuild b/kde-frameworks/purpose/purpose-5.46.0.ebuild
new file mode 100644
index 00000000000..6ca976f20fe
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.46.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_QTHELP="false"
+KDE_TEST="forceoptional"
+inherit kde5
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+kaccounts"
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ kaccounts? (
+ $(add_kdeapps_dep kaccounts-integration)
+ net-libs/accounts-qt
+ )
+"
+RDEPEND="${DEPEND}"
+
+# requires running environment
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package kaccounts KAccounts)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst(){
+ kde5_pkg_postinst
+
+ if ! has_version "kde-misc/kdeconnect[app]" ; then
+ elog "Optional runtime dependency:"
+ elog "kde-misc/kdeconnect[app] (send through KDE Connect)"
+ fi
+}