summaryrefslogtreecommitdiff
path: root/kde-frameworks/sonnet
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-04-14 15:47:50 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-14 15:48:15 +0200
commit9d3b28c5d21a2b1a312e1b9f8a29776bbb4b2649 (patch)
treeb68374ed2a634ca75fceacc9c94d0fca324592e5 /kde-frameworks/sonnet
parent49d0cca0f886e06d54896ae70b5d24a364ef17e3 (diff)
downloadgentoo-9d3b28c5d21a2b1a312e1b9f8a29776bbb4b2649.tar.gz
gentoo-9d3b28c5d21a2b1a312e1b9f8a29776bbb4b2649.tar.xz
kde-frameworks: Add KDE Frameworks 5.45.0
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'kde-frameworks/sonnet')
-rw-r--r--kde-frameworks/sonnet/Manifest1
-rw-r--r--kde-frameworks/sonnet/sonnet-5.45.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/Manifest b/kde-frameworks/sonnet/Manifest
index 4f1606e6134..28ad941de60 100644
--- a/kde-frameworks/sonnet/Manifest
+++ b/kde-frameworks/sonnet/Manifest
@@ -1,2 +1,3 @@
DIST sonnet-5.43.0.tar.xz 286196 BLAKE2B e5f18c9468f612a30098faed7f84e447a8de88c98e905805115a24b2aab2d7546d561723842d734d4be3763ac42fd43f99b1be11860cc68cc004578073eaffcf SHA512 63ee853d5f2df8b8163253add74418e46810188d58fc4ea56ee1d6dc6cd2f25b89c40f21039840c1992b2ce84e44acce26373cedb70770ca3d806e1dc73a0aa0
DIST sonnet-5.44.0.tar.xz 285492 BLAKE2B 7cd2558c71017a16f40712532b8f3ffdd082bdbbebd68481d40a6055c4f2d36990afad0e4611dacbc36b6568762447d50fa5c2706c7c20f1d33dd90757a1fece SHA512 a3909673c0949f19d16a2a4b9036f1fd572d5d88990bf1147cb63484a08ae2ca70c479ac5c196b32e8f1b19359ffbabf2394b507dce93a1fc86bb3ae43a73e60
+DIST sonnet-5.45.0.tar.xz 285628 BLAKE2B 88789ae9609e9f972f5c402e58a6e8fd1188f10036b15873171a056fba17ca5c292902f0cb7059265aa0a51c907f154b111bca29bc4a7f7e005c5243fddece04 SHA512 df35de0761c317c49ef0c8b74a7e67b4c1f1d23dedd67e6e5c05bd77c976b7909ab788f13dfcd670bea04368f2c733737701beacd42785d13c3e4a5a1cd57cf4
diff --git a/kde-frameworks/sonnet/sonnet-5.45.0.ebuild b/kde-frameworks/sonnet/sonnet-5.45.0.ebuild
new file mode 100644
index 00000000000..c71996ffd9f
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.45.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="aspell +hunspell nls"
+
+RDEPEND="
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell:= )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package aspell ASPELL)
+ $(cmake-utils_use_find_package hunspell HUNSPELL)
+ )
+
+ kde5_src_configure
+}