summaryrefslogtreecommitdiff
path: root/kde-frameworks/sonnet
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-02-10 14:15:37 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-02-11 23:00:24 +0100
commita37abaa67c24e28e5e853a9f9e8ed3381ceff877 (patch)
treee82c32cd1411c52fe9216880222174a0ef3c2bd9 /kde-frameworks/sonnet
parente06a02d1bb7eeecfe1fd66b9081cfed18058e428 (diff)
downloadgentoo-a37abaa67c24e28e5e853a9f9e8ed3381ceff877.tar.gz
gentoo-a37abaa67c24e28e5e853a9f9e8ed3381ceff877.tar.xz
kde-frameworks: Add KDE Frameworks 5.43.0
Bug: https://bugs.gentoo.org/647306 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'kde-frameworks/sonnet')
-rw-r--r--kde-frameworks/sonnet/Manifest1
-rw-r--r--kde-frameworks/sonnet/sonnet-5.43.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/Manifest b/kde-frameworks/sonnet/Manifest
index e2b70b78a5a..5a1c5a8be86 100644
--- a/kde-frameworks/sonnet/Manifest
+++ b/kde-frameworks/sonnet/Manifest
@@ -1,2 +1,3 @@
DIST sonnet-5.40.0.tar.xz 284824 BLAKE2B fdecd27ab93d346884cfb0ec6c21cc15451a8f5f8060b8037cdc7197ddbdfe31ce74774dd1875e17496cc1f24dff7e74f11095d098db7b18ada420b6da2f2023 SHA512 bf304b06607a1c98467621018445638e6e7fe96198c296452b853d5f593da406b247bc812616b354d114d83a5156df7794fa041e0a41ebd6f3d9e322a7a47d0e
DIST sonnet-5.42.0.tar.xz 285832 BLAKE2B c473fd2e159d8c34622f75dc4c473bec76144ed192e5627b663fcfddd5eaeae0eed5dbec02bc886f733331c02b3923e057c0ea4a1f488146930a424bd840a486 SHA512 f066d54107895970fb4502a3b6987373300a2c753e54ed31b25c952eb2c9e4d40cb2ea98a14bffd6e05147eee8ac7d59c210b04809bf99c826cd0c93e4edec01
+DIST sonnet-5.43.0.tar.xz 286196 BLAKE2B e5f18c9468f612a30098faed7f84e447a8de88c98e905805115a24b2aab2d7546d561723842d734d4be3763ac42fd43f99b1be11860cc68cc004578073eaffcf SHA512 63ee853d5f2df8b8163253add74418e46810188d58fc4ea56ee1d6dc6cd2f25b89c40f21039840c1992b2ce84e44acce26373cedb70770ca3d806e1dc73a0aa0
diff --git a/kde-frameworks/sonnet/sonnet-5.43.0.ebuild b/kde-frameworks/sonnet/sonnet-5.43.0.ebuild
new file mode 100644
index 00000000000..c71996ffd9f
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.43.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="aspell +hunspell nls"
+
+RDEPEND="
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell:= )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package aspell ASPELL)
+ $(cmake-utils_use_find_package hunspell HUNSPELL)
+ )
+
+ kde5_src_configure
+}