summaryrefslogtreecommitdiff
path: root/kde-frameworks
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-08-15 11:10:34 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-08-15 11:10:55 +0200
commit51e316e8aa8dded60a0b5decbd2e0943828146c9 (patch)
tree6ee50076a5edd566e65834567b2a800d50adef1c /kde-frameworks
parentb64a1137533d1a4485531730c67fc2afae467f46 (diff)
downloadgentoo-51e316e8aa8dded60a0b5decbd2e0943828146c9.tar.gz
gentoo-51e316e8aa8dded60a0b5decbd2e0943828146c9.tar.xz
kde-frameworks/extra-cmake-modules: Drop old
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.37.0.ebuild62
-rw-r--r--kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-5.37.0-ecmaddtest.patch74
2 files changed, 0 insertions, 136 deletions
diff --git a/kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.37.0.ebuild b/kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.37.0.ebuild
deleted file mode 100644
index 231e84818f0..00000000000
--- a/kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.37.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-KDE_AUTODEPS="false"
-KDE_DEBUG="false"
-KDE_QTHELP="false"
-KDE_TEST="false"
-inherit kde5 python-any-r1
-
-DESCRIPTION="Extra modules and scripts for CMake"
-HOMEPAGE="https://projects.kde.org/projects/kdesupport/extra-cmake-modules"
-
-LICENSE="BSD"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
-IUSE="doc test"
-
-DEPEND="
- doc? (
- ${PYTHON_DEPS}
- $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')
- )
- test? (
- $(add_qt_dep qtcore)
- $(add_qt_dep linguist-tools)
- )
-"
-RDEPEND="
- app-arch/libarchive[bzip2]
-"
-
-PATCHES=( "${FILESDIR}/${P}-ecmaddtest.patch" )
-
-python_check_deps() {
- has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- use doc && python-any-r1_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_HTML_DOCS="$(usex doc)"
- -DBUILD_MAN_DOCS="$(usex doc)"
- -DDOC_INSTALL_DIR="/usr/share/doc/${PF}"
- )
- use test && mycmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_PythonModuleGeneration=ON )
-
- cmake-utils_src_configure
-}
-
-src_test() {
- # ECMToolchainAndroidTest passes but then breaks src_install
- local myctestargs=(
- -E "(ECMToolchainAndroidTest)"
- )
-
- kde5_src_test
-}
diff --git a/kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-5.37.0-ecmaddtest.patch b/kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-5.37.0-ecmaddtest.patch
deleted file mode 100644
index fe867541889..00000000000
--- a/kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-5.37.0-ecmaddtest.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-From b99d2d2c5dedcaba9745dddc1dd7b8d4811babf1 Mon Sep 17 00:00:00 2001
-From: Kevin Funk <kfunk@kde.org>
-Date: Mon, 7 Aug 2017 15:50:25 +0200
-Subject: RFC: Make ECMAddTests respect BUILD_TESTING
-
-Summary:
-Use-case: Make building unit tests optional, by just following the CMake
-BUILD_TESTING option.
-
-The usual approach to conditionally build tests is to do:
-```
-if (BUILD_TESTING)
- add_executable(TestOne TestOne.cpp)
- target_link_libraries(TestOne my_library)
-endif()
-```
-
-or:
-
-```
-if (BUILD_TESTING)
- add_subdirectory(tests)
-endif()
-```
-
-This patch just turns all calls to ecm_add_test(...) into no-ops if
-BUILD_TESTING=OFF.
-
-See:
- https://cmake.org/cmake/help/v3.6/module/CTest.html
-
-Reviewers: vkrause
-
-Reviewed By: vkrause
-
-Subscribers: kossebau, vkrause, elvisangelaccio, asturmlechner, apol, #frameworks, #build_system
-
-Tags: #frameworks, #build_system
-
-Differential Revision: https://phabricator.kde.org/D7187
----
- modules/ECMAddTests.cmake | 10 ++++++++++
- 1 file changed, 10 insertions(+)
-
-diff --git a/modules/ECMAddTests.cmake b/modules/ECMAddTests.cmake
-index 9667388..c77a7aa 100644
---- a/modules/ECMAddTests.cmake
-+++ b/modules/ECMAddTests.cmake
-@@ -49,6 +49,12 @@
- # be given; this will be used for both the target and test names (and, as with
- # ecm_add_tests(), the NAME_PREFIX argument will be prepended to the test name).
- #
-+# If BUILD_TESTING is set to OFF, ecm_add_test will turn into a no-op and thus
-+# will not add any test-related targets
-+#
-+# BUILD_TESTING is created as a cache variable by the CTest module and by the
-+# :kde-module:`KDECMakeSettings` module.
-+#
- #
- # Since pre-1.0.0.
-
-@@ -84,6 +90,10 @@ include(ECMMarkAsTest)
- include(ECMMarkNonGuiExecutable)
-
- function(ecm_add_test)
-+ if(NOT BUILD_TESTING)
-+ return() # turn this function into a no-op
-+ endif()
-+
- set(options GUI)
- # TARGET_NAME_VAR and TEST_NAME_VAR are undocumented args used by
- # ecm_add_tests
---
-cgit v0.11.2