summaryrefslogtreecommitdiff
path: root/kde-frameworks
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-03-18 14:53:21 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-03-19 01:06:51 +0100
commitc848a2355c8ede11b283cd40babf915c60700f2c (patch)
treea83080d3d1daa2e90cee62f5d2758504d0568c2d /kde-frameworks
parentb15e931deb909b9b6eb2b3c4b9912fa950a6d854 (diff)
downloadgentoo-c848a2355c8ede11b283cd40babf915c60700f2c.tar.gz
gentoo-c848a2355c8ede11b283cd40babf915c60700f2c.tar.xz
kde-frameworks/plasma: Drop USE=egl and tie it together w/ USE=wayland
In short: X11 default is GLX with no UI handle to change it, on Wayland EGL is required. It is then much simpler to drop USE=egl and enable EGL support together with the wayland USE flag. See also: https://blog.martin-graesslin.com/blog/2016/08/opengl-changes-in-kwin-compositing/ Reported-by: Martijn Schmidt <martijn.schmidt@gmail.com> Gentoo-bug: 610892 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/plasma/plasma-5.32.0-r1.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/kde-frameworks/plasma/plasma-5.32.0-r1.ebuild b/kde-frameworks/plasma/plasma-5.32.0-r1.ebuild
index ba8af05f8de..21e3b71251c 100644
--- a/kde-frameworks/plasma/plasma-5.32.0-r1.ebuild
+++ b/kde-frameworks/plasma/plasma-5.32.0-r1.ebuild
@@ -10,7 +10,7 @@ inherit kde5
DESCRIPTION="Plasma framework"
LICENSE="LGPL-2+"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="egl gles2 wayland X"
+IUSE="gles2 wayland X"
COMMON_DEPEND="
$(add_frameworks_dep kactivities)
@@ -36,9 +36,11 @@ COMMON_DEPEND="
$(add_qt_dep qtsql)
$(add_qt_dep qtsvg)
$(add_qt_dep qtwidgets)
- egl? ( media-libs/mesa[egl] )
!gles2? ( virtual/opengl )
- wayland? ( $(add_frameworks_dep kwayland) )
+ wayland? (
+ $(add_frameworks_dep kwayland)
+ media-libs/mesa[egl]
+ )
X? (
$(add_qt_dep qtx11extras)
x11-libs/libX11
@@ -59,8 +61,8 @@ PATCHES=( "${FILESDIR}/${P}-prefix-qstringlist.patch" )
src_configure() {
local mycmakeargs=(
- $(cmake-utils_use_find_package egl EGL)
$(cmake-utils_use_find_package !gles2 OpenGL)
+ $(cmake-utils_use_find_package wayland EGL)
$(cmake-utils_use_find_package wayland KF5Wayland)
$(cmake-utils_use_find_package X X11)
$(cmake-utils_use_find_package X XCB)