summaryrefslogtreecommitdiff
path: root/kde-frameworks
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-11-28 19:36:10 +0100
committerJohannes Huber <johu@gentoo.org>2016-11-28 19:36:10 +0100
commite9172037f4e3386e63d186ff56a3ab1c4ae133c6 (patch)
treec577958da745cb1fb22309ace2303485543fcd55 /kde-frameworks
parent725d5fd492146167fd0b22ff3912909efa90396a (diff)
downloadgentoo-e9172037f4e3386e63d186ff56a3ab1c4ae133c6.tar.gz
gentoo-e9172037f4e3386e63d186ff56a3ab1c4ae133c6.tar.xz
kde-frameworks/sonnet: Fix configure w/ hunspell 1.5
Revision bump adds upstream to fix configure to search for hunspell 1.5 too. Package-Manager: portage-2.3.2
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/sonnet/files/sonnet-5.28.0-hunspell-1.5.patch21
-rw-r--r--kde-frameworks/sonnet/sonnet-5.28.0-r1.ebuild33
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/files/sonnet-5.28.0-hunspell-1.5.patch b/kde-frameworks/sonnet/files/sonnet-5.28.0-hunspell-1.5.patch
new file mode 100644
index 00000000000..bc4bb93e5d6
--- /dev/null
+++ b/kde-frameworks/sonnet/files/sonnet-5.28.0-hunspell-1.5.patch
@@ -0,0 +1,21 @@
+commit 5fc1e9679e0607d7d918b27ee13092a234abefe6
+Author: Heiko Becker <heirecka@exherbo.org>
+Date: Fri Nov 25 15:13:53 2016 +0100
+
+ Also search for hunspell-1.5
+
+ REVIEW: 129559
+
+diff --git a/cmake/FindHUNSPELL.cmake b/cmake/FindHUNSPELL.cmake
+index f028abe..d5ed183 100644
+--- a/cmake/FindHUNSPELL.cmake
++++ b/cmake/FindHUNSPELL.cmake
+@@ -14,7 +14,7 @@ ENDIF (HUNSPELL_INCLUDE_DIR AND HUNSPELL_LIBRARIES)
+
+ FIND_PATH(HUNSPELL_INCLUDE_DIR hunspell/hunspell.hxx )
+
+-FIND_LIBRARY(HUNSPELL_LIBRARIES NAMES hunspell-1.4 hunspell-1.3 hunspell-1.2)
++FIND_LIBRARY(HUNSPELL_LIBRARIES NAMES hunspell-1.5 hunspell-1.4 hunspell-1.3 hunspell-1.2)
+
+ # handle the QUIETLY and REQUIRED arguments and set HUNSPELL_FOUND to TRUE if
+ # all listed variables are TRUE
diff --git a/kde-frameworks/sonnet/sonnet-5.28.0-r1.ebuild b/kde-frameworks/sonnet/sonnet-5.28.0-r1.ebuild
new file mode 100644
index 00000000000..1ff3e9512b1
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.28.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="aspell +hunspell nls"
+
+RDEPEND="
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell:= )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+
+PATCHES=( "${FILESDIR}/${P}-hunspell-1.5.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package aspell ASPELL)
+ $(cmake-utils_use_find_package hunspell HUNSPELL)
+ )
+
+ kde5_src_configure
+}