summaryrefslogtreecommitdiff
path: root/kde-misc/kanyremote
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-misc/kanyremote
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-misc/kanyremote')
-rw-r--r--kde-misc/kanyremote/Manifest2
-rw-r--r--kde-misc/kanyremote/kanyremote-6.3.4.ebuild55
-rw-r--r--kde-misc/kanyremote/kanyremote-6.3.5.ebuild55
-rw-r--r--kde-misc/kanyremote/metadata.xml8
4 files changed, 120 insertions, 0 deletions
diff --git a/kde-misc/kanyremote/Manifest b/kde-misc/kanyremote/Manifest
new file mode 100644
index 00000000000..6103d1a21f0
--- /dev/null
+++ b/kde-misc/kanyremote/Manifest
@@ -0,0 +1,2 @@
+DIST kanyremote-6.3.4.tar.gz 310769 SHA256 ea7f11af91609d3bcb18bd064f3ef0a0f107f58debef7423580bdc53e65d6a4f SHA512 a0f488b33d5c7f974615d7e6bf6df8f2ccd0f0dc4307238cd75833848603801801be24805ca89feb2fe2074c1b78b635029994e3efe0f616205da6d05ca7f023 WHIRLPOOL 3a7a5d937dc7befd9b9d347b5dc6f1eb468308763941054326dd68a5b5fb40e9cc814d96d22ce0334642a31b4a2f0354c3c039fe9e94ad73cace71b8d8dc3af4
+DIST kanyremote-6.3.5.tar.gz 311639 SHA256 3fe3d186b503f43c30b2a8302a79810ee30d1ccf7839ceafcdda651915b4bbfe SHA512 2b40584097b8aedeaf1bbe66c1e4aab0a440111007e735f4573e7fc968ac9a7331e19e4ba288986e3428e7f3aed58d96ff1470101f0ba9098225c0053c706c5c WHIRLPOOL ef40e3e3239c77609d98fa86283f29be751cc2b4590c0ec76412839e3f21df7252cf63b95557ac5f4a61c6610e20029c432865812ccbe02184cf447373b0f214
diff --git a/kde-misc/kanyremote/kanyremote-6.3.4.ebuild b/kde-misc/kanyremote/kanyremote-6.3.4.ebuild
new file mode 100644
index 00000000000..b63de898b04
--- /dev/null
+++ b/kde-misc/kanyremote/kanyremote-6.3.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit autotools python-r1 base
+
+DESCRIPTION="KDE frontend to Anyremote"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/anyremote/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="amd64 x86"
+IUSE="bluetooth"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=app-mobilephone/anyremote-6.0[bluetooth?]
+ dev-python/PyQt4[X,${PYTHON_USEDEP}]
+ kde-base/pykde4:4[${PYTHON_USEDEP}]
+ bluetooth? ( dev-python/pybluez[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+src_prepare() {
+ # using gettextize no-interactive example from dev-util/bless package
+ cp $(type -p gettextize) "${T}"/ || die
+ sed -i -e 's:read dummy < /dev/tty::' "${T}/gettextize" || die
+ "${T}"/gettextize -f --no-changelog > /dev/null || die
+
+ # remove deprecated entry
+ sed -e "/Encoding=UTF-8/d" \
+ -i kanyremote.desktop || die "fixing .desktop file failed"
+
+ # fix documentation directory wrt bug #316087
+ sed -i "s/doc\/${PN}/doc\/${PF}/g" Makefile.am || die
+ eautoreconf
+
+ # disable bluetooth check to avoid errors
+ if ! use bluetooth ; then
+ sed -e "s/usepybluez = True/usepybluez = False/" -i kanyremote || die
+ fi
+}
+
+src_install() {
+ default
+
+ python_replicate_script "${D}"/usr/bin/kanyremote
+}
diff --git a/kde-misc/kanyremote/kanyremote-6.3.5.ebuild b/kde-misc/kanyremote/kanyremote-6.3.5.ebuild
new file mode 100644
index 00000000000..6a1d98fa813
--- /dev/null
+++ b/kde-misc/kanyremote/kanyremote-6.3.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit autotools python-r1
+
+DESCRIPTION="KDE frontend to Anyremote"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/anyremote/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=app-mobilephone/anyremote-6.5[bluetooth?]
+ dev-python/PyQt4[X,${PYTHON_USEDEP}]
+ kde-base/pykde4:4[${PYTHON_USEDEP}]
+ bluetooth? ( dev-python/pybluez[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+src_prepare() {
+ # using gettextize no-interactive example from dev-util/bless package
+ cp $(type -p gettextize) "${T}"/ || die
+ sed -i -e 's:read dummy < /dev/tty::' "${T}/gettextize" || die
+ "${T}"/gettextize -f --no-changelog > /dev/null || die
+
+ # remove deprecated entry
+ sed -e "/Encoding=UTF-8/d" \
+ -i kanyremote.desktop || die "fixing .desktop file failed"
+
+ # fix documentation directory wrt bug #316087
+ sed -i "s/doc\/${PN}/doc\/${PF}/g" Makefile.am || die
+ eautoreconf
+
+ # disable bluetooth check to avoid errors
+ if ! use bluetooth ; then
+ sed -e "s/usepybluez = True/usepybluez = False/" -i kanyremote || die
+ fi
+}
+
+src_install() {
+ default
+
+ python_replicate_script "${D}"/usr/bin/kanyremote
+}
diff --git a/kde-misc/kanyremote/metadata.xml b/kde-misc/kanyremote/metadata.xml
new file mode 100644
index 00000000000..82648daa075
--- /dev/null
+++ b/kde-misc/kanyremote/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <upstream>
+ <remote-id type="sourceforge">anyremote</remote-id>
+ </upstream>
+</pkgmetadata>