summaryrefslogtreecommitdiff
path: root/kde-misc/kcm-ufw
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-misc/kcm-ufw
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-misc/kcm-ufw')
-rw-r--r--kde-misc/kcm-ufw/Manifest1
-rw-r--r--kde-misc/kcm-ufw/files/kcm-ufw-0.4.3-linguas.patch26
-rw-r--r--kde-misc/kcm-ufw/kcm-ufw-0.4.3-r1.ebuild42
-rw-r--r--kde-misc/kcm-ufw/metadata.xml9
4 files changed, 78 insertions, 0 deletions
diff --git a/kde-misc/kcm-ufw/Manifest b/kde-misc/kcm-ufw/Manifest
new file mode 100644
index 00000000000..ff2ce956dd3
--- /dev/null
+++ b/kde-misc/kcm-ufw/Manifest
@@ -0,0 +1 @@
+DIST kcm_ufw-0.4.3.tar.bz2 766909 SHA256 b38ff531284904d4e5d54c7f63a0bb2a5c254f04551f67f844db65ff6ab54a10 SHA512 d2e638940a493eb31f9ba3fd1e9546caaa041d539da0bd16f9c6602ed5ea73edb852944e397749df4b843ec9c27ed3a8e6312aefd4693ceda42bccfd5a2804ba WHIRLPOOL c9e952057b4946f8852998249eb8dc8865aa559303a3c1d1154920d9ff0077d3be38373cd80b1861e26738d7033105d7cd4d90b20829af5bc3f22c6fb587cb7f
diff --git a/kde-misc/kcm-ufw/files/kcm-ufw-0.4.3-linguas.patch b/kde-misc/kcm-ufw/files/kcm-ufw-0.4.3-linguas.patch
new file mode 100644
index 00000000000..6fc3c90922f
--- /dev/null
+++ b/kde-misc/kcm-ufw/files/kcm-ufw-0.4.3-linguas.patch
@@ -0,0 +1,26 @@
+Comply with standard KDE conventions so that linguas may be handled by the eclass,
+instead of implementing package-specific hacks.
+
+--- po/CMakeLists.txt
++++ po/CMakeLists.txt
+@@ -8,19 +8,7 @@
+ set(catalogname kcm_ufw)
+ add_custom_target(translations ALL)
+
+- if (UFW_ES_TRANSLATION)
+- LIST(APPEND PO_FILES "${CMAKE_CURRENT_SOURCE_DIR}/es.po")
+- endif (UFW_ES_TRANSLATION)
+-
+- if (UFW_FR_TRANSLATION)
+- LIST(APPEND PO_FILES "${CMAKE_CURRENT_SOURCE_DIR}/fr.po")
+- endif (UFW_FR_TRANSLATION)
+-
+- if (UFW_LT_TRANSLATION)
+- LIST(APPEND PO_FILES "${CMAKE_CURRENT_SOURCE_DIR}/lt.po")
+- endif (UFW_LT_TRANSLATION)
+-
+- # file(GLOB PO_FILES *.po)
++ file(GLOB PO_FILES *.po)
+ foreach(_poFile ${PO_FILES})
+ get_filename_component(_poFileName ${_poFile} NAME)
+ string(REGEX REPLACE "^${catalogname}_?" "" _langCode ${_poFileName} )
diff --git a/kde-misc/kcm-ufw/kcm-ufw-0.4.3-r1.ebuild b/kde-misc/kcm-ufw/kcm-ufw-0.4.3-r1.ebuild
new file mode 100644
index 00000000000..e155f5a3afc
--- /dev/null
+++ b/kde-misc/kcm-ufw/kcm-ufw-0.4.3-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_DOC_DIRS="docs/%lingua"
+KDE_HANDBOOK="optional"
+KDE_LINGUAS="es fr lt"
+PYTHON_COMPAT=( python2_7 )
+inherit python-r1 kde4-base multilib
+
+MY_P="${P/-/_}"
+
+DESCRIPTION="KCM module to control the Uncomplicated Firewall"
+HOMEPAGE="http://kde-apps.org/content/show.php?content=137789"
+SRC_URI="http://craigd.wikispaces.com/file/view/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="debug"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ >=net-firewall/ufw-0.31
+ sys-auth/polkit-kde-agent
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep kcmshell)
+"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}/${P}-linguas.patch" )
+
+src_install() {
+ kde4-base_src_install
+ python_replicate_script "${D}"/usr/$(get_libdir)/kde4/libexec/kcm_ufw_helper.py
+}
diff --git a/kde-misc/kcm-ufw/metadata.xml b/kde-misc/kcm-ufw/metadata.xml
new file mode 100644
index 00000000000..87c94322d47
--- /dev/null
+++ b/kde-misc/kcm-ufw/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <maintainer>
+ <email>thev00d00@gentoo.org</email>
+ <name>Ian Whyman</name>
+ </maintainer>
+</pkgmetadata>