summaryrefslogtreecommitdiff
path: root/kde-misc/kimtoy/kimtoy-1.91.ebuild
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-02-09 21:49:04 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-02-09 23:41:25 +1100
commitab96f62ade0da5a5f642708318b8057f1c65538b (patch)
treece1cfbf0526d63033e7b29e2558c0c6b24d60bcf /kde-misc/kimtoy/kimtoy-1.91.ebuild
parentd42dffdebfcce5de63aecd3dfc7f7f07e6926cfd (diff)
downloadgentoo-ab96f62ade0da5a5f642708318b8057f1c65538b.tar.gz
gentoo-ab96f62ade0da5a5f642708318b8057f1c65538b.tar.xz
kde-misc/kimtoy: version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'kde-misc/kimtoy/kimtoy-1.91.ebuild')
-rw-r--r--kde-misc/kimtoy/kimtoy-1.91.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/kde-misc/kimtoy/kimtoy-1.91.ebuild b/kde-misc/kimtoy/kimtoy-1.91.ebuild
new file mode 100644
index 00000000000..b87b7266765
--- /dev/null
+++ b/kde-misc/kimtoy/kimtoy-1.91.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="An input method frontend for Plasma"
+HOMEPAGE="http://kde-apps.org/content/show.php?content=140967"
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ SRC_URI="http://kde-apps.org/CONTENT/content-files/140967-${P}.tar.bz2"
+fi
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+IUSE="libressl scim semantic-desktop"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep plasma)
+ app-i18n/ibus
+ dev-libs/glib:2
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-libs/libpng:0=[apng]
+ x11-libs/libX11
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ scim? (
+ >=app-i18n/scim-1.4.9
+ dev-libs/dbus-c++
+ )
+ semantic-desktop? ( $(add_frameworks_dep kfilemetadata) )
+"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/gettext
+ x11-misc/shared-mime-info
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-misc/kimtoy:4
+ >=app-i18n/fcitx-4.0
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package scim SCIM)
+ $(cmake-utils_use_find_package scim DBusCXX)
+ $(cmake-utils_use_find_package semantic-desktop KF5FileMetaData)
+ )
+
+ kde5_src_configure
+}