summaryrefslogtreecommitdiff
path: root/kde-misc/ksplasher
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-misc/ksplasher
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-misc/ksplasher')
-rw-r--r--kde-misc/ksplasher/Manifest1
-rw-r--r--kde-misc/ksplasher/files/ksplasher-pillow.patch13
-rw-r--r--kde-misc/ksplasher/ksplasher-2.0_beta2-r2.ebuild41
-rw-r--r--kde-misc/ksplasher/metadata.xml8
4 files changed, 63 insertions, 0 deletions
diff --git a/kde-misc/ksplasher/Manifest b/kde-misc/ksplasher/Manifest
new file mode 100644
index 00000000000..f0592ad4d3b
--- /dev/null
+++ b/kde-misc/ksplasher/Manifest
@@ -0,0 +1 @@
+DIST ksplasherx2.0beta2.tar.gz 278173 SHA256 218ba4268218d1c08ce7662ca682886511f75cc067c5958eb8a11610d7864682 SHA512 cb1f284039a5542a2cb578c9bd32fc7e16d8415bdf777ac330b1fd4c4c774f982236e264268bd364bc1c9cbe4d274612a243437fbc308f8fa00a25b4e27fa649 WHIRLPOOL f3cff409d0aefb74213aaea3d7a802ab9ebdf479f9520be2923de67324387a443dd5c5e91e4cfd6653a91796a3986f2a29873f5ebbcbc1d7f5b8817395e2fa9f
diff --git a/kde-misc/ksplasher/files/ksplasher-pillow.patch b/kde-misc/ksplasher/files/ksplasher-pillow.patch
new file mode 100644
index 00000000000..467c60c4e99
--- /dev/null
+++ b/kde-misc/ksplasher/files/ksplasher-pillow.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/show_bug.cgi?id=471520
+--- a/src/modules/filters.py
++++ b/src/modules/filters.py
+@@ -9,7 +9,8 @@
+ #
+
+ from __future__ import division
+-import sys, os, getopt, Image, ImageFile, ImageEnhance
++import sys, os, getopt
++from PIL import Image, ImageFile, ImageEnhance
+
+
+ def blink(srcfile1,destfile):
diff --git a/kde-misc/ksplasher/ksplasher-2.0_beta2-r2.ebuild b/kde-misc/ksplasher/ksplasher-2.0_beta2-r2.ebuild
new file mode 100644
index 00000000000..13f51c9e82c
--- /dev/null
+++ b/kde-misc/ksplasher/ksplasher-2.0_beta2-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1 eutils
+
+DESCRIPTION="A KSplashX engine (KDE4) Splash Screen Creator"
+HOMEPAGE="http://ksplasher.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}x${PV/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S=${WORKDIR}/${PN}x
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-pillow.patch"
+ # ksplasherx is a bash script which calls 'python foo'. We fix it here.
+ sed -i -e 's:python:/usr/bin/env python2:g' ksplasherx || die
+}
+
+src_install() {
+ dobin ksplasherx || die
+ insinto /usr/share/ksplasherx
+ doins -r src || die
+ python_fix_shebang "${ED}/usr/share/ksplasherx/src/"
+ doicon ksicon.png
+ make_desktop_entry ${PN}x KSplasherX ksicon "Qt;KDE;Graphics"
+ dodoc README
+}
diff --git a/kde-misc/ksplasher/metadata.xml b/kde-misc/ksplasher/metadata.xml
new file mode 100644
index 00000000000..5302f24179c
--- /dev/null
+++ b/kde-misc/ksplasher/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <upstream>
+ <remote-id type="sourceforge">ksplasher</remote-id>
+ </upstream>
+</pkgmetadata>