summaryrefslogtreecommitdiff
path: root/kde-misc/plasma-widget-message-indicator
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-misc/plasma-widget-message-indicator
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-misc/plasma-widget-message-indicator')
-rw-r--r--kde-misc/plasma-widget-message-indicator/Manifest1
-rw-r--r--kde-misc/plasma-widget-message-indicator/files/plasma-widget-message-indicator-0.5.8-libindicate.patch11
-rw-r--r--kde-misc/plasma-widget-message-indicator/metadata.xml8
-rw-r--r--kde-misc/plasma-widget-message-indicator/plasma-widget-message-indicator-0.5.8.ebuild31
4 files changed, 51 insertions, 0 deletions
diff --git a/kde-misc/plasma-widget-message-indicator/Manifest b/kde-misc/plasma-widget-message-indicator/Manifest
new file mode 100644
index 00000000000..cd8c2fa4ce7
--- /dev/null
+++ b/kde-misc/plasma-widget-message-indicator/Manifest
@@ -0,0 +1 @@
+DIST plasma-widget-message-indicator-0.5.8.tar.bz2 30641 SHA256 cb5e9c6f6fe1075e508868759dfebad654508c84a3c2a61264eca6b42185de7c SHA512 fb744c7b80fc1db6c3448fd4cd6186e74b6aee360a263f810abfca69d983054b7ed54dd823fa3fc36a854b036825e6a15db9742545d15d9c1038dda9276dde60 WHIRLPOOL 54046b24709d8a8a3014f6f343d2e4a7bb8df9c10e94565629533293ed8083c36a717eb0b9f4a34173893dccda5de59360c36f966f8a2d13334d86b89cf31a6e
diff --git a/kde-misc/plasma-widget-message-indicator/files/plasma-widget-message-indicator-0.5.8-libindicate.patch b/kde-misc/plasma-widget-message-indicator/files/plasma-widget-message-indicator-0.5.8-libindicate.patch
new file mode 100644
index 00000000000..26a677c1c75
--- /dev/null
+++ b/kde-misc/plasma-widget-message-indicator/files/plasma-widget-message-indicator-0.5.8-libindicate.patch
@@ -0,0 +1,11 @@
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -6,7 +6,7 @@ cmake_minimum_required(VERSION 2.6)
+ find_package(KDE4 4.4 REQUIRED)
+ include(KDE4Defaults)
+ find_package(PkgConfig REQUIRED)
+-pkg_check_modules(INDICATE REQUIRED indicate-0.6)
++pkg_search_module(INDICATE REQUIRED indicate-0.6 indicate-0.7)
+ pkg_check_modules(INDICATEQT REQUIRED indicate-qt>=0.2.5)
+ pkg_check_modules(DBUSMENUQT REQUIRED dbusmenu-qt>=0.3.0)
+
diff --git a/kde-misc/plasma-widget-message-indicator/metadata.xml b/kde-misc/plasma-widget-message-indicator/metadata.xml
new file mode 100644
index 00000000000..bdc6a3ada24
--- /dev/null
+++ b/kde-misc/plasma-widget-message-indicator/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <upstream>
+ <remote-id type="launchpad">plasma-widget-message-indicator</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/kde-misc/plasma-widget-message-indicator/plasma-widget-message-indicator-0.5.8.ebuild b/kde-misc/plasma-widget-message-indicator/plasma-widget-message-indicator-0.5.8.ebuild
new file mode 100644
index 00000000000..170f2a88ba0
--- /dev/null
+++ b/kde-misc/plasma-widget-message-indicator/plasma-widget-message-indicator-0.5.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+VIRTUALX_REQUIRED="test"
+inherit kde4-base
+
+DESCRIPTION="Plasmoid for displaying Ayatana indications"
+HOMEPAGE="https://launchpad.net/plasma-widget-message-indicator"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ >=dev-libs/libdbusmenu-qt-0.3.0[qt4(+)]
+ >=dev-libs/libindicate-qt-0.2.5
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/libindicate
+"
+
+# 1 test fails
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/${P}-libindicate.patch" )