summaryrefslogtreecommitdiff
path: root/kde-plasma/ksshaskpass
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-12-09 03:15:30 +1100
committerMichael Palimaka <kensington@gentoo.org>2015-12-09 03:22:50 +1100
commit9ef59ada130055054b5d3e3441fae5384e7e86f7 (patch)
treef685f33d61d3e05acb821b70001f077d9b22fd8b /kde-plasma/ksshaskpass
parentf1d62e0702898ed720a2292ecee8b3519d6a4481 (diff)
downloadgentoo-9ef59ada130055054b5d3e3441fae5384e7e86f7.tar.gz
gentoo-9ef59ada130055054b5d3e3441fae5384e7e86f7.tar.xz
kde-plasma: version bump 5.5.0
Package-Manager: portage-2.2.26
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.5.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 55696f21a8d..6d54b6283eb 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.4.2.tar.xz 19384 SHA256 2bd7ad5d1f0fc9664a9c2b406d987ff9c77b423f982d837dda7f1d5a7a4baa8e SHA512 b202898b757ed38817cd6be6bb3d77253498b3845d4490408cf6467be2bf4d14438120876974496b743ad1a0b3687884e814cb2fc0c5e12b08020ef0010231f0 WHIRLPOOL 6cfad7aeb9c58bf508ebad91afbfb51279e57d97bde7933a23c08915bdcefbdc41b8222090d7fad5bfa91b131b24203ae32986a3556ed938da95c84bb021d0a7
DIST ksshaskpass-5.4.3.tar.xz 19476 SHA256 7eb6025e58e8cd57cab640ab42ff9670ae113317534001be94916610135127a3 SHA512 b8378263806014c225a3c7337c1fcf0a513cf508db718e6154304f49841e0d3744b61a58058093e021f4ace8b282842bb7d90ae5a9ad912af222cbaedaac0aad WHIRLPOOL ed0c6a399bc4338b1b17ea2c790f1f9490eb1f2de01aa3b1aa5dcb8a7c919f5b4895e0eea65c76b624d2071436f1a0c60cc1256d0a320a60b8dccd4ea1af1031
+DIST ksshaskpass-5.5.0.tar.xz 20360 SHA256 10c2c4bbfdab8eb340e1a59f9378178b2c76493f512a7ff7dfceeafd3643a88a SHA512 0449d4719d3ce6d686bfd91b96987bda7f5b83ba4653a408002be2f6d7875743693150d8b4ed77c2e26781091795f248d26d9969a8b5b86d6c8e453386239473 WHIRLPOOL 438bcbec379aee04d52caf41fd6f9f8c39470c2c40a68bb9d32efad7628d336336239d61d8b106f3b68e77f2e16da3a3a28c73837a36541441f3731af686938c
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.5.0.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.5.0.ebuild
new file mode 100644
index 00000000000..1dd193540c9
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.5.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit kde5
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://projects.kde.org/projects/kde/workspace/ksshaskpass"
+KEYWORDS=" ~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ dev-qt/qtwidgets:5
+"
+RDEPEND="
+ ${DEPEND}
+ !net-misc/ksshaskpass
+"
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/plasma/startup
+ doins "${FILESDIR}/ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog ""
+ elog "In order to have ssh-agent start at kde startup,"
+ elog "edit /etc/plasma/startup/agent-startup.sh and uncomment"
+ elog "the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/plasma/shutdown/agent-shutdown.sh to"
+ elog "properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/plasma/startup/ksshaskpass.sh"
+ elog ""
+}