summaryrefslogtreecommitdiff
path: root/kde-plasma/plasma-integration/plasma-integration-5.12.0.ebuild
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-02-06 19:27:47 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-02-06 19:27:47 +0100
commitc6320bb13dc48f0969cc893f4406c7b892b819c3 (patch)
treea01a01e4f3df86e3ea7d5a862ff5d0e8fc1d7f95 /kde-plasma/plasma-integration/plasma-integration-5.12.0.ebuild
parentdacc7a97600c1e54e3741f69fe6ee2e3cef14547 (diff)
downloadgentoo-c6320bb13dc48f0969cc893f4406c7b892b819c3.tar.gz
gentoo-c6320bb13dc48f0969cc893f4406c7b892b819c3.tar.xz
kde-plasma: Add KDE Plasma 5.12.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'kde-plasma/plasma-integration/plasma-integration-5.12.0.ebuild')
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.12.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.12.0.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.12.0.ebuild
new file mode 100644
index 00000000000..1d60d9295f0
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.12.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwayland)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_plasma_dep breeze)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui 'dbus' '' '5=')
+ $(add_qt_dep qtquickcontrols2)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libXcursor
+ x11-libs/libxcb
+"
+RDEPEND="${DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+"
+
+# requires running kde environment
+RESTRICT+=" test"