summaryrefslogtreecommitdiff
path: root/kde-plasma/plasma-mediacenter
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-plasma/plasma-mediacenter
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-plasma/plasma-mediacenter')
-rw-r--r--kde-plasma/plasma-mediacenter/Manifest1
-rw-r--r--kde-plasma/plasma-mediacenter/metadata.xml5
-rw-r--r--kde-plasma/plasma-mediacenter/plasma-mediacenter-5.3.2.ebuild45
3 files changed, 51 insertions, 0 deletions
diff --git a/kde-plasma/plasma-mediacenter/Manifest b/kde-plasma/plasma-mediacenter/Manifest
new file mode 100644
index 00000000000..44d7597a6b2
--- /dev/null
+++ b/kde-plasma/plasma-mediacenter/Manifest
@@ -0,0 +1 @@
+DIST plasma-mediacenter-5.3.2.tar.xz 156644 SHA256 e69991e5a9770d799ef4a530d5792d212415246d10c0634a16f3a0e83cfc935a SHA512 c06f201753f31e3dc9b1fde903ff6552c0b42458200c327698dab5e6addd4e6d0b09d0de0d7cc3c95a940a7db5413d3bf410517a1c5a63975b2db9ff2f3b20b4 WHIRLPOOL 917690fb0b6f67d40acca1c392f42a10a6ade9dfafde36f2acdd13069a324be33af7d300cbf2e1e8c8cf1bd153b363df3ef4ccb9c77262391a724c259f14ae9c
diff --git a/kde-plasma/plasma-mediacenter/metadata.xml b/kde-plasma/plasma-mediacenter/metadata.xml
new file mode 100644
index 00000000000..a23f444b67d
--- /dev/null
+++ b/kde-plasma/plasma-mediacenter/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+</pkgmetadata>
diff --git a/kde-plasma/plasma-mediacenter/plasma-mediacenter-5.3.2.ebuild b/kde-plasma/plasma-mediacenter/plasma-mediacenter-5.3.2.ebuild
new file mode 100644
index 00000000000..5d8e33548ab
--- /dev/null
+++ b/kde-plasma/plasma-mediacenter/plasma-mediacenter-5.3.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit kde5
+
+DESCRIPTION="Unified media experience for any device capable of running KDE"
+KEYWORDS="~amd64"
+IUSE="semantic-desktop"
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep plasma)
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtxml:5
+ media-libs/taglib
+ semantic-desktop? (
+ $(add_plasma_dep baloo)
+ $(add_plasma_dep kfilemetadata)
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep plasma-workspace)
+ dev-qt/qtmultimedia:5[qml]
+ !media-video/plasma-mediacenter
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package semantic-desktop KF5Baloo)
+ $(cmake-utils_use_find_package semantic-desktop KF5FileMetadata)
+ )
+
+ kde5_src_configure
+}