summaryrefslogtreecommitdiff
path: root/kde-plasma
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-24 19:44:00 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-24 19:45:24 +0200
commit148a8177855184a1d69402bfedfdd554c331e1c1 (patch)
tree81f7cee4e62dd9e495e805c5bdfc76b392036244 /kde-plasma
parentdd20aab0399ce5fa2f7b4acd62e73849d6450f91 (diff)
downloadgentoo-148a8177855184a1d69402bfedfdd554c331e1c1.tar.gz
gentoo-148a8177855184a1d69402bfedfdd554c331e1c1.tar.xz
kde-plasma/kinfocenter: Fix cmake warning
Reported-by: Francesco Turco <fturco@fastmail.fm> Closes: https://bugs.gentoo.org/658980 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.12.5.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.12.5.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.12.5.ebuild
index 6b359cfb845..9a294aaa46f 100644
--- a/kde-plasma/kinfocenter/kinfocenter-5.12.5.ebuild
+++ b/kde-plasma/kinfocenter/kinfocenter-5.12.5.ebuild
@@ -60,14 +60,18 @@ RDEPEND="${COMMON_DEPEND}
src_configure() {
local mycmakeargs=(
- $(cmake-utils_use_find_package gles2 OpenGLES)
$(cmake-utils_use_find_package ieee1394 RAW1394)
- $(cmake-utils_use_find_package opengl OpenGL)
$(cmake-utils_use_find_package pci PCIUTILS)
$(cmake-utils_use_find_package wayland EGL)
$(cmake-utils_use_find_package wayland KF5Wayland)
)
+ if has_version "dev-qt/qtgui[gles2]"; then
+ mycmakeargs+=( $(cmake-utils_use_find_package gles2 OpenGLES) )
+ else
+ mycmakeargs+=( $(cmake-utils_use_find_package opengl OpenGL) )
+ fi
+
kde5_src_configure
}