summaryrefslogtreecommitdiff
path: root/kde-plasma
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-02-19 23:39:16 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-02-19 23:42:46 +0100
commit1822ce632f7758b438acb87f3bcd65e51c14332f (patch)
tree9a9801e12a4c8270e5ce38d5d5cbc2084c939961 /kde-plasma
parentb85186aedaa4cd047197272f11f4930125a34491 (diff)
downloadgentoo-1822ce632f7758b438acb87f3bcd65e51c14332f.tar.gz
gentoo-1822ce632f7758b438acb87f3bcd65e51c14332f.tar.xz
kde-plasma/khotkeys: Fix build with KF-5.31
Gentoo-bug: 610040 Package-Manager: portage-2.3.3
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/khotkeys/files/khotkeys-5.8.5-kf-5.31.patch39
-rw-r--r--kde-plasma/khotkeys/khotkeys-5.8.5.ebuild2
2 files changed, 41 insertions, 0 deletions
diff --git a/kde-plasma/khotkeys/files/khotkeys-5.8.5-kf-5.31.patch b/kde-plasma/khotkeys/files/khotkeys-5.8.5-kf-5.31.patch
new file mode 100644
index 00000000000..6b2d7c79be6
--- /dev/null
+++ b/kde-plasma/khotkeys/files/khotkeys-5.8.5-kf-5.31.patch
@@ -0,0 +1,39 @@
+From 617de4bd3fd080d43cce9bdc8af82963960d5c3a Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Daniel=20Vr=C3=A1til?= <dvratil@kde.org>
+Date: Wed, 18 Jan 2017 11:40:10 +0100
+Subject: Fix build with -fno-operator-names
+
+---
+ kcm_hotkeys/hotkeys_model.cpp | 2 +-
+ libkhotkeysprivate/action_data/action_data_group.cpp | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/kcm_hotkeys/hotkeys_model.cpp b/kcm_hotkeys/hotkeys_model.cpp
+index 66ea747..8703f83 100644
+--- a/kcm_hotkeys/hotkeys_model.cpp
++++ b/kcm_hotkeys/hotkeys_model.cpp
+@@ -486,7 +486,7 @@ QMimeData *KHotkeysModel::mimeData(const QModelIndexList &indexes) const
+
+ Q_FOREACH (const QModelIndex &index, indexes)
+ {
+- if (index.isValid() and index.column() == 0)
++ if (index.isValid() && index.column() == 0)
+ {
+ KHotKeys::ActionDataBase *element = indexToActionDataBase(index);
+ // We use the pointer as id.
+diff --git a/libkhotkeysprivate/action_data/action_data_group.cpp b/libkhotkeysprivate/action_data/action_data_group.cpp
+index ddbe24e..f80f775 100644
+--- a/libkhotkeysprivate/action_data/action_data_group.cpp
++++ b/libkhotkeysprivate/action_data/action_data_group.cpp
+@@ -83,7 +83,7 @@ Trigger::TriggerTypes ActionDataGroup::allowedTriggerTypes() const
+
+ bool ActionDataGroup::is_system_group() const
+ {
+- return _system_group != SYSTEM_NONE and _system_group != SYSTEM_ROOT;
++ return _system_group != SYSTEM_NONE && _system_group != SYSTEM_ROOT;
+ }
+
+
+--
+cgit v0.11.2
+
diff --git a/kde-plasma/khotkeys/khotkeys-5.8.5.ebuild b/kde-plasma/khotkeys/khotkeys-5.8.5.ebuild
index 621f6d0ce88..47256ea0c34 100644
--- a/kde-plasma/khotkeys/khotkeys-5.8.5.ebuild
+++ b/kde-plasma/khotkeys/khotkeys-5.8.5.ebuild
@@ -45,3 +45,5 @@ DEPEND="${COMMON_DEPEND}
x11-libs/libXtst
x11-proto/xproto
"
+
+PATCHES=( "${FILESDIR}/${P}-kf-5.31.patch" )