summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-config
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /lxqt-base/lxqt-config
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'lxqt-base/lxqt-config')
-rw-r--r--lxqt-base/lxqt-config/Manifest3
-rw-r--r--lxqt-base/lxqt-config/lxqt-config-0.7.0-r1.ebuild36
-rw-r--r--lxqt-base/lxqt-config/lxqt-config-0.8.0.ebuild54
-rw-r--r--lxqt-base/lxqt-config/lxqt-config-0.9.0.ebuild48
-rw-r--r--lxqt-base/lxqt-config/metadata.xml9
5 files changed, 150 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-config/Manifest b/lxqt-base/lxqt-config/Manifest
new file mode 100644
index 00000000000..a1a5937fd7b
--- /dev/null
+++ b/lxqt-base/lxqt-config/Manifest
@@ -0,0 +1,3 @@
+DIST lxqt-config-0.7.0.tar.xz 112572 SHA256 4b8ec02a7c78efe8fa45dcb0d60e83dc6a53bf81f12d2ea4b022cf9f6feae551 SHA512 9f75d69a5add165019bc20f861a1c847d01a37760bd29418c80b0d290fcab54716218ab40dfc80941e13242ea59e5f9de33a753dc33c1f5f257f9b58cef672a6 WHIRLPOOL 2a2996d7b889e3a16570a33aa472aca3e3b913b57eb20ce4dab142b23b8a9227a7c8a56f4370eb3c02d843fb9cb4b1af979992f337e112e4839a2645869dc419
+DIST lxqt-config-0.8.0.tar.xz 124940 SHA256 d2817df3c890038aca3e9efa2e2319df51825f47fdda5858efd92459bb8f4ad8 SHA512 3f54738d24348fb405b7dabe483393804310c843d82c100789ebf47258a6f5056222066fa752a4417eed3a6f4a03f174b334ea1b4898e42ebd5f49289848ffd3 WHIRLPOOL 14522ecac04026cffda8a76ba45a5488794e5474572345bacfd5078fc633101f90c3fa502f1bed73aa258d6283cbbd3c7088ba47fcde577344b4703c965bd5ce
+DIST lxqt-config-0.9.0.tar.xz 139564 SHA256 9d6b0d21846ac5d9c62c5806ce04383b92708ab7bd095b46d0ac9fbb3f84b913 SHA512 5b2693c5824ca0d02cb0c7225a83f2f50f0d29097af600e86b867d66332082a24185a95a803214efe87be731d918d587a0a06d360e23d880a8daf8671dff0c1a WHIRLPOOL 220e5f2359ae6a8e531493f35e09169edb48fb7cf7ae71b03525c2bda02f792dd0ca34f5a2c925c9aecdb43f6a873aa310f390785fd9457504733f27f19db6f5
diff --git a/lxqt-base/lxqt-config/lxqt-config-0.7.0-r1.ebuild b/lxqt-base/lxqt-config/lxqt-config-0.7.0-r1.ebuild
new file mode 100644
index 00000000000..a68e763bc9e
--- /dev/null
+++ b/lxqt-base/lxqt-config/lxqt-config-0.7.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt system configuration control center"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+ S=${WORKDIR}
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+DEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ ~lxqt-base/liblxqt-${PV}
+ ~dev-libs/libqtxdg-0.5.3
+ sys-libs/zlib
+ x11-libs/libXcursor
+ x11-libs/libXfixes"
+RDEPEND="${DEPEND}
+ x11-apps/setxkbmap"
+
+src_install(){
+ cmake-utils_src_install
+ doman man/*.1 lxqt-config-cursor/man/*.1 lxqt-config-appearance/man/*.1
+}
diff --git a/lxqt-base/lxqt-config/lxqt-config-0.8.0.ebuild b/lxqt-base/lxqt-config/lxqt-config-0.8.0.ebuild
new file mode 100644
index 00000000000..6a33f31f036
--- /dev/null
+++ b/lxqt-base/lxqt-config/lxqt-config-0.8.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt system configuration control center"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+DEPEND="
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/linguist-tools:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ ~lxqt-base/liblxqt-${PV}
+ >=dev-libs/libqtxdg-1.0.0
+ sys-libs/zlib
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libxcb:=
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXfixes"
+RDEPEND="${DEPEND}
+ x11-apps/setxkbmap"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT5=ON
+ )
+ cmake-utils_src_configure
+}
+
+src_install(){
+ cmake-utils_src_install
+ doman man/*.1 liblxqt-config-cursor/man/*.1 lxqt-config-appearance/man/*.1
+}
diff --git a/lxqt-base/lxqt-config/lxqt-config-0.9.0.ebuild b/lxqt-base/lxqt-config/lxqt-config-0.9.0.ebuild
new file mode 100644
index 00000000000..3661c72358a
--- /dev/null
+++ b/lxqt-base/lxqt-config/lxqt-config-0.9.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt system configuration control center"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+DEPEND="
+ >=dev-libs/libqtxdg-1.0.0
+ dev-qt/linguist-tools:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ kde-frameworks/kwindowsystem:5
+ ~lxqt-base/liblxqt-${PV}
+ sys-libs/zlib
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libxcb:=
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXfixes"
+RDEPEND="${DEPEND}
+ x11-apps/setxkbmap"
+
+src_install(){
+ cmake-utils_src_install
+ doman man/*.1 liblxqt-config-cursor/man/*.1 lxqt-config-appearance/man/*.1
+}
diff --git a/lxqt-base/lxqt-config/metadata.xml b/lxqt-base/lxqt-config/metadata.xml
new file mode 100644
index 00000000000..d89dead0ed8
--- /dev/null
+++ b/lxqt-base/lxqt-config/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>lxqt</herd>
+ <maintainer>
+ <email>jauhien@gentoo.org</email>
+ <name>Jauhien Piatlicki</name>
+ </maintainer>
+</pkgmetadata>