summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-qtplugin
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /lxqt-base/lxqt-qtplugin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'lxqt-base/lxqt-qtplugin')
-rw-r--r--lxqt-base/lxqt-qtplugin/Manifest3
-rw-r--r--lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.7.0.ebuild29
-rw-r--r--lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.8.0.ebuild36
-rw-r--r--lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.9.0.ebuild29
-rw-r--r--lxqt-base/lxqt-qtplugin/metadata.xml9
5 files changed, 106 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-qtplugin/Manifest b/lxqt-base/lxqt-qtplugin/Manifest
new file mode 100644
index 00000000000..41ef4a32149
--- /dev/null
+++ b/lxqt-base/lxqt-qtplugin/Manifest
@@ -0,0 +1,3 @@
+DIST lxqt-qtplugin-0.7.0.tar.xz 11980 SHA256 fb9780ff79f2cd02bc75329d26e1b78a72447cc31d19ee85c079bd175293f7c9 SHA512 15a738b3d79320cd01fbe108f83ceb1fdfad9fc03e3647b3436e8d7936063b47f80f0eacf920420404e0d10046568a859e98a66d747b3fa0f1ff2be3e8920bf2 WHIRLPOOL fe46394ff1e2f7967f2cdac0b7a5357bb6b7ea6accfdb4d651e54932d6cec348acd26f76f23bd3cbf58bc06ff0fb7ab2537fa5aacd23d897a9f878c71103c6e5
+DIST lxqt-qtplugin-0.8.0.tar.xz 16712 SHA256 0708c2a814c95777e93c8f23efc0bf1f0bdd193bae580627ced915a7b1b29b8d SHA512 6e9162e4f7aab07cebe54109a508caa17cfb21ea6354d122e28096f1abf4d3fbda69bfb7c50df32ed3bfa30eb4af9d5ec9c48e0d73173062aa227adbe7c33e66 WHIRLPOOL 3f959dfbbb71a8e04b2765180a14f5735639158a34e980d292d8b0e21bc863be6fbb88abb50ba2931a1ad37c535a5b2b3ca87457523c05344d01a10a6e01467a
+DIST lxqt-qtplugin-0.9.0.tar.xz 15732 SHA256 7bc715d55ccf7b4356dc89b23f441b79b2a79a523efdb67bc4a81acaa86243c5 SHA512 7c73feec6805990476d714bb575954014a254d20435063e24fe5d7aaaa90c335b1c7ca44e2dac8311a42b4ecbb084dbd1e7d41882160b9e4010b55a88677e3cc WHIRLPOOL d860fd09be28f9b5ece534d5c0cd00a484fb26fccc5a4fd6c79ca0bcdcbb740447ff368eb26cd2bceb3774fea4b152f229df72d0d7f9483d3d3da7d8f11b0344
diff --git a/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.7.0.ebuild b/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.7.0.ebuild
new file mode 100644
index 00000000000..c8e92d67193
--- /dev/null
+++ b/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.7.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt system integration plugin for Qt"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+S=${WORKDIR}
+
+DEPEND="~lxqt-base/liblxqt-${PV}
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ x11-libs/libX11"
+RDEPEND="${DEPEND}"
diff --git a/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.8.0.ebuild b/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.8.0.ebuild
new file mode 100644
index 00000000000..7b4a58be1e5
--- /dev/null
+++ b/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.8.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt system integration plugin for Qt"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+DEPEND="
+ dev-qt/linguist-tools:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ ~lxqt-base/liblxqt-${PV}
+ x11-libs/libX11"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT5=ON
+ )
+ cmake-utils_src_configure
+}
diff --git a/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.9.0.ebuild b/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.9.0.ebuild
new file mode 100644
index 00000000000..c6fcd30cf7b
--- /dev/null
+++ b/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.9.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt system integration plugin for Qt"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+DEPEND="
+ dev-qt/linguist-tools:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ ~lxqt-base/liblxqt-${PV}
+ x11-libs/libX11"
+RDEPEND="${DEPEND}"
diff --git a/lxqt-base/lxqt-qtplugin/metadata.xml b/lxqt-base/lxqt-qtplugin/metadata.xml
new file mode 100644
index 00000000000..d89dead0ed8
--- /dev/null
+++ b/lxqt-base/lxqt-qtplugin/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>lxqt</herd>
+ <maintainer>
+ <email>jauhien@gentoo.org</email>
+ <name>Jauhien Piatlicki</name>
+ </maintainer>
+</pkgmetadata>