summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-session
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /lxqt-base/lxqt-session
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'lxqt-base/lxqt-session')
-rw-r--r--lxqt-base/lxqt-session/Manifest3
-rw-r--r--lxqt-base/lxqt-session/lxqt-session-0.7.0-r1.ebuild41
-rw-r--r--lxqt-base/lxqt-session/lxqt-session-0.8.0.ebuild51
-rw-r--r--lxqt-base/lxqt-session/lxqt-session-0.9.0-r1.ebuild45
-rw-r--r--lxqt-base/lxqt-session/metadata.xml9
5 files changed, 149 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-session/Manifest b/lxqt-base/lxqt-session/Manifest
new file mode 100644
index 00000000000..22402edc5d4
--- /dev/null
+++ b/lxqt-base/lxqt-session/Manifest
@@ -0,0 +1,3 @@
+DIST lxqt-session-0.7.0.tar.xz 68208 SHA256 d6af28a6054555acf1a2e47c839d6802e5a88b237cdcd8d2ee3155661bbdd6d6 SHA512 0a1fcdf9669295c5651ce21ee377997c5dbea147576bd26bd146642a23ecec1a402e209a0244a8798e481567f38499a6cc56887193b1b4bea07d746a15e5f94a WHIRLPOOL 0c20d15631ba575609f5b76a3d1054c048d721571e2b3fa9992e4b7e3fb8cf1d9642bf4268bad0ad3d00acede18c9bc5eff27f4a43ef3013bfb1570668a07364
+DIST lxqt-session-0.8.0.tar.xz 70796 SHA256 bab662d167d6b718bfd30122f0c26d786469ed52ec5ae4e6393d6fb9882ff767 SHA512 eb43d10390d3d01041c149c4cdedada9a1a27b840f9ff0aca5991584e984d5163eaa17a8e8c7b67f607f0240b5465783ed83a8f9253e59ea971cdd6557bf5257 WHIRLPOOL 5ddeb6234c1bc7dc60abaebdfe8fd71e8dfa0a679e978a9a5b17ad55859ee455cd61b6d4bc1bdb09bc109e775ec264d807841f77d35a26daaff7245345c6315b
+DIST lxqt-session-0.9.0.tar.xz 56556 SHA256 c543ffb938e230c144399b59c99c53ee69fd0b37ff404a02576ce1179a551d06 SHA512 d0f5626c64ee6b03ad017df99cde09c8a27c1f5de658e39dd5346d79605b4f173bcef8f02d9d9b5c9cbed8c2e8c30b5202443fe229ce5bf3258143d312bf3183 WHIRLPOOL e8f6990ebe5cebbf4af939394c41782fb0034dd3381c07f0a6d9442dd50a1351191c27a9b94e01df49d0749334bdb0a37597fd51fdbf27633efbefe97192f502
diff --git a/lxqt-base/lxqt-session/lxqt-session-0.7.0-r1.ebuild b/lxqt-base/lxqt-session/lxqt-session-0.7.0-r1.ebuild
new file mode 100644
index 00000000000..740c9dfbae6
--- /dev/null
+++ b/lxqt-base/lxqt-session/lxqt-session-0.7.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="LXQT session manager"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+S=${WORKDIR}
+
+CDEPEND="dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ ~lxqt-base/liblxqt-${PV}
+ ~dev-libs/libqtxdg-0.5.3
+ x11-libs/libX11"
+DEPEND="${CDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ ~lxqt-base/lxqt-common-${PV}"
+
+src_install(){
+ cmake-utils_src_install
+ doman lxqt-config-session/man/*.1 lxqt-session/man/*.1
+}
diff --git a/lxqt-base/lxqt-session/lxqt-session-0.8.0.ebuild b/lxqt-base/lxqt-session/lxqt-session-0.8.0.ebuild
new file mode 100644
index 00000000000..ea9900c5871
--- /dev/null
+++ b/lxqt-base/lxqt-session/lxqt-session-0.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="LXQT session manager"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+CDEPEND="
+ dev-qt/linguist-tools:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ ~lxqt-base/liblxqt-${PV}
+ >=dev-libs/libqtxdg-1.0.0
+ x11-libs/libX11"
+DEPEND="${CDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ ~lxqt-base/lxqt-common-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT5=ON
+ )
+ cmake-utils_src_configure
+}
+
+src_install(){
+ cmake-utils_src_install
+ doman lxqt-config-session/man/*.1 lxqt-session/man/*.1
+}
diff --git a/lxqt-base/lxqt-session/lxqt-session-0.9.0-r1.ebuild b/lxqt-base/lxqt-session/lxqt-session-0.9.0-r1.ebuild
new file mode 100644
index 00000000000..2f520b55acf
--- /dev/null
+++ b/lxqt-base/lxqt-session/lxqt-session-0.9.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="LXQT session manager"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+CDEPEND="
+ >=dev-libs/libqtxdg-1.0.0
+ dev-qt/linguist-tools:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ kde-frameworks/kwindowsystem:5[X]
+ ~lxqt-base/liblxqt-${PV}
+ x11-libs/libX11"
+DEPEND="${CDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ =lxqt-base/lxqt-common-0.9*"
+
+src_install(){
+ cmake-utils_src_install
+ doman lxqt-config-session/man/*.1 lxqt-session/man/*.1
+}
diff --git a/lxqt-base/lxqt-session/metadata.xml b/lxqt-base/lxqt-session/metadata.xml
new file mode 100644
index 00000000000..d89dead0ed8
--- /dev/null
+++ b/lxqt-base/lxqt-session/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>lxqt</herd>
+ <maintainer>
+ <email>jauhien@gentoo.org</email>
+ <name>Jauhien Piatlicki</name>
+ </maintainer>
+</pkgmetadata>