summaryrefslogtreecommitdiff
path: root/mail-client/claws-mail-notification
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mail-client/claws-mail-notification
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mail-client/claws-mail-notification')
-rw-r--r--mail-client/claws-mail-notification/Manifest1
-rw-r--r--mail-client/claws-mail-notification/claws-mail-notification-0.31.ebuild40
-rw-r--r--mail-client/claws-mail-notification/files/claws-mail-notification-0.26-libnotify-0.7.patch50
-rw-r--r--mail-client/claws-mail-notification/files/claws-mail-notification-0.27-libnotify-0.7-extra.patch11
-rw-r--r--mail-client/claws-mail-notification/metadata.xml9
5 files changed, 111 insertions, 0 deletions
diff --git a/mail-client/claws-mail-notification/Manifest b/mail-client/claws-mail-notification/Manifest
new file mode 100644
index 00000000000..89947c40ade
--- /dev/null
+++ b/mail-client/claws-mail-notification/Manifest
@@ -0,0 +1 @@
+DIST notification_plugin-0.31.tar.gz 561196 SHA256 51cf2f52d60535e0ee8e1a80340cc12c6ed2179055846141afbf94faadca539e SHA512 017ed3579a193baf3f6a7e859d518ec075eb8c4f960d67d64f1f54433dab76a8f1c71b8eb2326a0e3fc6c2d68635378d119822863677a71ccf4a5560b75f2b11 WHIRLPOOL 003b3a3ca022d486882c13838459b9613eb61a04aa440fe241683e35727c4d480f087881c5ff54bd2c04b29ea8883ece4e5b2b1eb5376f02f2bebb4825f4de8e
diff --git a/mail-client/claws-mail-notification/claws-mail-notification-0.31.ebuild b/mail-client/claws-mail-notification/claws-mail-notification-0.31.ebuild
new file mode 100644
index 00000000000..c692c9e5956
--- /dev/null
+++ b/mail-client/claws-mail-notification/claws-mail-notification-0.31.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit multilib
+
+MY_P=${PN#claws-mail-}_plugin-${PV}
+
+DESCRIPTION="Plugin providing various ways to notify user of new and unread mail"
+HOMEPAGE="http://www.claws-mail.org/"
+SRC_URI="http://www.claws-mail.org/downloads/plugins/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="libnotify"
+
+RDEPEND="~mail-client/claws-mail-3.9.0
+ >=x11-libs/gtk+-2.10:2
+ libnotify? ( x11-libs/libnotify )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --disable-static \
+ $(use_enable libnotify)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README
+
+ # kill useless files
+ rm -f "${D}"/usr/lib*/claws-mail/plugins/*.{a,la}
+}
diff --git a/mail-client/claws-mail-notification/files/claws-mail-notification-0.26-libnotify-0.7.patch b/mail-client/claws-mail-notification/files/claws-mail-notification-0.26-libnotify-0.7.patch
new file mode 100644
index 00000000000..6159d139cdb
--- /dev/null
+++ b/mail-client/claws-mail-notification/files/claws-mail-notification-0.26-libnotify-0.7.patch
@@ -0,0 +1,50 @@
+--- src/notification_popup.c
++++ src/notification_popup.c
+@@ -339,7 +339,16 @@
+ break;
+ }
+
++#ifdef NOTIFY_CHECK_VERSION
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ ppopup->notification = notify_notification_new(summary, utf8_str, NULL);
++#else
+ ppopup->notification = notify_notification_new(summary, utf8_str, NULL, NULL);
++#endif
++#else
++ ppopup->notification = notify_notification_new(summary, utf8_str, NULL, NULL);
++#endif
++
+ g_free(utf8_str);
+ if(ppopup->notification == NULL) {
+ debug_print("Notification Plugin: Failed to create a new "
+--- src/notification_trayicon.c
++++ src/notification_trayicon.c
+@@ -61,6 +61,10 @@
+ #ifdef HAVE_LIBNOTIFY
+ #include <libnotify/notify.h>
+
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
++
+ typedef struct {
+ gint count;
+ gint num_mail;
+@@ -601,8 +605,17 @@
+ summary = notification_trayicon_popup_assemble_summary();
+ utf8_str = notification_trayicon_popup_assemble_body(msginfo);
+
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ popup.notification = notify_notification_new(summary, utf8_str, NULL);
++#else
+ popup.notification = notify_notification_new(summary, utf8_str, NULL, NULL);
++#endif
++
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ /* notify_notification_attach_to_status_icon function was removed */
++#else
+ notify_notification_attach_to_status_icon(popup.notification, trayicon);
++#endif
+
+ g_free(summary);
+ g_free(utf8_str);
diff --git a/mail-client/claws-mail-notification/files/claws-mail-notification-0.27-libnotify-0.7-extra.patch b/mail-client/claws-mail-notification/files/claws-mail-notification-0.27-libnotify-0.7-extra.patch
new file mode 100644
index 00000000000..34b96392de0
--- /dev/null
+++ b/mail-client/claws-mail-notification/files/claws-mail-notification-0.27-libnotify-0.7-extra.patch
@@ -0,0 +1,11 @@
+--- configure 2011-04-09 19:17:25.000000000 +0200
++++ configure 2011-04-13 16:40:22.000000000 +0200
+@@ -14934,7 +14934,7 @@
+ fi
+
+ LIBNOTIFY_REQUIRED=0.4.3
+-LIBNOTIFY_TOO_HIGH=0.7.0
++LIBNOTIFY_TOO_HIGH=0.8.0
+ # Check whether --enable-libnotify was given.
+ if test "${enable_libnotify+set}" = set; then :
+ enableval=$enable_libnotify; enable_libnotify=$enableval
diff --git a/mail-client/claws-mail-notification/metadata.xml b/mail-client/claws-mail-notification/metadata.xml
new file mode 100644
index 00000000000..df7c388592e
--- /dev/null
+++ b/mail-client/claws-mail-notification/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <maintainer>
+ <email>fauli@gentoo.org</email>
+ <name>Christian Faulhammer</name>
+ </maintainer>
+</pkgmetadata>