summaryrefslogtreecommitdiff
path: root/mail-client/nail
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mail-client/nail
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mail-client/nail')
-rw-r--r--mail-client/nail/Manifest1
-rw-r--r--mail-client/nail/files/nail-12.4-debian.patch56
-rw-r--r--mail-client/nail/files/nail-12.4-openssl-1.patch72
-rw-r--r--mail-client/nail/metadata.xml23
-rw-r--r--mail-client/nail/nail-12.4-r2.ebuild107
-rw-r--r--mail-client/nail/nail-12.4.ebuild91
6 files changed, 350 insertions, 0 deletions
diff --git a/mail-client/nail/Manifest b/mail-client/nail/Manifest
new file mode 100644
index 00000000000..2a648791aa0
--- /dev/null
+++ b/mail-client/nail/Manifest
@@ -0,0 +1 @@
+DIST mailx-12.4.tar.bz2 271482 SHA256 92201e769fe346bc0364c87437a330ef3c97ab3e9d7b2235b93f509e85e5716a SHA512 a0e29972f552bd630ce1a14f70e61661815118520bcd4a00b6cad53f3270d3d08c835ff6982ba8800eb380a5b46f54eb6e60fb7533b5f41c916af45d29605af8 WHIRLPOOL 05884e1fe21b49dfdec298a7ba1e812d471686c744073b766cffb9f5f7bc62573f82ca59a0bd9e6fabc4625dedff97a1401167a1c8fbc92c24b47ce9d56c259e
diff --git a/mail-client/nail/files/nail-12.4-debian.patch b/mail-client/nail/files/nail-12.4-debian.patch
new file mode 100644
index 00000000000..2fea0b190d2
--- /dev/null
+++ b/mail-client/nail/files/nail-12.4-debian.patch
@@ -0,0 +1,56 @@
+--- heirloom-mailx-12.4.orig/getopt.c
++++ heirloom-mailx-12.4/getopt.c
+@@ -43,7 +43,7 @@
+ char *optarg;
+ int optind = 1;
+ int opterr = 1;
+-int optopt;
++int optoptc;
+
+ static void
+ error(const char *s, int c)
+@@ -69,7 +69,7 @@
+ *bp++ = *s++;
+ while (*msg)
+ *bp++ = *msg++;
+- *bp++ = optopt;
++ *bp++ = optoptc;
+ *bp++ = '\n';
+ write(2, buf, bp - buf);
+ ac_free(buf);
+@@ -101,13 +101,13 @@
+ }
+ curp = &argv[optind][1];
+ }
+- optopt = curp[0] & 0377;
++ optoptc = curp[0] & 0377;
+ while (optstring[0]) {
+ if (optstring[0] == ':') {
+ optstring++;
+ continue;
+ }
+- if ((optstring[0] & 0377) == optopt) {
++ if ((optstring[0] & 0377) == optoptc) {
+ if (optstring[1] == ':') {
+ if (curp[1] != '\0') {
+ optarg = (char *)&curp[1];
+@@ -127,7 +127,7 @@
+ optind++;
+ optarg = 0;
+ }
+- return optopt;
++ return optoptc;
+ }
+ optstring++;
+ }
+--- heirloom-mailx-12.4.orig/mailx.1
++++ heirloom-mailx-12.4/mailx.1
+@@ -3766,7 +3766,7 @@
+ .sp
+ .fi
+ which might cause
+-.N mailx
++.B mailx
+ to respond with, for example:
+ .nf
+ .sp
diff --git a/mail-client/nail/files/nail-12.4-openssl-1.patch b/mail-client/nail/files/nail-12.4-openssl-1.patch
new file mode 100644
index 00000000000..376c4d668e3
--- /dev/null
+++ b/mail-client/nail/files/nail-12.4-openssl-1.patch
@@ -0,0 +1,72 @@
+http://bugs.gentoo.org/328363
+http://repos.archlinux.org/wsvn/community/mailx-heirloom/trunk/mailx-heirloom-openssl-1.0.patch
+
+--- openssl.c
++++ openssl.c
+@@ -105,7 +105,7 @@
+ static void ssl_load_verifications(struct sock *sp);
+ static void ssl_certificate(struct sock *sp, const char *uhp);
+ static enum okay ssl_check_host(const char *server, struct sock *sp);
+-static int smime_verify(struct message *m, int n, STACK *chain,
++static int smime_verify(struct message *m, int n, STACK_OF(X509) *chain,
+ X509_STORE *store);
+ static EVP_CIPHER *smime_cipher(const char *name);
+ static int ssl_password_cb(char *buf, int size, int rwflag, void *userdata);
+@@ -308,7 +308,7 @@
+ X509 *cert;
+ X509_NAME *subj;
+ char data[256];
+- /*GENERAL_NAMES*/STACK *gens;
++ /*GENERAL_NAMES*/STACK_OF(GENERAL_NAMES) *gens;
+ GENERAL_NAME *gen;
+ int i;
+
+@@ -496,7 +496,7 @@
+ }
+
+ static int
+-smime_verify(struct message *m, int n, STACK *chain, X509_STORE *store)
++smime_verify(struct message *m, int n, STACK_OF(X509) *chain, X509_STORE *store)
+ {
+ struct message *x;
+ char *cp, *sender, *to, *cc, *cnttype;
+@@ -505,7 +505,8 @@
+ off_t size;
+ BIO *fb, *pb;
+ PKCS7 *pkcs7;
+- STACK *certs, *gens;
++ STACK_OF(X509) *certs;
++ STACK_OF(GENERAL_NAMES) *gens;
+ X509 *cert;
+ X509_NAME *subj;
+ char data[LINESIZE];
+@@ -614,7 +615,7 @@
+ {
+ int *msgvec = vp, *ip;
+ int ec = 0;
+- STACK *chain = NULL;
++ STACK_OF(X509) *chain = NULL;
+ X509_STORE *store;
+ char *ca_dir, *ca_file;
+
+@@ -687,7 +688,7 @@
+ X509 *cert;
+ PKCS7 *pkcs7;
+ BIO *bb, *yb;
+- STACK *certs;
++ STACK_OF(X509) *certs;
+ EVP_CIPHER *cipher;
+
+ certfile = expand((char *)certfile);
+@@ -950,9 +951,9 @@
+ off_t size;
+ BIO *fb, *pb;
+ PKCS7 *pkcs7;
+- STACK *certs;
++ STACK_OF(X509) *certs;
+ X509 *cert;
+- STACK *chain = NULL;
++ STACK_OF(X509) *chain = NULL;
+ enum okay ok = OKAY;
+
+ message_number = n;
diff --git a/mail-client/nail/metadata.xml b/mail-client/nail/metadata.xml
new file mode 100644
index 00000000000..cec2552c7b9
--- /dev/null
+++ b/mail-client/nail/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <use>
+ <flag name="net">
+ Enable support for network protocols (POP, IMAP and SMTP). If you
+ only need to send mail with the local Transport Agent, disabling
+ this will get you support for only /usr/sbin/sendmail call.
+ </flag>
+ <flag name="ssl">
+ If network is enabled, this adds support for S/MIME and
+ SSL/TLS-powered protocols through <pkg>dev-libs/openssl</pkg>.
+ </flag>
+ <flag name="kerberos">
+ If network is enabled, this adds support for GSSAPI login on IMAP
+ through <pkg>virtual/kerberos</pkg>.
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">heirloom</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/mail-client/nail/nail-12.4-r2.ebuild b/mail-client/nail/nail-12.4-r2.ebuild
new file mode 100644
index 00000000000..96f5ddbb908
--- /dev/null
+++ b/mail-client/nail/nail-12.4-r2.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+HOMEPAGE="http://heirloom.sourceforge.net/"
+DESCRIPTION="an enhanced mailx-compatible mail client"
+LICENSE="BSD"
+
+MY_PN="mailx"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://sourceforge/project/heirloom/heirloom-${MY_PN}/${PV}/${MY_P}.tar.bz2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="ssl net kerberos"
+
+RDEPEND="
+ net? (
+ ssl? ( dev-libs/openssl )
+ kerberos? ( virtual/krb5 )
+ )
+ !mail-client/mailx
+ !net-mail/mailutils
+"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+undef() {
+ sed -i -e "/$1/s:#define:#undef:" config.h || die
+}
+
+droplib() {
+ sed -i -e "/$1/s:^:#:" LIBS || die
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-debian.patch \
+ "${FILESDIR}"/${P}-openssl-1.patch
+ # Do not strip the binary
+ sed -i -e '/STRIP/d' Makefile
+}
+
+src_configure() {
+ # Build config.h and LIBS, neccesary to tweak the config
+ # use -j1 because it will produce bogus output otherwise
+ emake -j1 config.h LIBS || die
+
+ # Logic to 'configure' the package
+
+ if ! use ssl || ! use net ; then
+ undef 'USE_\(OPEN\)\?SSL'
+ droplib -lssl
+ fi
+
+ if ! use kerberos || ! use net ; then
+ undef 'USE_GSSAPI'
+ droplib -lgssapi_krb5
+ fi
+
+ if ! use net ; then
+ undef 'HAVE_SOCKETS'
+ fi
+}
+
+src_compile() {
+ # No configure script to check for and set this
+ tc-export CC
+
+ emake \
+ CPPFLAGS="${CPPFLAGS} -D_GNU_SOURCE" \
+ PREFIX="${EPREFIX}"/usr SYSCONFDIR="${EPREFIX}"/etc \
+ SENDMAIL="${EPREFIX}/usr/sbin/sendmail" \
+ MAILSPOOL='/var/spool/mail' \
+ || die "emake failed"
+}
+
+src_install () {
+ # Use /usr/sbin/sendmail by default and provide an example
+ cat <<- EOSMTP >> nail.rc
+
+ # Use the local sendmail (/usr/sbin/sendmail) binary by default.
+ # (Uncomment the following line to use a SMTP server)
+ #set smtp=localhost
+
+ # Ask for CC: list too.
+ set askcc
+ EOSMTP
+
+ emake DESTDIR="${D}" \
+ UCBINSTALL=$(type -p install) \
+ PREFIX="${EPREFIX}"/usr SYSCONFDIR="${EPREFIX}"/etc install \
+ || die
+
+ dodoc AUTHORS README || die
+
+ dodir /bin
+ dosym ../usr/bin/mailx /bin/mail || die
+ dosym mailx /usr/bin/mail || die
+ dosym mailx /usr/bin/Mail || die
+
+ dosym mailx.1 /usr/share/man/man1/mail.1 || die
+ dosym mailx.1 /usr/share/man/man1/Mail.1 || die
+}
diff --git a/mail-client/nail/nail-12.4.ebuild b/mail-client/nail/nail-12.4.ebuild
new file mode 100644
index 00000000000..6fb81dc8e0a
--- /dev/null
+++ b/mail-client/nail/nail-12.4.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+HOMEPAGE="http://heirloom.sourceforge.net/"
+DESCRIPTION="an enhanced mailx-compatible mail client"
+LICENSE="BSD"
+
+MY_PN="mailx"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://sourceforge/project/heirloom/heirloom-${MY_PN}/${PV}/${MY_P}.tar.bz2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-freebsd ~x86-interix"
+IUSE="ssl net kerberos"
+
+RDEPEND="
+ ssl? ( dev-libs/openssl )
+ kerberos? ( virtual/krb5 )
+ !mail-client/mailx
+ !net-mail/mailutils
+"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+remove_ssl() {
+ elog "Disabling SSL support"
+ sed -i -e 's~#define USE_\(OPEN\)\?SSL~#undef USE_\1SSL~' config.h
+ sed -i -e 's~-ssl~~' -e 's~-lcrypto~~' LIBS
+}
+
+remove_sockets() {
+ elog "Not enabling sockets (thus disabling IMAP, POP and SMTP)"
+ sed -i -e 's~#define HAVE_SOCKETS~#undef HAVE_SOCKETS~' config.h
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-debian.patch \
+ "${FILESDIR}"/${P}-openssl-1.patch
+ # Do not strip the binary
+ sed -i -e '/STRIP/d' Makefile
+}
+
+src_configure() {
+ # Build config.h and LIBS, neccesary to tweak the config
+ make config.h LIBS
+
+ # Logic to 'configure' the package
+ if use net && ! use ssl ; then
+ remove_ssl
+ elif ! use net ; then
+ # Linking to ssl without net support is pointless
+ remove_ssl
+ remove_sockets
+ fi
+}
+
+src_compile() {
+ # No configure script to check for and set this
+ tc-export CC
+
+ emake \
+ CPPFLAGS="${CPPFLAGS} -D_GNU_SOURCE"
+ PREFIX="${EPREFIX}"/usr SYSCONFDIR="${EPREFIX}"/etc \
+ MAILSPOOL='/var/spool/mail' \
+ || die "emake failed"
+}
+
+src_install () {
+ # Use /usr/lib/sendmail by default and provide an example
+ cat <<- EOSMTP >> nail.rc
+
+ # Use the local sendmail (/usr/lib/sendmail) binary by default.
+ # (Uncomment the following line to use a SMTP server)
+ #set smtp=localhost
+ EOSMTP
+
+ make DESTDIR="${D}" \
+ UCBINSTALL=$(type -p install) \
+ PREFIX="${EPREFIX}"/usr SYSCONFDIR="${EPREFIX}"/etc install \
+ || die
+ dodoc AUTHORS README
+ dodir /bin
+ dosym /usr/bin/mailx /bin/mail
+ dosym /usr/bin/mailx /usr/bin/mail
+ dosym /usr/bin/mailx /usr/bin/Mail
+}