summaryrefslogtreecommitdiff
path: root/mail-filter/popfile
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mail-filter/popfile
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mail-filter/popfile')
-rw-r--r--mail-filter/popfile/Manifest1
-rw-r--r--mail-filter/popfile/files/popfile33
-rw-r--r--mail-filter/popfile/metadata.xml8
-rw-r--r--mail-filter/popfile/popfile-1.1.3.ebuild55
4 files changed, 97 insertions, 0 deletions
diff --git a/mail-filter/popfile/Manifest b/mail-filter/popfile/Manifest
new file mode 100644
index 00000000000..fff727678a2
--- /dev/null
+++ b/mail-filter/popfile/Manifest
@@ -0,0 +1 @@
+DIST popfile-1.1.3.zip 523431 SHA256 d197a187fbdaaf655f7eefceb969e0944cb4d5d290c0aba419b132797dfd6c54 SHA512 0e3ed3d67d2c2b456643335dd030a51e890bb371c5b8cf9eed9fac350a2536b8884eeffff78fcb27b99c39711505df533ee3ded5b40714fb46e54c2d25b3dda9 WHIRLPOOL 84e72bb8a98e1e1d20acde10c41cf8f8ed4418f8823cb5aaab29a7bfb916123447dc48b5180d617a6966db3f476de5a08770c5e96c0453e3481185c034889dbe
diff --git a/mail-filter/popfile/files/popfile b/mail-filter/popfile/files/popfile
new file mode 100644
index 00000000000..84fe795d5bd
--- /dev/null
+++ b/mail-filter/popfile/files/popfile
@@ -0,0 +1,33 @@
+#!/bin/bash
+#
+# /usr/bin/popfile
+# Shell script wrapper around the popfile perl script
+#
+# Author Stuart Herbert
+# (stuart@gentoo.org)
+#
+# Copyright Released into the public domain
+#
+# ------------------------------------------------------------------------
+
+POPFILE_DIR=/usr/share/popfile
+POPFILE_PL=popfile.pl
+
+if [[ `id -u` != 0 ]] ; then
+ echo "*** error: You must be root to run popfile" >&2
+ exit 1
+fi
+
+if [[ ! -d $POPFILE_DIR ]] ; then
+ echo "*** error: Directory $POPFILE_DIR does not exist" >&2
+ echo "*** Is popfile installed?"
+ exit 1
+fi
+
+if [[ ! -e $POPFILE_DIR/$POPFILE_PL ]] ; then
+ echo "*** error: popfile.pl is missing or not executable" >&2
+ exit 1
+fi
+
+cd $POPFILE_DIR
+exec ./$POPFILE_PL
diff --git a/mail-filter/popfile/metadata.xml b/mail-filter/popfile/metadata.xml
new file mode 100644
index 00000000000..1534479cc5b
--- /dev/null
+++ b/mail-filter/popfile/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <description>This package lacks a primary herd or maintainer.</description>
+</maintainer>
+</pkgmetadata>
diff --git a/mail-filter/popfile/popfile-1.1.3.ebuild b/mail-filter/popfile/popfile-1.1.3.ebuild
new file mode 100644
index 00000000000..5bf549cfe05
--- /dev/null
+++ b/mail-filter/popfile/popfile-1.1.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Anti-spam bayesian filter"
+HOMEPAGE="http://getpopfile.org"
+SRC_URI="http://getpopfile.org/downloads/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="cjk ipv6 mysql ssl xmlrpc"
+
+RDEPEND="virtual/perl-Digest-MD5
+ virtual/perl-MIME-Base64
+ dev-perl/DBD-SQLite
+ dev-perl/HTML-Tagset
+ dev-perl/HTML-Template
+ dev-perl/TimeDate
+ dev-perl/DBI
+ virtual/perl-Digest
+ cjk? ( dev-perl/Encode-compat
+ dev-perl/Text-Kakasi )
+ mysql? ( dev-perl/DBD-mysql )
+ ipv6? ( dev-perl/IO-Socket-INET6 )
+ ssl? ( dev-libs/openssl
+ dev-perl/IO-Socket-SSL
+ dev-perl/Net-SSLeay )
+ xmlrpc? ( dev-perl/PlRPC )"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ local f
+ for f in `find ./ -type f`; do
+ edos2unix "${f}"
+ done
+}
+
+src_install() {
+ dodoc *.change*
+ rm -rf *.change* license
+
+ insinto /usr/share/${PN}
+ doins -r *
+
+ fperms 755 /usr/share/${PN}/{popfile,insert,pipe,bayes}.pl
+
+ dosbin "${FILESDIR}"/${PN}
+}