summaryrefslogtreecommitdiff
path: root/mail-filter/sieve-connect
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mail-filter/sieve-connect
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mail-filter/sieve-connect')
-rw-r--r--mail-filter/sieve-connect/Manifest1
-rw-r--r--mail-filter/sieve-connect/metadata.xml44
-rw-r--r--mail-filter/sieve-connect/sieve-connect-0.87.ebuild34
3 files changed, 79 insertions, 0 deletions
diff --git a/mail-filter/sieve-connect/Manifest b/mail-filter/sieve-connect/Manifest
new file mode 100644
index 00000000000..570b9d25fd3
--- /dev/null
+++ b/mail-filter/sieve-connect/Manifest
@@ -0,0 +1 @@
+DIST sieve-connect-0.87.tar.bz2 40023 SHA256 e3de80ab34994de0277fc7bf53b7c08e82db1a1f2762ddac4311d8191cea6c49 SHA512 28ed4f5cd929ee5edb420afcbac238399463beecf551643b9ee5ea41debbb1e5401a619b39b6422ec47885ea3cc207866e09da2e46a65bcc3d4f3ca5bdbf016a WHIRLPOOL 73e05f2829ad9d16e414ae5578cb02e2ec1f654fdb8c355daa4339849fefb7d5a302115dd67cab78c82e6a93bd282f6f0889cdbcf19d2dac4ed702cbf909ecd8
diff --git a/mail-filter/sieve-connect/metadata.xml b/mail-filter/sieve-connect/metadata.xml
new file mode 100644
index 00000000000..416bc4dd883
--- /dev/null
+++ b/mail-filter/sieve-connect/metadata.xml
@@ -0,0 +1,44 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ This is sieve-connect. A client for the ManageSieve protocol,
+ as specifed in RFC 5804. Historically, this was MANAGESIEVE as
+ implemented by timsieved in Cyrus IMAP. This software is licensed
+ and the terms are provided in the file "LICENSE" as supplied
+ with this software (BSD license without the advertising clause).
+
+ SIEVE is an RFC-specified language for mail filtering, which at
+ time of writing is specified in a list of RFCs at the end of this
+ document, plus various drafts, both IETF and individual submissions.
+ It's designed to be regular enough for machines to be able to
+ manipulate, whilst still being editable by humans. Alas, not many
+ clients actually implement this instead of embedding their own
+ internal codes in sieve comments, defeating the goal of being able
+ to edit with a client of your choice.
+
+ This is not yet fully compatible with RFC 5804, but is moving
+ towards that from the timsieved baseline; some issues to be
+ worked on are documented in the "TODO" file.
+
+ sieve-connect speaks ManageSieve and supports TLS for connection
+ privacy and also authentication if using client certificates.
+ sieve-connect will use SASL authentication; SASL integrity layers
+ are not supported, use TLS instead. GSSAPI-based authentication
+ should generally work, provided that client and server can use a
+ common underlaying protocol. If it doesn't work for you, please
+ report the issue.
+
+ sieve-connect is designed to be both a tool which can be invoked
+ from scripts and also a decent interactive client. It should also
+ be a drop-in replacement for "sieveshell", as supplied with Cyrus
+ IMAP.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/syscomet/sieve-connect/issues</bugs-to>
+ <remote-id type="github">syscomet/sieve-connect</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/mail-filter/sieve-connect/sieve-connect-0.87.ebuild b/mail-filter/sieve-connect/sieve-connect-0.87.ebuild
new file mode 100644
index 00000000000..01775ffb8f4
--- /dev/null
+++ b/mail-filter/sieve-connect/sieve-connect-0.87.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Sieve Command Line Interface"
+HOMEPAGE="http://people.spodhuis.org/phil.pennock/software/"
+SRC_URI="https://github.com/syscomet/sieve-connect/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=dev-lang/perl-5"
+RDEPEND="${DEPEND}
+ >=dev-perl/Authen-SASL-2.11
+ dev-perl/IO-Socket-INET6
+ >=dev-perl/IO-Socket-SSL-0.97
+ dev-perl/Net-DNS
+ dev-perl/Net-SSLeay
+ dev-perl/TermReadKey
+ dev-perl/Term-ReadLine-Gnu"
+
+src_compile() {
+ emake all sieve-connect.1
+}
+
+src_install() {
+ dobin sieve-connect
+ doman sieve-connect.1
+ dodoc README*
+}