summaryrefslogtreecommitdiff
path: root/mate-base/mate-common
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-08-11 02:26:51 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2016-08-12 01:11:48 -0400
commitd6f60d8e7d5c041e0d89ff5be182c7aa483f178c (patch)
treeb4333b3f0b319ce3750f66780d6535e441bec045 /mate-base/mate-common
parent27db3020e0efbe90a2d93f48e0a39b50c73cb763 (diff)
downloadgentoo-d6f60d8e7d5c041e0d89ff5be182c7aa483f178c.tar.gz
gentoo-d6f60d8e7d5c041e0d89ff5be182c7aa483f178c.tar.xz
mate-base/mate-common: 1.12.x vbump, import from project repo
Package-Manager: portage-2.3.0
Diffstat (limited to 'mate-base/mate-common')
-rw-r--r--mate-base/mate-common/Manifest1
-rw-r--r--mate-base/mate-common/mate-common-1.12.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/mate-base/mate-common/Manifest b/mate-base/mate-common/Manifest
index 2724e648440..e9adf00c0ec 100644
--- a/mate-base/mate-common/Manifest
+++ b/mate-base/mate-common/Manifest
@@ -1 +1,2 @@
DIST mate-common-1.10.0.tar.xz 72136 SHA256 a2193e5d2ae78aa3f7bdf5636fb46d8142d417be76885758bf3795bc5e73d822 SHA512 1b183fcfcef1f52b78829c57ebfcf5a3fc5720ca2049e16339df947436638c188ef04b825e7e28723e24d60108bee0f6971c8395abf8af5ea40d3b6397b99ba4 WHIRLPOOL 2bdf9eb1ddf531f1327735efa84b5b5c63b8a8c9a0aed09c4ec88f3919515f53691e9a066e941e35a9299d08c8fa3c1ff997011056ae268c40ed0221348732a6
+DIST mate-common-1.12.0.tar.xz 66156 SHA256 7c178326ac810c6580647da16d13a8a36a5cc04725ce3a62419c5e2228c8b934 SHA512 3392cc38ee51dec37330ac7d309bd42dfec5f622b50d92af46e16d059781ed4bc1396cb4525518dfe1f2a913fecb426d3ef047731f2208219ef648f27bf54f32 WHIRLPOOL ac12bb8bd880e9bb943f137e5070b74be855e7b1f24fc6249178de2366c7d0d172be416f611ce1e3435c630feed2274e196e27bb59e33c6953563a39b1cbc842
diff --git a/mate-base/mate-common/mate-common-1.12.0.ebuild b/mate-base/mate-common/mate-common-1.12.0.ebuild
new file mode 100644
index 00000000000..43f092f5888
--- /dev/null
+++ b/mate-base/mate-common/mate-common-1.12.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit mate-desktop.org
+
+if [[ ${PV} == 9999 ]]; then
+ inherit autotools
+else
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Common files for development of MATE packages"
+LICENSE="GPL-3"
+SLOT="0"
+
+src_prepare() {
+ default
+ if [[ ${PV} == 9999 ]]; then
+ eautoreconf
+ fi
+}
+
+src_install() {
+ mv doc-build/README README.doc-build \
+ || die "Failed to rename doc-build/README."
+
+ default
+
+ dodoc doc/usage.txt
+}