summaryrefslogtreecommitdiff
path: root/mate-base/mate-panel
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mate-base/mate-panel
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mate-base/mate-panel')
-rw-r--r--mate-base/mate-panel/Manifest2
-rw-r--r--mate-base/mate-panel/files/mate-panel-1.8.1-update_marco_wm_name.patch11
-rw-r--r--mate-base/mate-panel/mate-panel-1.8.0.ebuild81
-rw-r--r--mate-base/mate-panel/mate-panel-1.8.1-r1.ebuild81
-rw-r--r--mate-base/mate-panel/metadata.xml8
5 files changed, 183 insertions, 0 deletions
diff --git a/mate-base/mate-panel/Manifest b/mate-base/mate-panel/Manifest
new file mode 100644
index 00000000000..74bf05a2b59
--- /dev/null
+++ b/mate-base/mate-panel/Manifest
@@ -0,0 +1,2 @@
+DIST mate-panel-1.8.0.tar.xz 1930348 SHA256 ac20c42d1b2ae7bf08e4e701e12165e63753f80648c1ea4ff5297f3381481056 SHA512 bdac2baa567cb52cdb6ddf3ed1d20e9de496e22734538fbca8e9efa6c2d4263ea6c13800ff21cffa8e5383cc5ee875ae7982b0d6e0d0a704abcbd97e3c07c53a WHIRLPOOL 73090851f4410689f184beaafca8c587e8ecf633bffd1356212a8c145c60187de50f7c498e363ebd5f54ae51333e2a6dd6ab1d47c7f04c1318a76d6932fae3ba
+DIST mate-panel-1.8.1.tar.xz 1953156 SHA256 d53d1546577db3e45ce6b46b4a40b2edc066781cc1e864eef47ad07b0fdb3f19 SHA512 925189eedf604117b4b4033b77a6ec4096f5c663218ca6736d549cdfd69c5476eebed56688632a6a20d0e2de49bc09ebd8373ecf45f486161b012346bb2eff8b WHIRLPOOL bb298e1b4b4078409e3a6b7858e2abf1667339c8581ee728f95f8ab0ea63288598e9c205b63baed40a57b19268c062a099fc98600502fd3723675ccfc19baade
diff --git a/mate-base/mate-panel/files/mate-panel-1.8.1-update_marco_wm_name.patch b/mate-base/mate-panel/files/mate-panel-1.8.1-update_marco_wm_name.patch
new file mode 100644
index 00000000000..f57bf983bef
--- /dev/null
+++ b/mate-base/mate-panel/files/mate-panel-1.8.1-update_marco_wm_name.patch
@@ -0,0 +1,11 @@
+--- a/applets/wncklet/workspace-switcher.c
++++ b/applets/wncklet/workspace-switcher.c
+@@ -143,6 +143,8 @@
+
+ if (!wm_name)
+ pager->wm = PAGER_WM_UNKNOWN;
++ else if (strcmp(wm_name, "Metacity (Marco)") == 0)
++ pager->wm = PAGER_WM_MARCO;
+ else if (strcmp(wm_name, "Marco") == 0)
+ pager->wm = PAGER_WM_MARCO;
+ else if (strcmp(wm_name, "Compiz") == 0)
diff --git a/mate-base/mate-panel/mate-panel-1.8.0.ebuild b/mate-base/mate-panel/mate-panel-1.8.0.ebuild
new file mode 100644
index 00000000000..50ff6e230e6
--- /dev/null
+++ b/mate-base/mate-panel/mate-panel-1.8.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools gnome2 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="The MATE panel"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE="X +introspection networkmanager"
+
+RDEPEND="
+ dev-libs/atk:0
+ >=dev-libs/dbus-glib-0.80:0
+ >=dev-libs/glib-2.26:2
+ >=dev-libs/libmateweather-1.8
+ dev-libs/libxml2:2
+ >=gnome-base/dconf-0.10:0
+ gnome-base/librsvg:2
+ >=mate-base/mate-desktop-1.8:0
+ >=mate-base/mate-menus-1.8:0
+ >=media-libs/libcanberra-0.23:0[gtk]
+ >=sys-apps/dbus-1.1.2:0
+ >=x11-libs/cairo-1:0
+ >=x11-libs/gdk-pixbuf-2.7.1:2
+ x11-libs/libICE:0
+ x11-libs/libSM:0
+ x11-libs/libX11:0
+ >=x11-libs/libwnck-2.30:1[introspection?]
+ >=x11-libs/pango-1.15.4:0[introspection?]
+ >=x11-libs/gtk+-2.19.7:2[introspection?]
+ x11-libs/libXau:0
+ >=x11-libs/libXrandr-1.2:0
+ virtual/libintl:0
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:0 )
+ networkmanager? ( >=net-misc/networkmanager-0.6:0 )"
+
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools:0
+ >=dev-lang/perl-5:0=
+ >=dev-util/intltool-0.40:*
+ >=mate-base/mate-common-1.8:0
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+src_prepare() {
+ # Disable python check.
+ sed -e '/AM_PATH_PYTHON/d' -i configure.ac || die
+
+ eautoreconf
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --libexecdir=/usr/libexec/mate-applets \
+ --disable-deprecation-flags \
+ $(use_enable networkmanager network-manager) \
+ $(use_enable introspection) \
+ $(use_with X x)
+}
+
+src_compile() {
+ emake -j1
+}
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
diff --git a/mate-base/mate-panel/mate-panel-1.8.1-r1.ebuild b/mate-base/mate-panel/mate-panel-1.8.1-r1.ebuild
new file mode 100644
index 00000000000..6bef4413a70
--- /dev/null
+++ b/mate-base/mate-panel/mate-panel-1.8.1-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils autotools gnome2 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="The MATE panel"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="X +introspection networkmanager"
+
+RDEPEND="
+ dev-libs/atk:0
+ >=dev-libs/dbus-glib-0.80:0
+ >=dev-libs/glib-2.26:2
+ >=dev-libs/libmateweather-1.8
+ dev-libs/libxml2:2
+ >=gnome-base/dconf-0.10:0
+ gnome-base/librsvg:2
+ >=mate-base/mate-desktop-1.8:0
+ >=mate-base/mate-menus-1.8:0
+ >=media-libs/libcanberra-0.23:0[gtk]
+ >=sys-apps/dbus-1.1.2:0
+ >=x11-libs/cairo-1:0
+ >=x11-libs/gdk-pixbuf-2.7.1:2
+ x11-libs/libICE:0
+ x11-libs/libSM:0
+ x11-libs/libX11:0
+ >=x11-libs/libwnck-2.30:1[introspection?]
+ >=x11-libs/pango-1.15.4:0[introspection?]
+ >=x11-libs/gtk+-2.19.7:2[introspection?]
+ x11-libs/libXau:0
+ >=x11-libs/libXrandr-1.2:0
+ virtual/libintl:0
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:0 )
+ networkmanager? ( >=net-misc/networkmanager-0.6:0 )"
+
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools:0
+ >=dev-lang/perl-5:0=
+ >=dev-util/intltool-0.40:*
+ >=mate-base/mate-common-1.8:0
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+src_prepare() {
+ # Disable python check.
+ sed -e '/AM_PATH_PYTHON/d' -i configure.ac || die
+
+ epatch "${FILESDIR}/${P}-update_marco_wm_name.patch"
+
+ epatch_user
+
+ eautoreconf
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --libexecdir=/usr/libexec/mate-applets \
+ --disable-deprecation-flags \
+ $(use_enable networkmanager network-manager) \
+ $(use_enable introspection) \
+ $(use_with X x)
+}
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
diff --git a/mate-base/mate-panel/metadata.xml b/mate-base/mate-panel/metadata.xml
new file mode 100644
index 00000000000..89e7d8d2f4f
--- /dev/null
+++ b/mate-base/mate-panel/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>mate</herd>
+ <upstream>
+ <remote-id type="github">mate-desktop/mate-panel</remote-id>
+ </upstream>
+</pkgmetadata>