summaryrefslogtreecommitdiff
path: root/media-fonts/ja-ipafonts
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-fonts/ja-ipafonts
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-fonts/ja-ipafonts')
-rw-r--r--media-fonts/ja-ipafonts/Manifest2
-rw-r--r--media-fonts/ja-ipafonts/files/66-ja-ipafonts.conf41
-rw-r--r--media-fonts/ja-ipafonts/ja-ipafonts-003.02-r1.ebuild29
-rw-r--r--media-fonts/ja-ipafonts/ja-ipafonts-003.03.ebuild29
-rw-r--r--media-fonts/ja-ipafonts/metadata.xml6
5 files changed, 107 insertions, 0 deletions
diff --git a/media-fonts/ja-ipafonts/Manifest b/media-fonts/ja-ipafonts/Manifest
new file mode 100644
index 00000000000..f2ed1af0b10
--- /dev/null
+++ b/media-fonts/ja-ipafonts/Manifest
@@ -0,0 +1,2 @@
+DIST IPAfont00302.zip 20113208 SHA256 5cb52a0dc99400b75455a829aad77915f0823ef4d8811ee3190654006439fb65 SHA512 58dfbb6b7ae5114aed28588d05d48649a2f216011d7bd2798a62558f1f55c9b998ad510f7b7a0ab9d272f75bdc69de1110bd67205ac61d221b0ce8fd71583685 WHIRLPOOL c4e6b5088b3d3d4391c95c42b1cc01684e09b086a673b7cee7591821616b7d9cec65bbc015933898fc38194b844ef4471477403173930886823a6ae45ae02f30
+DIST IPAfont00303.zip 20088137 SHA256 f755ed79a4b8e715bed2f05a189172138aedf93db0f465b4e20c344a02766fe5
diff --git a/media-fonts/ja-ipafonts/files/66-ja-ipafonts.conf b/media-fonts/ja-ipafonts/files/66-ja-ipafonts.conf
new file mode 100644
index 00000000000..e8894f42c19
--- /dev/null
+++ b/media-fonts/ja-ipafonts/files/66-ja-ipafonts.conf
@@ -0,0 +1,41 @@
+<?xml version="1.0"?>
+<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
+<fontconfig>
+ <!-- Generic names -->
+ <alias>
+ <family>sans-serif</family>
+ <prefer>
+ <family>IPAPGothic</family>
+ <family>IPAGothic</family>
+ </prefer>
+ </alias>
+ <alias>
+ <family>serif</family>
+ <prefer>
+ <family>IPAPMincho</family>
+ <family>IPAMincho</family>
+ </prefer>
+ </alias>
+ <alias>
+ <family>monospace</family>
+ <prefer>
+ <family>IPAGothic</family>
+ <family>IPAMincho</family>
+ </prefer>
+ </alias>
+
+ <!-- disable hinting -->
+<!--
+ <match target="font">
+ <test name="family">
+ <string>IPAPGothic</string>
+ <string>IPAPMincho</string>
+ <string>IPAGothic</string>
+ <string>IPAMincho</string>
+ </test>
+ <edit name="hinting" mode="assign">
+ <bool>false</bool>
+ </edit>
+ </match>
+-->
+</fontconfig>
diff --git a/media-fonts/ja-ipafonts/ja-ipafonts-003.02-r1.ebuild b/media-fonts/ja-ipafonts/ja-ipafonts-003.02-r1.ebuild
new file mode 100644
index 00000000000..39a55eb79e1
--- /dev/null
+++ b/media-fonts/ja-ipafonts/ja-ipafonts-003.02-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit font
+
+MY_P="IPAfont${PV/.}"
+
+DESCRIPTION="Japanese TrueType fonts developed by IPA (Information-technology Promotion Agency, Japan)"
+HOMEPAGE="http://ipafont.ipa.go.jp/"
+SRC_URI="http://dl.ipafont.ipa.go.jp/IPAfont/${MY_P}.zip"
+
+LICENSE="IPAfont"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+RESTRICT="binchecks strip"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+S="${WORKDIR}/${MY_P}"
+
+FONT_SUFFIX="ttf"
+FONT_S="${S}"
+FONT_CONF=( "${FILESDIR}"/66-${PN}.conf )
+
+DOCS=( "Readme_${MY_P}.txt" )
diff --git a/media-fonts/ja-ipafonts/ja-ipafonts-003.03.ebuild b/media-fonts/ja-ipafonts/ja-ipafonts-003.03.ebuild
new file mode 100644
index 00000000000..4db3375166f
--- /dev/null
+++ b/media-fonts/ja-ipafonts/ja-ipafonts-003.03.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit font
+
+MY_P="IPAfont${PV/.}"
+
+DESCRIPTION="Japanese TrueType fonts developed by IPA (Information-technology Promotion Agency, Japan)"
+HOMEPAGE="http://ipafont.ipa.go.jp/"
+SRC_URI="http://dl.ipafont.ipa.go.jp/IPAfont/${MY_P}.zip"
+
+LICENSE="IPAfont"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+RESTRICT="binchecks strip"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+S="${WORKDIR}/${MY_P}"
+
+FONT_SUFFIX="ttf"
+FONT_S="${S}"
+FONT_CONF=( "${FILESDIR}"/66-${PN}.conf )
+
+DOCS=( "Readme_${MY_P}.txt" )
diff --git a/media-fonts/ja-ipafonts/metadata.xml b/media-fonts/ja-ipafonts/metadata.xml
new file mode 100644
index 00000000000..cdee2535d93
--- /dev/null
+++ b/media-fonts/ja-ipafonts/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cjk</herd>
+<herd>fonts</herd>
+</pkgmetadata>