summaryrefslogtreecommitdiff
path: root/media-fonts/nanumfont/nanumfont-2.0-r1.ebuild
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2015-11-11 09:13:19 +0100
committerGuilherme Amadio <amadio@gentoo.org>2015-11-11 09:15:34 +0100
commit3ffe331d30e71cfcc575ab60798b69ebbcf77425 (patch)
tree93c084185dc80db57256a0e4afa580ef1c9d6d2b /media-fonts/nanumfont/nanumfont-2.0-r1.ebuild
parent2ff55b99c7106206b553996b84d9175acb832d0e (diff)
downloadgentoo-3ffe331d30e71cfcc575ab60798b69ebbcf77425.tar.gz
gentoo-3ffe331d30e71cfcc575ab60798b69ebbcf77425.tar.xz
Revert "media-fonts/nanumfont: renamed to media-fonts/nanum, remove old versions"
This reverts commit d391643289097344a0b18ab2665bb26198a0e3a1. The old ebuild contained monospaced fonts that are not in the new ebuild yet. Reverting until the new ebuild contains all fonts.
Diffstat (limited to 'media-fonts/nanumfont/nanumfont-2.0-r1.ebuild')
-rw-r--r--media-fonts/nanumfont/nanumfont-2.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-fonts/nanumfont/nanumfont-2.0-r1.ebuild b/media-fonts/nanumfont/nanumfont-2.0-r1.ebuild
new file mode 100644
index 00000000000..ba1c378635b
--- /dev/null
+++ b/media-fonts/nanumfont/nanumfont-2.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit font
+
+MY_P="NanumGothicCoding-${PV}"
+DESCRIPTION="Korean monospace font distributed by NHN"
+HOMEPAGE="http://dev.naver.com/projects/nanumfont"
+SRC_URI="http://dev.naver.com/frs/download.php/441/${MY_P}.zip"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Only installs fonts
+RESTRICT="strip binchecks"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}"
+FONT_S="${S}"
+
+FONT_SUFFIX="ttf"
+
+src_prepare() {
+ # Rename names in cp949 encoding, bug #322041
+ mkdir recode || die
+ mv *-Bold.ttf recode/${PN}-Bold.ttf || die
+ mv *.ttf recode/${PN}.ttf || die
+ mv recode/* .
+}