summaryrefslogtreecommitdiff
path: root/media-fonts/x11fonts-jmk
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-fonts/x11fonts-jmk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-fonts/x11fonts-jmk')
-rw-r--r--media-fonts/x11fonts-jmk/Manifest1
-rw-r--r--media-fonts/x11fonts-jmk/files/gzip.patch19
-rw-r--r--media-fonts/x11fonts-jmk/metadata.xml5
-rw-r--r--media-fonts/x11fonts-jmk/x11fonts-jmk-3.0-r1.ebuild38
4 files changed, 63 insertions, 0 deletions
diff --git a/media-fonts/x11fonts-jmk/Manifest b/media-fonts/x11fonts-jmk/Manifest
new file mode 100644
index 00000000000..f4d9defc2a6
--- /dev/null
+++ b/media-fonts/x11fonts-jmk/Manifest
@@ -0,0 +1 @@
+DIST jmk-x11-fonts-3.0.tar.gz 624357 SHA256 d5699451d8bd13b2ce7ac7856ac46b62e0ba82647f8ac0cd180ee424fe715d31
diff --git a/media-fonts/x11fonts-jmk/files/gzip.patch b/media-fonts/x11fonts-jmk/files/gzip.patch
new file mode 100644
index 00000000000..c01c1c09394
--- /dev/null
+++ b/media-fonts/x11fonts-jmk/files/gzip.patch
@@ -0,0 +1,19 @@
+--- Imakefile 1999-08-24 00:09:41.000000000 -0400
++++ Imakefile 2005-02-21 01:40:20.000000000 -0500
+@@ -22,7 +22,6 @@
+
+ CAT = cat
+ CP = cp -df
+-GZIP = gzip
+ MKDIR = mkdir -p
+ MV = mv -f
+ RM = rm -f
+@@ -438,7 +437,7 @@
+ done
+ -$(RM) $(TARBALL)$(BACKUP_SUFFIX)
+ -$(MV) $(TARBALL) $(TARBALL)$(BACKUP_SUFFIX)
+- $(TAR) -cvf - $(TARBALL_DIR) | $(GZIP) -9 -c >$(TARBALL)
++ $(TAR) -cvf - $(TARBALL_DIR) | gzip -9 -c >$(TARBALL)
+ -$(RM) -r $(TARBALL_DIR)
+
+ clean::
diff --git a/media-fonts/x11fonts-jmk/metadata.xml b/media-fonts/x11fonts-jmk/metadata.xml
new file mode 100644
index 00000000000..696065edd33
--- /dev/null
+++ b/media-fonts/x11fonts-jmk/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>fonts</herd>
+</pkgmetadata>
diff --git a/media-fonts/x11fonts-jmk/x11fonts-jmk-3.0-r1.ebuild b/media-fonts/x11fonts-jmk/x11fonts-jmk-3.0-r1.ebuild
new file mode 100644
index 00000000000..6013c96105a
--- /dev/null
+++ b/media-fonts/x11fonts-jmk/x11fonts-jmk-3.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+MY_P=jmk-x11-fonts-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="This package contains character-cell fonts for use with X"
+SRC_URI="http://www.pobox.com/~jmknoble/fonts/${MY_P}.tar.gz"
+HOMEPAGE="http://www.jmknoble.net/fonts/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc s390 sh sparc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="x11-misc/imake
+ x11-apps/mkfontdir
+ x11-apps/bdftopcf"
+RDEPEND=""
+
+FONTPATH="/usr/share/fonts/jmk"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/gzip.patch
+}
+
+src_compile() {
+ xmkmf || die
+ emake || die
+}
+
+src_install() {
+ make install INSTALL_DIR="${D}${FONTPATH}" || die
+ dodoc README NEWS
+}