summaryrefslogtreecommitdiff
path: root/media-gfx/iscan-plugin-gt-f720
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/iscan-plugin-gt-f720
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/iscan-plugin-gt-f720')
-rw-r--r--media-gfx/iscan-plugin-gt-f720/Manifest2
-rw-r--r--media-gfx/iscan-plugin-gt-f720/iscan-plugin-gt-f720-0.0.1.2.ebuild69
-rw-r--r--media-gfx/iscan-plugin-gt-f720/iscan-plugin-gt-f720-0.0.1.ebuild67
-rw-r--r--media-gfx/iscan-plugin-gt-f720/metadata.xml15
4 files changed, 153 insertions, 0 deletions
diff --git a/media-gfx/iscan-plugin-gt-f720/Manifest b/media-gfx/iscan-plugin-gt-f720/Manifest
new file mode 100644
index 00000000000..0d1416e7243
--- /dev/null
+++ b/media-gfx/iscan-plugin-gt-f720/Manifest
@@ -0,0 +1,2 @@
+DIST esci-interpreter-gt-f720-0.0.1-2.i386.rpm 381387 SHA256 c47d2acfb6de4d9c300e2f26df5b8a7c250e07195245d638457b8a4ea61f0903 SHA512 6ccc6f48d8c00614346a0faee798b876497ba5ac1b35e3fd558a6e01711b944dc713e654d53fff09daff00b91251150665932564fea4fc60ec1a0a7ec95fa1f5 WHIRLPOOL 2edd2338e00d05a017e68bdae4ca791dd409e8138adfff7cc45557ec612a209b1cb01f2ce823fbc2de4afead23019c1962a013885886bafe838ed51b018635e7
+DIST esci-interpreter-gt-f720-0.0.1-2.x86_64.rpm 170040 SHA256 9e82fc5110b4f2b08402ac4e0a4391665b7edccaba43df4299f5c48b60faaabb SHA512 457fcfa3ae8291336a127e95dc81e24a2125ae8f861bf74d2006e4d019c54bd351c2480254b9173e52dfe489962dffea2819963596f280e1dc05c527fbf6b625 WHIRLPOOL 362e8030b9c55f12ff56c9883689b8d0d9e5387c55fdcd9b0fbb5ca418b479a081b3bdd845f59ad3381ff52c96fd25d879746786d1b129cc5d1d27f6c358cd65
diff --git a/media-gfx/iscan-plugin-gt-f720/iscan-plugin-gt-f720-0.0.1.2.ebuild b/media-gfx/iscan-plugin-gt-f720/iscan-plugin-gt-f720-0.0.1.2.ebuild
new file mode 100644
index 00000000000..4b94f9ebce9
--- /dev/null
+++ b/media-gfx/iscan-plugin-gt-f720/iscan-plugin-gt-f720-0.0.1.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit multilib versionator rpm
+
+MY_PV="$(get_version_component_range 1-3)"
+MY_PVR="$(replace_version_separator 3 -)"
+MY_P="esci-interpreter-gt-f720-${MY_PVR}"
+
+DESCRIPTION="Epson Perfection V300 PHOTO scanner plugin for SANE 'epkowa' backend"
+HOMEPAGE="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
+SRC_URI="amd64? ( http://dev.gentoo.org/~flameeyes/avasys/${MY_P}.x86_64.rpm )
+ x86? ( http://dev.gentoo.org/~flameeyes/avasys/${MY_P}.i386.rpm )"
+
+LICENSE="AVASYS"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+
+IUSE=""
+IUSE_LINGUAS="ja"
+
+for X in ${IUSE_LINGUAS}; do IUSE="${IUSE} linguas_${X}"; done
+
+DEPEND=">=media-gfx/iscan-2.21.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="usr/lib64/esci/libesci-interpreter-gt-f720.so*"
+
+src_install() {
+ local MY_LIB="/usr/$(get_libdir)"
+
+ # install scanner firmware
+ insinto /usr/share/esci
+ doins "${WORKDIR}/usr/share/esci/"*
+
+ # install docs
+ if use linguas_ja; then
+ dodoc usr/share/doc/*/AVASYSPL.ja.txt
+ else
+ dodoc usr/share/doc/*/AVASYSPL.en.txt
+ fi
+
+ # install scanner plugins
+ insinto "${MY_LIB}/esci"
+ INSOPTIONS="-m0755"
+ doins "${WORKDIR}/usr/$(get_libdir)/esci/"*
+}
+
+pkg_postinst() {
+ local MY_LIB="/usr/$(get_libdir)"
+
+ # Needed for scaner to work properly.
+ iscan-registry --add interpreter usb 0x04b8 0x0131 "${MY_LIB}/esci/libesci-interpreter-gt-f720 /usr/share/esci/esfw8b.bin"
+ elog
+ elog "Firmware file esfw8b.bin for Epson Perfection V300 PHOTO"
+ elog "has been installed in /usr/share/esci and registered for use."
+ elog
+}
+
+pkg_prerm() {
+ local MY_LIB="/usr/$(get_libdir)"
+
+ iscan-registry --remove interpreter usb 0x04b8 0x0131 "${MY_LIB}/esci/libesci-interpreter-gt-f720 /usr/share/esci/esfw8b.bin"
+}
diff --git a/media-gfx/iscan-plugin-gt-f720/iscan-plugin-gt-f720-0.0.1.ebuild b/media-gfx/iscan-plugin-gt-f720/iscan-plugin-gt-f720-0.0.1.ebuild
new file mode 100644
index 00000000000..8bdb3974610
--- /dev/null
+++ b/media-gfx/iscan-plugin-gt-f720/iscan-plugin-gt-f720-0.0.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit multilib rpm
+
+# Revision used by upstream
+SRC_REV="2"
+
+MY_P="esci-interpreter-gt-f720-${PV}"
+
+DESCRIPTION="Epson Perfection V300 PHOTO scanner plugin for SANE 'epkowa' backend"
+HOMEPAGE="http://www.avasys.jp/english/linux_e/dl_scan.html"
+SRC_URI="
+ x86? ( http://linux.avasys.jp/drivers/scanner-plugins/GT-F720/${MY_P}-${SRC_REV}.i386.rpm )
+ amd64? ( http://linux.avasys.jp/drivers/scanner-plugins/GT-F720/${MY_P}-${SRC_REV}.x86_64.rpm )"
+
+LICENSE="AVASYS"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE=""
+IUSE_LINGUAS="ja"
+
+for X in ${IUSE_LINGUAS}; do IUSE="${IUSE} linguas_${X}"; done
+
+DEPEND=">=media-gfx/iscan-2.21.0"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ local MY_LIB="/usr/$(get_libdir)"
+
+ # install scanner firmware
+ insinto /usr/share/esci
+ doins "${WORKDIR}/usr/share/esci/"*
+
+ # install docs
+ if use linguas_ja; then
+ dodoc "usr/share/doc/${MY_P}/AVASYSPL.ja.txt"
+ else
+ dodoc "usr/share/doc/${MY_P}/AVASYSPL.en.txt"
+ fi
+
+ # install scanner plugins
+ insinto "${MY_LIB}/esci"
+ INSOPTIONS="-m0755"
+ doins "${WORKDIR}/usr/$(get_libdir)/esci/"*
+}
+
+pkg_postinst() {
+ local MY_LIB="/usr/$(get_libdir)"
+
+ # Needed for scaner to work properly.
+ iscan-registry --add interpreter usb 0x04b8 0x0131 "${MY_LIB}/esci/libesci-interpreter-gt-f720 /usr/share/esci/esfw8b.bin"
+ elog
+ elog "Firmware file esfw8b.bin for Epson Perfection V300 PHOTO"
+ elog "has been installed in /usr/share/esci and registered for use."
+ elog
+}
+
+pkg_prerm() {
+ local MY_LIB="/usr/$(get_libdir)"
+
+ iscan-registry --remove interpreter usb 0x04b8 0x0131 "${MY_LIB}/esci/libesci-interpreter-gt-f720 /usr/share/esci/esfw8b.bin"
+}
diff --git a/media-gfx/iscan-plugin-gt-f720/metadata.xml b/media-gfx/iscan-plugin-gt-f720/metadata.xml
new file mode 100644
index 00000000000..7e0ae148163
--- /dev/null
+++ b/media-gfx/iscan-plugin-gt-f720/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ Proprietary plugin for several EPSON scanner models with the epkowa SANE backend (provided by media-gfx/iscan).
+ This particular plugin (f720) seems to be required for:
+ Epson GT-F720
+ Epson GT-S620
+ Epson Perfection V30
+ Epson Perfection V300 Photo
+ </longdescription>
+</pkgmetadata>