summaryrefslogtreecommitdiff
path: root/media-gfx/krita/files/krita-3.2.0-tests-optional.patch
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-08-19 23:37:55 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-08-20 00:57:34 +0200
commit3c9eced271b5ac28a569db8e648e24726f3f433e (patch)
treea4e8abd7c42a95e6f9cb0fdb60537ffe17bca3d7 /media-gfx/krita/files/krita-3.2.0-tests-optional.patch
parent3af6d5ea93b0a4ed29677e2f7e6690e3945889c9 (diff)
downloadgentoo-3c9eced271b5ac28a569db8e648e24726f3f433e.tar.gz
gentoo-3c9eced271b5ac28a569db8e648e24726f3f433e.tar.xz
media-gfx/krita: 3.2.0 version bump
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'media-gfx/krita/files/krita-3.2.0-tests-optional.patch')
-rw-r--r--media-gfx/krita/files/krita-3.2.0-tests-optional.patch282
1 files changed, 282 insertions, 0 deletions
diff --git a/media-gfx/krita/files/krita-3.2.0-tests-optional.patch b/media-gfx/krita/files/krita-3.2.0-tests-optional.patch
new file mode 100644
index 00000000000..0f143ff1cc5
--- /dev/null
+++ b/media-gfx/krita/files/krita-3.2.0-tests-optional.patch
@@ -0,0 +1,282 @@
+Autogenerated by KDE_TEST=forceoptional-recursive and edited.
+
+--- a/plugins/paintops/libpaintop/CMakeLists.txt 2017-08-19 23:45:06.235796211 +0200
++++ b/plugins/paintops/libpaintop/CMakeLists.txt 2017-08-19 23:45:06.241796045 +0200
+@@ -95,4 +95,6 @@
+ install(TARGETS kritalibpaintop ${INSTALL_TARGETS_DEFAULT_ARGS})
+
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+--- a/plugins/paintops/defaultpaintops/CMakeLists.txt 2017-08-19 23:45:06.250795797 +0200
++++ b/plugins/paintops/defaultpaintops/CMakeLists.txt 2017-08-19 23:45:06.258795576 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(brush/tests)
++endif()
+
+ include_directories(brush)
+ include_directories(duplicate)
+--- a/plugins/impex/exr/CMakeLists.txt 2017-08-19 23:45:06.266795355 +0200
++++ b/plugins/impex/exr/CMakeLists.txt 2017-08-19 23:45:06.274795134 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ include_directories(SYSTEM ${OPENEXR_INCLUDE_DIR} )
+
+--- a/plugins/impex/jpeg/CMakeLists.txt 2017-08-19 23:45:06.282794913 +0200
++++ b/plugins/impex/jpeg/CMakeLists.txt 2017-08-19 23:45:06.289794720 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(ICCJPEG_SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/3rdparty/lcms")
+
+--- a/plugins/impex/psd/CMakeLists.txt 2017-08-19 23:45:06.297794499 +0200
++++ b/plugins/impex/psd/CMakeLists.txt 2017-08-19 23:45:06.304794306 +0200
+@@ -1,5 +1,7 @@
+ if (NOT MSVC AND NOT APPLE)
+- add_subdirectory(tests)
++ if(BUILD_TESTING)
++ add_subdirectory(tests)
++ endif()
+ endif()
+
+ configure_file(config_psd.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config_psd.h)
+--- a/plugins/impex/ppm/CMakeLists.txt 2017-08-19 23:45:06.313794058 +0200
++++ b/plugins/impex/ppm/CMakeLists.txt 2017-08-19 23:45:06.319793892 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ include_directories( ${CMAKE_CURRENT_SOURCE_DIR} )
+
+--- a/plugins/impex/png/CMakeLists.txt 2017-08-19 23:45:06.327793672 +0200
++++ b/plugins/impex/png/CMakeLists.txt 2017-08-19 23:45:06.334793478 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(kritapngimport_SOURCES
+ kis_png_import.cc
+--- a/plugins/impex/csv/CMakeLists.txt 2017-08-19 23:45:06.343793230 +0200
++++ b/plugins/impex/csv/CMakeLists.txt 2017-08-19 23:45:06.349793064 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ include_directories(SYSTEM
+ ${Boost_INCLUDE_DIRS}
+--- a/plugins/impex/xcf/CMakeLists.txt 2017-08-19 23:45:06.357792843 +0200
++++ b/plugins/impex/xcf/CMakeLists.txt 2017-08-19 23:45:06.364792650 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(XCFTOOLS_SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/3rdparty/xcftools")
+
+--- a/plugins/impex/tiff/CMakeLists.txt 2017-08-19 23:45:06.372792429 +0200
++++ b/plugins/impex/tiff/CMakeLists.txt 2017-08-19 23:45:06.379792236 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(libkritatiffconverter_LIB_SRCS
+ kis_tiff_converter.cc
+--- a/plugins/extensions/qmic/CMakeLists.txt 2017-08-19 23:45:06.387792016 +0200
++++ b/plugins/extensions/qmic/CMakeLists.txt 2017-08-19 23:45:06.393791850 +0200
+@@ -20,4 +20,6 @@
+ target_link_libraries(kritaqmic kritaui)
+ install(TARGETS kritaqmic DESTINATION ${KRITA_PLUGIN_INSTALL_DIR})
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+--- a/plugins/filters/CMakeLists.txt 2017-08-19 23:45:06.401791629 +0200
++++ b/plugins/filters/CMakeLists.txt 2017-08-19 23:45:06.408791436 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+ add_subdirectory( blur )
+ add_subdirectory( colors )
+ add_subdirectory( colorsfilters )
+--- a/plugins/filters/unsharp/CMakeLists.txt 2017-08-19 23:45:06.416791215 +0200
++++ b/plugins/filters/unsharp/CMakeLists.txt 2017-08-19 23:45:06.422791049 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+
+ set(kritaunsharpfilter_SOURCES
+ unsharp.cpp
+--- a/plugins/tools/basictools/CMakeLists.txt 2017-08-19 23:45:06.430790829 +0200
++++ b/plugins/tools/basictools/CMakeLists.txt 2017-08-19 23:45:06.437790636 +0200
+@@ -1,5 +1,7 @@
+ if (NOT APPLE)
+- add_subdirectory(tests)
++ if(BUILD_TESTING)
++ add_subdirectory(tests)
++ endif()
+ endif ()
+
+ include_directories(SYSTEM ${Boost_INCLUDE_DIRS})
+--- a/plugins/tools/tool_transform2/CMakeLists.txt 2017-08-19 23:45:06.446790387 +0200
++++ b/plugins/tools/tool_transform2/CMakeLists.txt 2017-08-19 23:45:06.453790194 +0200
+@@ -1,5 +1,7 @@
+ if (NOT WIN32 AND NOT APPLE)
+- add_subdirectory(tests)
++ if(BUILD_TESTING)
++ add_subdirectory(tests)
++ endif()
+ endif()
+
+ include_directories(SYSTEM ${Boost_INCLUDE_DIRS})
+--- a/plugins/color/lcms2engine/CMakeLists.txt 2017-08-19 23:45:06.461789973 +0200
++++ b/plugins/color/lcms2engine/CMakeLists.txt 2017-08-19 23:45:06.468789780 +0200
+@@ -1,6 +1,8 @@
+ project( lcmsengine )
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ include_directories(SYSTEM
+ ${LCMS2_INCLUDE_DIR}
+--- a/plugins/dockers/defaultdockers/CMakeLists.txt 2017-08-19 23:45:06.476789559 +0200
++++ b/plugins/dockers/defaultdockers/CMakeLists.txt 2017-08-19 23:45:06.483789366 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+
+ set(kritadefaultdockers_SOURCES
+ kis_layer_box.cpp
+--- a/plugins/dockers/animation/CMakeLists.txt 2017-08-19 23:45:06.491789145 +0200
++++ b/plugins/dockers/animation/CMakeLists.txt 2017-08-19 23:45:06.497788980 +0200
+@@ -1,5 +1,7 @@
+ if (NOT WIN32 AND NOT APPLE)
+- add_subdirectory(tests)
++ if(BUILD_TESTING)
++ add_subdirectory(tests)
++ endif()
+ endif()
+
+ include_directories(SYSTEM ${Boost_INCLUDE_DIRS})
+--- a/plugins/dockers/lut/CMakeLists.txt 2017-08-19 23:45:06.506788731 +0200
++++ b/plugins/dockers/lut/CMakeLists.txt 2017-08-19 23:45:06.512788565 +0200
+@@ -1,5 +1,7 @@
+ if (NOT WIN32 AND NOT APPLE)
+- add_subdirectory(tests)
++ if(BUILD_TESTING)
++ add_subdirectory(tests)
++ endif()
+ endif()
+
+ include_directories(SYSTEM
+--- a/libs/store/CMakeLists.txt 2017-08-19 23:45:06.520788345 +0200
++++ b/libs/store/CMakeLists.txt 2017-08-19 23:45:06.527788151 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(kritastore_LIB_SRCS
+ KoDirectoryStore.cpp
+--- a/libs/flake/CMakeLists.txt 2017-08-19 23:45:06.536787903 +0200
++++ b/libs/flake/CMakeLists.txt 2017-08-19 23:45:06.542787737 +0200
+@@ -8,7 +8,9 @@
+ )
+
+ add_subdirectory(styles)
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(kritaflake_SRCS
+ KoGradientHelper.cpp
+--- a/libs/widgetutils/CMakeLists.txt 2017-08-19 23:45:06.550787517 +0200
++++ b/libs/widgetutils/CMakeLists.txt 2017-08-19 23:45:06.557787323 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ configure_file(xmlgui/config-xmlgui.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-xmlgui.h )
+
+--- a/libs/odf/CMakeLists.txt 2017-08-19 23:45:06.565787103 +0200
++++ b/libs/odf/CMakeLists.txt 2017-08-19 23:45:06.572786910 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+
+ set(kritaodf_LIB_SRCS
+ KoOdf.cpp
+--- a/libs/pigment/CMakeLists.txt 2017-08-19 23:45:06.580786689 +0200
++++ b/libs/pigment/CMakeLists.txt 2017-08-19 23:45:06.587786495 +0200
+@@ -34,7 +34,9 @@
+ message(${__per_arch_factory_objs})
+ endif()
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+ add_subdirectory(benchmarks)
+
+ set(kritapigment_SRCS
+--- a/libs/widgets/CMakeLists.txt 2017-08-19 23:45:06.595786275 +0200
++++ b/libs/widgets/CMakeLists.txt 2017-08-19 23:45:06.601786109 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+
+ include_directories(${CMAKE_CURRENT_BINARY_DIR})
+
+--- a/libs/ui/CMakeLists.txt 2017-08-19 23:45:06.610785861 +0200
++++ b/libs/ui/CMakeLists.txt 2017-08-19 23:45:06.617785667 +0200
+@@ -9,7 +9,9 @@
+ ${Boost_INCLUDE_DIRS}
+ )
+
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+
+ if (APPLE)
+ find_library(FOUNDATION_LIBRARY Foundation)
+--- a/libs/image/CMakeLists.txt 2017-08-19 23:45:06.626785419 +0200
++++ b/libs/image/CMakeLists.txt 2017-08-19 23:45:06.632785254 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+
+ add_subdirectory( tiles3 )
+
+--- a/libs/image/tiles3/CMakeLists.txt 2017-08-19 23:45:06.641785005 +0200
++++ b/libs/image/tiles3/CMakeLists.txt 2017-08-19 23:45:06.647784839 +0200
+@@ -1,2 +1,4 @@
+ include_directories(SYSTEM ${Boost_INCLUDE_DIRS})
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+--- a/libs/brush/CMakeLists.txt 2017-08-19 23:45:06.658784536 +0200
++++ b/libs/brush/CMakeLists.txt 2017-08-19 23:45:06.665784343 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+
+ include_directories(SYSTEM
+ ${EIGEN3_INCLUDE_DIR}