summaryrefslogtreecommitdiff
path: root/media-gfx/lximage-qt
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/lximage-qt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/lximage-qt')
-rw-r--r--media-gfx/lximage-qt/Manifest3
-rw-r--r--media-gfx/lximage-qt/lximage-qt-0.2.0.ebuild33
-rw-r--r--media-gfx/lximage-qt/lximage-qt-0.3.0.ebuild47
-rw-r--r--media-gfx/lximage-qt/lximage-qt-0.4.0.ebuild47
-rw-r--r--media-gfx/lximage-qt/metadata.xml9
5 files changed, 139 insertions, 0 deletions
diff --git a/media-gfx/lximage-qt/Manifest b/media-gfx/lximage-qt/Manifest
new file mode 100644
index 00000000000..108898546a8
--- /dev/null
+++ b/media-gfx/lximage-qt/Manifest
@@ -0,0 +1,3 @@
+DIST lximage-qt-0.2.0.tar.xz 41240 SHA256 4750981bbf1a1a36fd581addd8d6acecb608f9660442b6831eb05639151524fb SHA512 238e1fb7795fb2b5d73132fc61942b0277d1c2b7c880f3022e4fabee754a17da013af1907ada001762271ac7ded42efbf4470990bb574d26215ff0276f4a7c16 WHIRLPOOL a09053cfb944518a3879dcf28786ad70a2b7a67cc04d4f2a737d1dadaad846c883b322aa906135f01726cf2266d78d70a94e5e619699b91718faa914787afc37
+DIST lximage-qt-0.3.0.tar.xz 41660 SHA256 0a5a5114eb1014a4e24af17d4a5d77676bac6a5d25458082e8e2eb45c87f2984 SHA512 d5af86b32cb416378f30413c65cd576d7a7f6d88f551e4749b161d64e08984254f4e1eb8f7b897bb5a334eb72b2af1c5de47109f5dd462d66b3b7fe9febc4902 WHIRLPOOL 80aea4cbb37d41a1ec2793de7a0343cd5464d197ad748b0031ac55526d311a9c753b4542428d19fd9e84263e4a1b0716b89d03ba8a86435af063d93643bd4ee1
+DIST lximage-qt-0.4.0.tar.xz 43716 SHA256 11abc99b0946e6254aad42cb3e29349dc6199879be0728418e7bc81200d59730 SHA512 6b07e16534b835da60f5845c801cad0bdd381b6deb79ad99fc44afb9b776deb3cf76c85c9e4b59ba4148d71e894f659743c002ea4baf5589e8d261eb1a19b1fa WHIRLPOOL 7db84a9fe83057ec05a9b363f7c64c0302f9fc9c1f5e62aec84520bd6a481dce709f671fdcfef46f64a89143c34457f8955d05df2641b7b29487eb3056c825ef
diff --git a/media-gfx/lximage-qt/lximage-qt-0.2.0.ebuild b/media-gfx/lximage-qt/lximage-qt-0.2.0.ebuild
new file mode 100644
index 00000000000..57ceb65029d
--- /dev/null
+++ b/media-gfx/lximage-qt/lximage-qt-0.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXImage Image Viewer - GPicView replacement"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+ S=${WORKDIR}
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+RDEPEND="dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-libs/glib:2
+ media-libs/libexif
+ >=x11-libs/libfm-1.2
+ x11-libs/libX11
+ x11-libs/libXfixes
+ x11-misc/pcmanfm-qt"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
diff --git a/media-gfx/lximage-qt/lximage-qt-0.3.0.ebuild b/media-gfx/lximage-qt/lximage-qt-0.3.0.ebuild
new file mode 100644
index 00000000000..da8dfcac34a
--- /dev/null
+++ b/media-gfx/lximage-qt/lximage-qt-0.3.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXImage Image Viewer - GPicView replacement"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-qt/linguist-tools:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-libs/libexif
+ >=x11-libs/libfm-1.2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-misc/pcmanfm-qt"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT5=ON
+ )
+ cmake-utils_src_configure
+}
diff --git a/media-gfx/lximage-qt/lximage-qt-0.4.0.ebuild b/media-gfx/lximage-qt/lximage-qt-0.4.0.ebuild
new file mode 100644
index 00000000000..63cab0c590d
--- /dev/null
+++ b/media-gfx/lximage-qt/lximage-qt-0.4.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXImage Image Viewer - GPicView replacement"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-qt/linguist-tools:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-libs/libexif
+ >=x11-libs/libfm-1.2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-misc/pcmanfm-qt"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT5=ON
+ )
+ cmake-utils_src_configure
+}
diff --git a/media-gfx/lximage-qt/metadata.xml b/media-gfx/lximage-qt/metadata.xml
new file mode 100644
index 00000000000..d89dead0ed8
--- /dev/null
+++ b/media-gfx/lximage-qt/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>lxqt</herd>
+ <maintainer>
+ <email>jauhien@gentoo.org</email>
+ <name>Jauhien Piatlicki</name>
+ </maintainer>
+</pkgmetadata>