summaryrefslogtreecommitdiff
path: root/media-gfx/opcion
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/opcion
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/opcion')
-rw-r--r--media-gfx/opcion/Manifest1
-rw-r--r--media-gfx/opcion/files/opcion-1.1.1-fix-source.patch15
-rw-r--r--media-gfx/opcion/metadata.xml8
-rw-r--r--media-gfx/opcion/opcion-1.1.1-r2.ebuild58
4 files changed, 82 insertions, 0 deletions
diff --git a/media-gfx/opcion/Manifest b/media-gfx/opcion/Manifest
new file mode 100644
index 00000000000..587716dff1d
--- /dev/null
+++ b/media-gfx/opcion/Manifest
@@ -0,0 +1 @@
+DIST Opcion_v1.1.1_src.zip 319793 SHA256 f1af9606c63e200d860d01c2f7bd241031b857928b939fb8044d27aabf83f298
diff --git a/media-gfx/opcion/files/opcion-1.1.1-fix-source.patch b/media-gfx/opcion/files/opcion-1.1.1-fix-source.patch
new file mode 100644
index 00000000000..4c5f1dc9c9e
--- /dev/null
+++ b/media-gfx/opcion/files/opcion-1.1.1-fix-source.patch
@@ -0,0 +1,15 @@
+--- FontViewer/components/AAToggleButton.java 2007-04-29 12:20:16.000000000 +0200
++++ FontViewer/components/AAToggleButton.java 2007-04-29 12:10:53.000000000 +0200
+@@ -38,7 +38,11 @@
+ this.setToolTipText(fname + " (" + floc + ")");
+ }
+
+- public String getFName() {
++ public AAToggleButton(String s) {
++ super(s);
++ }
++
++ public String getFName() {
+ return fname;
+ }
+
diff --git a/media-gfx/opcion/metadata.xml b/media-gfx/opcion/metadata.xml
new file mode 100644
index 00000000000..4a2bc1931f5
--- /dev/null
+++ b/media-gfx/opcion/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>fonts</herd>
+ <upstream>
+ <remote-id type="sourceforge">opcion</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-gfx/opcion/opcion-1.1.1-r2.ebuild b/media-gfx/opcion/opcion-1.1.1-r2.ebuild
new file mode 100644
index 00000000000..babe77b7fa4
--- /dev/null
+++ b/media-gfx/opcion/opcion-1.1.1-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils java-pkg-2
+
+MY_P="Opcion_v${PV}"
+
+DESCRIPTION="Free font viewer written in Java"
+HOMEPAGE="http://opcion.sourceforge.net/"
+SRC_URI="mirror://sourceforge/opcion/${MY_P}_src.zip"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+COMMON_DEP="=dev-java/jgoodies-looks-1.2*"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEP}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # add missing constructor
+ epatch "${FILESDIR}/${P}-fix-source.patch"
+
+ # calls nonexisting constructor and seems unused
+ rm FontViewer/windows/test.java || die
+
+ rm -rf com/jgoodies || die
+ find . -name '*.class' -delete || die
+ rm *.txt || die
+}
+
+src_compile() {
+ find . -name '*.java' > "${T}/src.list"
+ local cp="$(java-pkg_getjars jgoodies-looks-1.2)"
+ mkdir build || die
+ # quite icky way to copy resources
+ cp -R FontViewer com build || die
+ find build -name '*.java' -delete
+ ejavac -nowarn -classpath "${cp}" -d build "@${T}/src.list"
+ jar cf ${PN}.jar -C build . || die
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+
+ java-pkg_dolauncher ${PN} --main FontViewer.Opcion
+
+ newicon FontViewer/resources/icons/IconSmall.png ${PN}-icon.png
+ make_desktop_entry ${PN} opcion ${PN}-icon
+}