summaryrefslogtreecommitdiff
path: root/media-gfx/phototonic
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/phototonic
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/phototonic')
-rw-r--r--media-gfx/phototonic/Manifest2
-rw-r--r--media-gfx/phototonic/metadata.xml12
-rw-r--r--media-gfx/phototonic/phototonic-1.5.54.ebuild36
-rw-r--r--media-gfx/phototonic/phototonic-1.6.6.ebuild36
4 files changed, 86 insertions, 0 deletions
diff --git a/media-gfx/phototonic/Manifest b/media-gfx/phototonic/Manifest
new file mode 100644
index 00000000000..1092dab6ba3
--- /dev/null
+++ b/media-gfx/phototonic/Manifest
@@ -0,0 +1,2 @@
+DIST phototonic-1.5.54.tar.xz 160716 SHA256 a84ec02cd03635fd5f2b19deea46eec0c74e6f9fabb24943fcf37bbece1c214e SHA512 a4ce914503a8452bb6d2a2c97cef6c5b4b69e0d8c5a349bd5a68680731b3a9e70a9afa7ff63cb2836aa8d970f074b058627687fa7cdcfb898da13c696c2d6df7 WHIRLPOOL a17369097cdf5ec9efac2cefaee582aafbdbfee0a22ee8395c2824aa16913c10c929e8359fcd70d508400e85d4f30b25fcba7b176fc135a29b43d0e009080883
+DIST phototonic-1.6.6.tar.xz 166448 SHA256 52b11420f2da6637f7b570029f6f6a8052277631e74bb80ad97be47a50c485a3 SHA512 ce1766b120ae27dacd34219943eec092385713e187415a65e59f1d0b94942266b02686377000be07a3a0ad2a0d4d4f19753d150ee6bf3c1ca85fa224eac6ebfd WHIRLPOOL 822c3248d0d1b4e5f3e3a7eec15e11aea598ebb43550601e5483cd6516c42cfd7ae04c79273766c117fc525b837b29a8546a8f272b4d5761e2957e9e6275cc80
diff --git a/media-gfx/phototonic/metadata.xml b/media-gfx/phototonic/metadata.xml
new file mode 100644
index 00000000000..56722af239a
--- /dev/null
+++ b/media-gfx/phototonic/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <maintainer>
+ <email>yngwin@gentoo.org</email>
+ <name>Ben de Groot</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">oferkv/phototonic</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-gfx/phototonic/phototonic-1.5.54.ebuild b/media-gfx/phototonic/phototonic-1.5.54.ebuild
new file mode 100644
index 00000000000..cc3f4daaba7
--- /dev/null
+++ b/media-gfx/phototonic/phototonic-1.5.54.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit qmake-utils
+
+DESCRIPTION="Image viewer and organizer"
+HOMEPAGE="http://oferkv.github.io/phototonic/"
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/oferkv/phototonic.git"
+else
+ SRC_URI="http://dev.gentoo.org/~yngwin/distfiles/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="svg tiff"
+
+RDEPEND="dev-qt/qtwidgets:5
+ dev-qt/qtgui:5
+ dev-qt/qtcore:5
+ media-gfx/exiv2:=
+ svg? ( dev-qt/qtsvg:5 )
+ tiff? ( dev-qt/qtimageformats:5 )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+}
diff --git a/media-gfx/phototonic/phototonic-1.6.6.ebuild b/media-gfx/phototonic/phototonic-1.6.6.ebuild
new file mode 100644
index 00000000000..cc3f4daaba7
--- /dev/null
+++ b/media-gfx/phototonic/phototonic-1.6.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit qmake-utils
+
+DESCRIPTION="Image viewer and organizer"
+HOMEPAGE="http://oferkv.github.io/phototonic/"
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/oferkv/phototonic.git"
+else
+ SRC_URI="http://dev.gentoo.org/~yngwin/distfiles/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="svg tiff"
+
+RDEPEND="dev-qt/qtwidgets:5
+ dev-qt/qtgui:5
+ dev-qt/qtcore:5
+ media-gfx/exiv2:=
+ svg? ( dev-qt/qtsvg:5 )
+ tiff? ( dev-qt/qtimageformats:5 )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+}