summaryrefslogtreecommitdiff
path: root/media-libs/SoQt
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/SoQt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/SoQt')
-rw-r--r--media-libs/SoQt/Manifest1
-rw-r--r--media-libs/SoQt/SoQt-1.5.0-r1.ebuild58
-rw-r--r--media-libs/SoQt/files/SoQt-1.4.1-gcc44.patch22
-rw-r--r--media-libs/SoQt/files/SoQt-1.5.0-pkgconfig-partial.patch13
-rw-r--r--media-libs/SoQt/metadata.xml7
5 files changed, 101 insertions, 0 deletions
diff --git a/media-libs/SoQt/Manifest b/media-libs/SoQt/Manifest
new file mode 100644
index 00000000000..d3653c1ae2c
--- /dev/null
+++ b/media-libs/SoQt/Manifest
@@ -0,0 +1 @@
+DIST SoQt-1.5.0.tar.gz 1515230 SHA256 f6a34b4c19e536c00f21aead298cdd274a7a0b03a31826fbe38fc96f3d82ab91 SHA512 e65596bf466b56aa0d7c4f367b250ba3a77094cf1a529c1e2a199b8b91106ab8954873ddfc9f9cd7ff359c0f82e6bbf32d30e78e3fb92733490937e477890a0b WHIRLPOOL 17d2701963f18fae04eb110d39e6ecff6ab0a8cc8d0a07c7d083fb8995d86ded74f32450ba5940131c2379a4d6adc33e13ebef54f98dfe455fee6ee08ca40aab
diff --git a/media-libs/SoQt/SoQt-1.5.0-r1.ebuild b/media-libs/SoQt/SoQt-1.5.0-r1.ebuild
new file mode 100644
index 00000000000..f3dfa7afb47
--- /dev/null
+++ b/media-libs/SoQt/SoQt-1.5.0-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="The glue between Coin3D and Qt"
+SRC_URI="http://ftp.coin3d.org/coin/src/all/${P}.tar.gz"
+HOMEPAGE="http://www.coin3d.org/"
+
+LICENSE="|| ( GPL-2 PEL )"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="debug doc static-libs"
+
+RDEPEND="
+ >=media-libs/coin-3.1.3
+ virtual/opengl
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.5.0-pkgconfig-partial.patch"
+)
+
+DOCS=(AUTHORS ChangeLog FAQ HACKING NEWS README)
+
+src_configure() {
+ local myeconfargs=(
+ htmldir="/usr/share/doc/${PF}/html"
+ --disable-compact
+ --disable-html-help
+ --disable-loadlibrary
+ --disable-man
+ --enable-pkgconfig
+ --includedir="/usr/include/coin"
+ --with-coin
+ $(use_enable debug)
+ $(use_enable debug symbols)
+ $(use_enable doc html)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ # Remove SoQt from Libs.private
+ sed -e '/Libs.private/s/ -lSoQt//' -i "${BUILD_DIR}"/SoQt.pc || die
+
+ autotools-utils_src_install
+}
diff --git a/media-libs/SoQt/files/SoQt-1.4.1-gcc44.patch b/media-libs/SoQt/files/SoQt-1.4.1-gcc44.patch
new file mode 100644
index 00000000000..f8777b037c5
--- /dev/null
+++ b/media-libs/SoQt/files/SoQt-1.4.1-gcc44.patch
@@ -0,0 +1,22 @@
+diff -ru soqt-1.4.1~/src/Inventor/Qt/SoQtComponent.cpp soqt-1.4.1/src/Inventor/Qt/SoQtComponent.cpp
+--- soqt-1.4.1~/src/Inventor/Qt/SoQtComponent.cpp 2009-02-25 07:55:02.000000000 -0800
++++ soqt-1.4.1/src/Inventor/Qt/SoQtComponent.cpp 2009-02-25 07:56:36.000000000 -0800
+@@ -100,10 +100,17 @@
+ this->parent->removeEventFilter(this);
+ }
+
++#if COIN_MAJOR_VERSION >= 3
++static void delete_dict_value(SbDict::Key key, void * value)
++{
++ delete (QCursor *)value;
++}
++#else // COIN_MAJOR_VERSION >= 3
+ static void delete_dict_value(unsigned long key, void * value)
+ {
+ delete (QCursor *)value;
+ }
++#endif // COIN_MAJOR_VERSION < 3
+
+ void
+ SoQtComponentP::atexit_cleanup()
+
diff --git a/media-libs/SoQt/files/SoQt-1.5.0-pkgconfig-partial.patch b/media-libs/SoQt/files/SoQt-1.5.0-pkgconfig-partial.patch
new file mode 100644
index 00000000000..ff55a03aed4
--- /dev/null
+++ b/media-libs/SoQt/files/SoQt-1.5.0-pkgconfig-partial.patch
@@ -0,0 +1,13 @@
+diff -ruN SoQt-1.5.0/SoQt.pc.in my/SoQt.pc.in
+--- SoQt-1.5.0/SoQt.pc.in 2010-03-02 23:57:41.000000000 +0100
++++ my/SoQt.pc.in 2013-05-28 01:14:13.083619183 +0200
+@@ -10,7 +10,8 @@
+ Version: @SOQT_VERSION@
+ Requires: Coin
+ Conflicts:
+-Libs: -L${libdir} @SOGUI_EXTRA_LDFLAGS@ @SOGUI_EXTRA_LIBS@
++Libs: -L${libdir} -lSoQt
++Libs.private: -L${libdir} @SOGUI_EXTRA_LIBS@
+ Cflags: -I${includedir} @SOGUI_EXTRA_CFLAGS@ @SOGUI_EXTRA_CPPFLAGS@
+
+ soqt_host=@host@
diff --git a/media-libs/SoQt/metadata.xml b/media-libs/SoQt/metadata.xml
new file mode 100644
index 00000000000..e6b9e2af139
--- /dev/null
+++ b/media-libs/SoQt/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>reavertm@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>