summaryrefslogtreecommitdiff
path: root/media-libs/SoXt
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/SoXt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/SoXt')
-rw-r--r--media-libs/SoXt/Manifest1
-rw-r--r--media-libs/SoXt/SoXt-1.3.0.ebuild52
-rw-r--r--media-libs/SoXt/files/SoXt-1.3.0-pkgconfig-partial.patch12
-rw-r--r--media-libs/SoXt/metadata.xml15
4 files changed, 80 insertions, 0 deletions
diff --git a/media-libs/SoXt/Manifest b/media-libs/SoXt/Manifest
new file mode 100644
index 00000000000..275c2d43e86
--- /dev/null
+++ b/media-libs/SoXt/Manifest
@@ -0,0 +1 @@
+DIST SoXt-1.3.0.tar.gz 1203903 SHA256 f5443aadafe8e2222b9b5a23d1f228bb0f3e7d98949b8ea8676171b7ea5bf013 SHA512 1aae8c6d0b5e8de52734dac0326f9bcbae343a1819d18bb915f8f6fa223782e3512286819af62f494ce5238b8e1d981af5322186b2c07a94be20b7c9d32db208 WHIRLPOOL 3f89ffe061844da1fc5f6ce26beb9f69480791a6dfbc8d13869e7a0a07d4b7933180a8f0d35f0ceb3b1a6674d98901db6d3803c5f6991b9de4a1395f846019fa
diff --git a/media-libs/SoXt/SoXt-1.3.0.ebuild b/media-libs/SoXt/SoXt-1.3.0.ebuild
new file mode 100644
index 00000000000..0618ea5e197
--- /dev/null
+++ b/media-libs/SoXt/SoXt-1.3.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+HOMEPAGE="http://www.coin3d.org/"
+DESCRIPTION="GUI binding for using Coin/Open Inventor with Xt/Motif"
+SRC_URI="https://bitbucket.org/Coin3D/coin/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="debug doc static-libs"
+
+RDEPEND="
+ >=media-libs/coin-3.1.3
+ x11-libs/motif:0
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.3.0-pkgconfig-partial.patch"
+)
+
+DOCS=(AUTHORS ChangeLog HACKING NEWS README TODO BUGS.txt)
+
+src_configure() {
+ local myeconfargs=(
+ htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ --disable-compact
+ --disable-html-help
+ --includedir="$(coin-config --includedir)"
+ --with-coin
+ --with-motif
+ $(use_enable debug)
+ $(use_enable debug profile)
+ $(use_enable doc html)
+ $(use_enable doc man)
+ )
+ autotools-utils_src_configure
+ # Remove SoXt from Libs.private (patch installs it in Libs)
+ sed -i -e '/Libs.private/s/ -lSoXt//' "${BUILD_DIR}"/SoXt.pc || die
+ # Strip the default libdir
+ sed -i -e "s,-L%{_libdir} ,," soxt-default.cfg
+ # soxt-config is arch dependent
+ sed -i -e "s,/share/Coin/conf/,/%{_lib}/Coin2/conf/,g" soxt-config
+}
diff --git a/media-libs/SoXt/files/SoXt-1.3.0-pkgconfig-partial.patch b/media-libs/SoXt/files/SoXt-1.3.0-pkgconfig-partial.patch
new file mode 100644
index 00000000000..397d223b615
--- /dev/null
+++ b/media-libs/SoXt/files/SoXt-1.3.0-pkgconfig-partial.patch
@@ -0,0 +1,12 @@
+--- SoXt.pc.in.orig 2013-06-17 11:26:59.998321839 -0700
++++ SoXt.pc.in 2013-06-17 11:28:01.603654611 -0700
+@@ -10,7 +10,8 @@
+ Version: @SOXT_VERSION@
+ Requires: Coin
+ Conflicts:
+-Libs: -L${libdir} @SOGUI_EXTRA_LDFLAGS@ @SOGUI_EXTRA_LIBS@
++Libs: -L${libdir} -lSoXt
++Libs.private: -L${libdir} @SOGUI_EXTRA_LIBS@
+ Cflags: -I${includedir} @SOGUI_EXTRA_CFLAGS@ @SOGUI_EXTRA_CPPFLAGS@
+
+ soxt_host=@host@
diff --git a/media-libs/SoXt/metadata.xml b/media-libs/SoXt/metadata.xml
new file mode 100644
index 00000000000..9aaf70cc460
--- /dev/null
+++ b/media-libs/SoXt/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-physics</herd>
+<maintainer>
+ <email>sci-physics@gentoo.org</email>
+ <description>Feel free to maintain/fix</description>
+</maintainer>
+<longdescription lang='en'>
+ SoXt is an alternative to SGIs InventorXt library, which is a GUI
+ binding for using Open Inventor with Xt/Motif. While SoXt has been developed
+ for use with Coin, it is also possible to compile it against Open Inventor
+ from SGI or TGS.
+</longdescription>
+</pkgmetadata>