summaryrefslogtreecommitdiff
path: root/media-libs/aften
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/aften
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/aften')
-rw-r--r--media-libs/aften/Manifest1
-rw-r--r--media-libs/aften/aften-0.0.8.ebuild34
-rw-r--r--media-libs/aften/files/aften-0.0.8-multilib.patch13
-rw-r--r--media-libs/aften/files/aften-0.0.8-ppc.patch97
-rw-r--r--media-libs/aften/metadata.xml13
5 files changed, 158 insertions, 0 deletions
diff --git a/media-libs/aften/Manifest b/media-libs/aften/Manifest
new file mode 100644
index 00000000000..f39996af57e
--- /dev/null
+++ b/media-libs/aften/Manifest
@@ -0,0 +1 @@
+DIST aften-0.0.8.tar.bz2 80865 SHA256 87cc847233bb92fbd5bed49e2cdd6932bb58504aeaefbfd20ecfbeb9532f0c0a SHA512 1261297eac5065c6f028618d3e15e9b152ac35440c74cfb09d98cd99a90fb1c6a49585f70928834c3f6ddbcdd1d8721f7329d24f57cd30901dff09bbc0d419e3 WHIRLPOOL c47442eb3aa978972c5185b637de39a80bd3910934097d31dbcd3e24348c59c9ed99980fd276f0b9e1c0dc90c07e591d4d057ac9bcb4f460806984e1558c1350
diff --git a/media-libs/aften/aften-0.0.8.ebuild b/media-libs/aften/aften-0.0.8.ebuild
new file mode 100644
index 00000000000..55e48c2b31a
--- /dev/null
+++ b/media-libs/aften/aften-0.0.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="An A/52 (AC-3) audio encoder"
+HOMEPAGE="http://aften.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1 BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="cxx"
+
+PATCHES=(
+ "${FILESDIR}/${P}-multilib.patch"
+ "${FILESDIR}/${P}-ppc.patch"
+)
+
+src_configure() {
+ local mycmakeargs="-DSHARED=1"
+ use cxx && mycmakeargs+=" -DBINDINGS_CXX=1"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc README Changelog
+ # File collision with media-sound/wavbreaker, upstream informed
+ mv "${D}/usr/bin/wavinfo" "${D}/usr/bin/wavinfo-aften" || die
+}
diff --git a/media-libs/aften/files/aften-0.0.8-multilib.patch b/media-libs/aften/files/aften-0.0.8-multilib.patch
new file mode 100644
index 00000000000..f09b8dc5bb1
--- /dev/null
+++ b/media-libs/aften/files/aften-0.0.8-multilib.patch
@@ -0,0 +1,13 @@
+Index: aften-0.0.8/CMakeLists.txt
+===================================================================
+--- aften-0.0.8.orig/CMakeLists.txt
++++ aften-0.0.8/CMakeLists.txt
+@@ -305,6 +305,6 @@ ENDIF(BINDINGS_CXX)
+
+ INSTALL(TARGETS ${INSTALL_TARGETS} aften_exe wavinfo wavrms wavfilter
+ RUNTIME DESTINATION bin
+- LIBRARY DESTINATION lib
+- ARCHIVE DESTINATION lib)
++ LIBRARY DESTINATION lib${LIB_SUFFIX}
++ ARCHIVE DESTINATION lib${LIB_SUFFIX})
+ INSTALL(FILES ${INSTALL_HEADERS} libaften/aften.h libaften/aften-types.h DESTINATION include/aften)
diff --git a/media-libs/aften/files/aften-0.0.8-ppc.patch b/media-libs/aften/files/aften-0.0.8-ppc.patch
new file mode 100644
index 00000000000..a841acf8f56
--- /dev/null
+++ b/media-libs/aften/files/aften-0.0.8-ppc.patch
@@ -0,0 +1,97 @@
+Index: libaften/ppc/ppc_cpu_caps.h
+===================================================================
+--- libaften/ppc/ppc_cpu_caps.h
++++ libaften/ppc/ppc_cpu_caps.h
+@@ -20,6 +20,7 @@
+ #ifndef PPC_CPU_CAPS_H
+ #define PPC_CPU_CAPS_H
+
++#include "aften-types.h"
+ #include "common.h"
+ #include "cpu_caps.h"
+
+Index: libaften/ppc/mdct_altivec.c
+===================================================================
+--- libaften/ppc/mdct_altivec.c (revision 659)
++++ libaften/ppc/mdct_altivec.c (revision 660)
+@@ -47,11 +47,11 @@
+ #include "mem.h"
+
+ // sign change constants
+-static const vec_u32_t vPNNP = (vec_u32_t)
++static const vec_u32_t vPNNP = VEC_U32
+ (0x00000000, 0x80000000, 0x80000000, 0x00000000);
+-static const vec_u32_t vPNPN = (vec_u32_t)
++static const vec_u32_t vPNPN = VEC_U32
+ (0x00000000, 0x80000000, 0x00000000, 0x80000000);
+-static const vec_u32_t vNNNN = (vec_u32_t)
++static const vec_u32_t vNNNN = VEC_U32
+ (0x80000000, 0x80000000, 0x80000000, 0x80000000);
+
+
+@@ -92,7 +92,7 @@
+ vec_u8_t perm1036 = VPERMUTE4(1, 0, 3, 6);
+ vec_u8_t perm5472 = VPERMUTE4(5, 4, 7, 2);
+ vector float zero = (vector float) vec_splat_u32(0);
+- vector float pi2_8 = (vector float)(AFT_PI2_8, AFT_PI2_8, AFT_PI2_8, AFT_PI2_8);
++ vector float pi2_8 = VEC_FLOAT(AFT_PI2_8, AFT_PI2_8, AFT_PI2_8, AFT_PI2_8);
+ vector float x0to3, x4to7, x8to11, x12to15;
+ vector float v1, v2, v3, v4, v5;
+
+@@ -143,7 +143,7 @@
+ vec_u8_t perm0022 = VPERMUTE4(0, 0, 2, 2);
+ vec_u8_t perm1405 = VPERMUTE4(1, 4, 0, 5);
+ vector float zero = (vector float) vec_splat_u32(0);
+- vector float cpi = (vector float) (AFT_PI2_8, AFT_PI2_8, AFT_PI1_8, AFT_PI3_8);
++ vector float cpi = VEC_FLOAT(AFT_PI2_8, AFT_PI2_8, AFT_PI1_8, AFT_PI3_8);
+ vec_u32_t vNPNP = vec_sld(vPNPN, vPNPN, 4);
+ vector float x0to3, x4to7, x8to11, x12to15, x16to19, x20to23, x24to27, x28to31;
+ vector float pi3122, pi1322, pi1313, pi3131;
+@@ -395,7 +395,7 @@
+ vec_u8_t perm3636 = vec_add(perm1414, vec_splat_u8(8));
+ vec_u8_t perm2266, perm3377;
+
+- vector float point5 = (vector float) (0.5f, 0.5f, 0.5f, 0.5f);
++ vector float point5 = VEC_FLOAT(0.5f, 0.5f, 0.5f, 0.5f);
+ vector float zero = (vector float) vec_splat_u32(0);
+ vec_u32_t vNPNP = vec_sld(vPNPN, vPNPN, 4);
+
+Index: libaften/ppc/altivec_common.h
+===================================================================
+--- libaften/ppc/altivec_common.h (revision 659)
++++ libaften/ppc/altivec_common.h (revision 660)
+@@ -28,11 +28,23 @@
+ typedef vector unsigned int vec_u32_t;
+ typedef vector signed int vec_s32_t;
+
++#if defined( __APPLE_CC__ ) && defined( __APPLE_ALTIVEC__ ) /* apple */
++#define VEC_U32(a,b,c,d) (vec_u32_t) (a, b, c, d)
++#define VEC_FLOAT(a,b,c,d) (vector float) (a, b, c, d)
+ #define VPERMUTE4(a,b,c,d) (vec_u8_t) \
+ ( (a*4)+0, (a*4)+1, (a*4)+2, (a*4)+3, \
+ (b*4)+0, (b*4)+1, (b*4)+2, (b*4)+3, \
+ (c*4)+0, (c*4)+1, (c*4)+2, (c*4)+3, \
+ (d*4)+0, (d*4)+1, (d*4)+2, (d*4)+3 )
++#else /* gnu */
++#define VEC_U32(a,b,c,d) {a, b, c, d}
++#define VEC_FLOAT(a,b,c,d) {a, b, c, d}
++#define VPERMUTE4(a,b,c,d) \
++ { (a*4)+0, (a*4)+1, (a*4)+2, (a*4)+3, \
++ (b*4)+0, (b*4)+1, (b*4)+2, (b*4)+3, \
++ (c*4)+0, (c*4)+1, (c*4)+2, (c*4)+3, \
++ (d*4)+0, (d*4)+1, (d*4)+2, (d*4)+3 }
++#endif
+
+ static inline vector float vec_ld_float(const float *a)
+ {
+--- ppc_cpu_caps.bak 2007-12-23 17:13:33.000000000 +0000
++++ libaften/ppc/ppc_cpu_caps.c 2007-12-23 17:13:43.000000000 +0000
+@@ -81,7 +81,7 @@
+ //Attempt to use AltiVec
+ if(!sigsetjmp(g_env, 0))
+ {
+- asm volatile ( "vor v0, v0, v0" );
++ asm volatile ( "vor 0, 0, 0" );
+ }
+
+ //Restore the old signal handler
diff --git a/media-libs/aften/metadata.xml b/media-libs/aften/metadata.xml
new file mode 100644
index 00000000000..27e3137c34a
--- /dev/null
+++ b/media-libs/aften/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <longdescription lang="en">
+ Aften is an audio encoder which generates compressed audio streams based
+ on ATSC A/52 specification. This type of audio is also known as AC-3 or
+ Dolby® Digital and is one of the audio codecs used in DVD-Video content.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">aften</remote-id>
+ </upstream>
+</pkgmetadata>