summaryrefslogtreecommitdiff
path: root/media-libs/assimp
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/assimp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/assimp')
-rw-r--r--media-libs/assimp/Manifest2
-rw-r--r--media-libs/assimp/assimp-3.0.1270.ebuild36
-rw-r--r--media-libs/assimp/assimp-3.1.1.ebuild39
-rw-r--r--media-libs/assimp/metadata.xml15
4 files changed, 92 insertions, 0 deletions
diff --git a/media-libs/assimp/Manifest b/media-libs/assimp/Manifest
new file mode 100644
index 00000000000..521b94e8e4f
--- /dev/null
+++ b/media-libs/assimp/Manifest
@@ -0,0 +1,2 @@
+DIST assimp--3.0.1270-source-only.zip 4042147 SHA256 ac29beb596db97df57451a5503afaf2d8b4366522842a6914da89644927a1423 SHA512 0c23e4eafbd2ff5eb6371b9a3b83ea2b0ef65110f6091a4e63e28b83a6dd1939f1f03607ad002cb5e9a632b821f65d1cc78b63d7792f45ed186071ef0a7ab820 WHIRLPOOL 9f32ea8b3c54ca7efd4a1c57300571bedb7f527bf630aa7203636c297acc53e6fbebf482069e76e833a1eb6317fa313c3d78ad4e6a68db4dd82a466b136f8d38
+DIST assimp-3.1.1.zip 32869052 SHA256 3b8d16eaf6c4b26479295f4f7436388bee1e42e8c0b11f6f695b7194985eb00e SHA512 c466d312c0db53fa31b5d1e9b0f65e547a82fb28b1df0a6a96f0dcd876b636a6883d9d705d325193acc58910272b5f158ba37d824ecad29eccf7cf5731697527 WHIRLPOOL 238a79a7e2c7ce799dc89394043962456af06eb8b6ed105893512cb751919287c70c88030b03832ba2f3e6ea54d82db4e8d6009629bb7ed3f3e5e6df78bbd6c6
diff --git a/media-libs/assimp/assimp-3.0.1270.ebuild b/media-libs/assimp/assimp-3.0.1270.ebuild
new file mode 100644
index 00000000000..e84b1c28237
--- /dev/null
+++ b/media-libs/assimp/assimp-3.0.1270.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils versionator
+
+DESCRIPTION="Importer library to import assets from 3D files"
+HOMEPAGE="http://assimp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}--${PV}-source-only.zip"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="+boost samples static tools"
+SLOT="0"
+
+DEPEND="
+ boost? ( dev-libs/boost )
+ samples? ( x11-libs/libX11 virtual/opengl media-libs/freeglut )
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}--${PV}-source-only
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build samples ASSIMP_SAMPLES) \
+ $(cmake-utils_use_build tools ASSIMP_TOOLS) \
+ $(cmake-utils_use_build static STATIC_LIB) \
+ $(cmake-utils_use_enable !boost BOOST_WORKAROUND)
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/media-libs/assimp/assimp-3.1.1.ebuild b/media-libs/assimp/assimp-3.1.1.ebuild
new file mode 100644
index 00000000000..f1b0c879200
--- /dev/null
+++ b/media-libs/assimp/assimp-3.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils versionator
+
+DESCRIPTION="Importer library to import assets from 3D files"
+HOMEPAGE="http://assimp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+boost samples static tools"
+SLOT="0"
+
+DEPEND="
+ boost? ( dev-libs/boost )
+ samples? ( x11-libs/libX11 virtual/opengl media-libs/freeglut )
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e 's/ASSIMP_LIB_INSTALL_DIR "lib"/ASSIMP_LIB_INSTALL_DIR ${CMAKE_INSTALL_LIBDIR}/' CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build samples ASSIMP_SAMPLES) \
+ $(cmake-utils_use_build tools ASSIMP_TOOLS) \
+ $(cmake-utils_use_build static STATIC_LIB) \
+ $(cmake-utils_use_enable !boost BOOST_WORKAROUND)
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/media-libs/assimp/metadata.xml b/media-libs/assimp/metadata.xml
new file mode 100644
index 00000000000..82ecba06b26
--- /dev/null
+++ b/media-libs/assimp/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>slis@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="boost">Build assimp with boost support</flag>
+ <flag name="samples">Build viewer library</flag>
+ <flag name="tools">Build assimp tool binary</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">assimp</remote-id>
+ </upstream>
+</pkgmetadata>